Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11715 closed defect (duplicate)

custom images don't boot on Asus WL-500g

Reported by: tachemihai@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: Cc:

Description

Images built with the Image Builder or compiled from scratch don't boot on Asus WL-500g (no premium, no deluxe).
The pre-built image for brcm47xx 10.03.1 works but I need to build my own custom image.
After power-on the power led stays on indefinitely and it should turn off and come back on when the boot process is over.
I tried flashing with mtd / sysupgrade or directly by TFTP.
I tried using the prebuilt 10.03.1 Image Generator and various recent trunk builds.
Could there be something wrong with the toolchain? How come the prebuilt image works?

The system I'm cross-compiling on is CentOS 5.5 x64. On the same system and buildroot I have successfully built numerous images for other routers.
I have tried building very small base images w/o wifi, it's not due to image size. WL500g doesn't have a serial console so I can't tell what's wrong.
I even tried building a brcm24 image with the 10.03.1 Image Builder and it doesn't boot.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by anonymous

New information:
I tried uncompressing different trx images with firmware-mod-kit.
The official brcm47xx 10.03.1 image is uncompressed successfully but any other custom built image fails with "Firmware extraction failed!". So it seems that there really is something wrong/different with the trx images generated by the toolchain and the Image Builder.

Is there something wrong with by system? I flashed different routers with custom images built on the same system and toolchain recently and had no issues.

comment:2 Changed 6 years ago by anonymous

Ok, please disregard the last comment, that tool failed because now the SquashFS image is XZ compressed instead of lzma. BTW, I tried disabling XZ and built an image with a lzma compressed SquashFS root partition and still no success.
TRX files and loader are fine.
How can I determine if this is the result of the kernel not loading/executing properly? Or how can I confirm that the kernel is OK and then look further into rootfs and it's contents?

comment:3 Changed 5 years ago by anonymous

Official 12.09-beta trx doesn't boot, same symptoms.

comment:4 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.