Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11674 closed defect (fixed)

brcm47xx (wrt54g3gv2) - incorrect detect platform

Reported by: dove@… Owned by: hauke
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: wrt54g3gv2 Cc:

Description

In trunk r32104 incorrect detect platform at Linksys wrt54g3gv2.

 dmesg |grep diag
[    4.324000] diag: Detected 'Linksys WRTSL54GS'

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

Could you provide the nvram content of your device.

comment:2 Changed 5 years ago by noreginos@…

I've the same problem with 12.09-rc1.
System installed yesterday (7 Dec 2012), from official bin.
Could it be the reason why I can't control LEDs (/sys/class/leds/ is empty, in /proc/diag/led/ there's only dmz, power, ses_orange, ses_white) from default (I'm just starting with leds, and haven't installed any additional package for this)?
Here's mine nvram:
root@OpenWrt:~# nvram show | sort
aa0=3
ag0=255
boardflags=0x0018
boardnum=42
boardrev=0x10
boardtype=0x042f
boot_from=1
boot_hw_model=WRT54G3GV2-VF
boot_hw_ver=1.0
boot_ver=v5.5
boot_wait=off
bootnv_ver=3
ccode=0
cctl=0
clkfreq=264
dl_ram_addr=a0001000
et0macaddr=00:23:69:61:E9:E7
et0mdcport=0
et0phyaddr=30
et1macaddr=00:90:4C:60:00:2B
et1mdcport=1
et1phyaddr=5
il0macaddr=00:23:69:61:e9:e9
image_status=IMG_SAME
lan_ipaddr=192.168.1.1
lan_netmask=255.255.255.0
led_dual_led=on
led_gpio2=2
led_gpio3=3
led_gpio4=4
mfg_wait=on
opo=0x0
os_flash_addr=bfc40000
os_ram_addr=80001000
pa0b0=0x170c
pa0b1=0xfa24
pa0b2=0xfe70
pa0itssit=62
pa0maxpwr=0x48
pci/1/1/aa0=0x03
pci/1/1/ag0=0x02
pci/1/1/boardflags=0xe248
pci/1/1/boardrev=0x40
pci/1/1/boardtype=0x449
pci/1/1/ccode=0
pci/1/1/devid=0x4318
pci/1/1/il0macaddr=00:90:4C:8D:00:2a
pci/1/1/opo=14
pci/1/1/pa0b0=0x1460
pci/1/1/pa0b1=0xfacb
pci/1/1/pa0b2=0xfe5c
pci/1/1/pa0itssit=62
pci/1/1/pa0maxpwr=0x4e
pci/1/1/sromrev=2
pci/1/1/wl0gpio0=2
pci/1/1/wl0gpio1=1
pci/1/1/wl0gpio2=11
pci/1/1/wl0gpio3=11
pmon_ver=CFE 4.151.10.5
reset_gpio=6
scratch=a0180000
sdram_config=0x0062
sdram_init=0x0009
sdram_ncdl=0x407
sdram_refresh=0x0000
sromrev=2
tftpd_ipaddr=192.168.1.254
watchdog=5000
wl0gpio2=0
wl0gpio3=0
wl0id=0x4320

comment:3 Changed 5 years ago by Zajec

dove/noreginos could you try installing some recent bcm47xx build (AA will be probably too old): http://downloads.openwrt.org/snapshots/trunk/brcm47xx/

With the recent build, please test model detection with simple:
cat /proc/cpuinfo

Does it detect your model correctly?

comment:4 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from assigned to closed

comment:5 Changed 5 years ago by COVERek

Hi,
In AA (r36088) I have the same problem...

root@OpenWrt:/# dmesg | grep diag
[    5.648000] diag: Detected 'Linksys WRTSL54GS'
root@OpenWrt:/# cat /proc/cpuinfo
system type		: Broadcom BCM47XX
processor		: 0
cpu model		: Broadcom BMIPS3300 V0.6
BogoMIPS		: 262.14
wait instruction	: yes
microsecond timers	: yes
tlb_entries		: 32
extra interrupt vector	: yes
hardware watchpoint	: no
ASEs implemented	:
shadow register sets	: 1
kscratch registers	: 0
core			: 0
VCED exceptions		: not available
VCEI exceptions		: not available

comment:6 Changed 5 years ago by COVERek

  • Resolution no_response deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by hauke

  • Resolution set to fixed
  • Status changed from reopened to closed

This was fixed some time ago in trunk.

There your board should be correctly be detected.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.