Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11623 closed defect (fixed)

ip6addr on AP interace does not work (with netifd)

Reported by: br1@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: IPv6 netifd Cc:

Description

IPv6 address on an AP interface does not work.

This is on ATTITUDE ADJUSTMENT (Bleeding Edge, r3210) with netifd.

The kernel log shows:

OpenWrt kern.info kernel: [ 15.412000] ADDRCONF(NETDEV_UP): wlan0: link is not ready

/etc/config/wireless:

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid OpenWrt
option encryption psk2
option key XXX

/etc/config/network

config interface lan

option ifname wlan0
option proto static
option ipaddr 192.168.12.1
option netmask 255.255.255.0
option ip6addr '2001:b18:2000:81ca::1/64'

The same ip6addr is added successfully to an ethernet interface, so I guess there must be some timing issue with hostapd and ip6addr.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by jow

Remove the option ifname

comment:2 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r32356

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.