Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11547 closed defect (fixed)

[trunk 31870][ar71xx] no wlan after boot

Reported by: flux242@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: ath9k boot Cc:

Description

I've got Buffalo a300h and I'm using only g mode currently. I'm using 13 channel as the only possibility to make it work in my crowded environment. After boot the wifi is not up.

root@Buffalo:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '4c:e6:76:c4:52:ea'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '16'
        option country 'DE'
        option channel '13'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'XXXXXXXXXXXX'
        option encryption 'psk2+ccmp'
        option key 'xxxxxxxxxxxxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option macaddr '4c:e6:76:c4:52:eb'
        option hwmode '11na'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '1'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

This is the error messages in the syslog after boot

May 28 14:36:15 Buffalo daemon.warn hostapd: wlan0: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
May 28 14:36:15 Buffalo daemon.warn hostapd: wlan0: IEEE 802.11 Hardware does not support configured channel

But if I connect to router via lan and call wifi the wifi is up and running without any problem

root@Buffalo:~# wifi
'radio1' is disabled
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 4c:e6:76:c4:52:ea and ssid 'BuffaloG'
random: Only 17/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations
WPA: Not enough entropy in random pool for secure operations - update keys later when the first station connects
'radio1' is disabled

WTF? Do I really need to boot my main computer to bring the wifi up after each reboot now?

root@Buffalo:~# lsmod | grep ath
ath79_wdt               2240  1 
ath9k                  79888  0 
ath9k_common            1152  1 ath9k
ath9k_hw              319408  2 ath9k,ath9k_common
ath                    12320  3 ath9k,ath9k_common,ath9k_hw
mac80211              241952  1 ath9k
cfg80211              136656  2 ath9k,mac80211
compat                   784  5 ath9k,ath9k_common,ath9k_hw,mac80211,cfg80211

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by nbd

what version are you running?

comment:2 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

oh, sorry. it's in the title. r31859 should have fixed this issue

comment:3 Changed 6 years ago by nbd

  • Resolution worksforme deleted
  • Status changed from closed to reopened

oops, accidentally closed the ticket

comment:4 Changed 6 years ago by flux242@…

no, it looks like r31859 has not fixed the issue. At least for me

comment:5 Changed 6 years ago by nbd

please try r31954 - after updating deselect crda before you build the new image

comment:6 Changed 6 years ago by flux242@…

seems to work now. Thanks

comment:7 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.