Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11542 closed defect (fixed)

WZR-HP-AG300H wlan1 (5GHz radio1): deauthenticating from by local choice (reason=3)

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Router Model: Buffalo WZR-HP-AG300H
Firmware Version: OpenWrt Attitude Adjustment r31858/LuCI Trunk (trunk+svn8683)
Kernel Version: 3.3.7

The problem seems to be only with the wlan1 5GHz radio1. The 5GHz radio1 worked a couple of release back. the bug seemed to have been introduced in the last 2 or 3 builds.

The 2GHz wlan0 works as expected.

Below is a snippet from the kernel log. One thing I've noticed is that is off is the incomplete MAC in the log's beginning.

''':b1:c2:d3:e4:f5 (try 1/3)'''
[ 6601.600000] wlan1: RX AssocResp from '''a0:b1:c2:d3:e4:f5''' (capab=0x11 status=18 aid=0)
[ 6601.600000] wlan1: a0:b1:c2:d3:e4:f5 denied association (code=18)
[ 6601.600000] wlan1: deauthenticating from a0:b1:c2:d3:e4:f5 by local choice (reason=3)
[ 6603.690000] wlan1: authenticate with a0:b1:c2:d3:e4:f5
[ 6603.690000] wlan1: send auth to a0:b1:c2:d3:e4:f5 (try 1/3)
[ 6603.690000] wlan1: authenticated
[ 6603.710000] wlan1: associate with a0:b1:c2:d3:e4:f5 (try 1/3)
[ 6603.710000] wlan1: RX AssocResp from a0:b1:c2:d3:e4:f5 (capab=0x11 status=18 aid=0)
[ 6603.710000] wlan1: a0:b1:c2:d3:e4:f5 denied association (code=18)
[ 6603.710000] wlan1: deauthenticating from a0:b1:c2:d3:e4:f5 by local choice (reason=3)
[ 6605.800000] wlan1: authenticate with a0:b1:c2:d3:e4:f5
[ 6605.800000] wlan1: send auth to a0:b1:c2:d3:e4:f5 (try 1/3)

Attachments (2)

kernel.txt (15.5 KB) - added by anonymous 6 years ago.
kernel log
system.txt (15.9 KB) - added by anonymous 6 years ago.
system log

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by anonymous

kernel log

Changed 6 years ago by anonymous

system log

comment:1 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Looks like a configuration error to me. The relevant message is:

wlan1: a0:b1:c2:d3:e4:f5 denied association (code=18)

code=18 is WLAN_REASON_INVALID_GROUP_CIPHER, so there's a mismatch in crypto algorithms.
Try setting the AP and client to WPA2, AES/CCMP only.

comment:2 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am setting up radio1 as client(sta) mode to a linksys e3000 dual band. Firstly my current setup worked previously with cipher set to auto in open wrt. Secondly the e3000 doesn't have setting to change cipher mode. This sort of indicates that something changed with openwrt that broke the crypto settings.

The wifi indicates wireless is disabled or not associated no matter if I try to setup the radio for client or AP mode. According to the log it indicates that authentication was successful, but fails association so shouldn't cipher fail during authentication not just after.

comment:3 Changed 6 years ago by null@…

The problem looks like it may have something to do with the length of the wpa2 passsphrase in the current release. The passphrase that I was using "thefoxranaroundtheclockhickorydickrydoc" which after I changed to a shorter passphrase the errors stopped.

comment:4 Changed 6 years ago by nbd

  • Priority changed from high to response-needed

please try latest trunk to see if the issue is still there with the long passphrase

comment:5 Changed 6 years ago by anonymous

long pass phrase is no longer a problem. thanks

comment:6 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.