Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11535 closed defect (wontfix)

ar71xx: wifi sta/client mode fails with "Operation not supported"

Reported by: irimi Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: ar71xx Cc:

Description

ar71xx/ TPL 1043ND:
At least since -r31708 wifi sta mode always fails with "operation not supported", -r31650 is still fine , I guess problem could be caused by -r31689 ... -r31692 !??

Problem is confirmed by other user.

root@openwrt:# wifi
Successfully initialized wpa_supplicant
Command failed: Operation not supported


root@openwrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  b0:48:7a:c3:82:30
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40

config wifi-iface
        option device   radio0
        option network  wan
        option mode     sta
        option ssid     Yudansha
        option encryption psk
        option key SECRET

cat /etc/config/network
[...]
config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
[...]
root@openwrt:~# iwconfig
eth0.1    no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Yudansha"  
          Mode:Managed  Frequency:2.452 GHz  Access Point: 00:04:0E:DB:58:AF   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=59/70  Signal level=-51 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.
br-lan    no wireless extensions.
eth0.2    no wireless extensions.


[ 3000.290000] wlan0: deauthenticating from 00:04:0e:db:58:af by local choice (reason=3)
[ 3002.450000] wlan0: authenticate with 00:04:0e:db:58:af
[ 3002.450000] wlan0: send auth to 00:04:0e:db:58:af (try 1/3)
[ 3002.450000] wlan0: authenticated
[ 3002.480000] wlan0: associate with 00:04:0e:db:58:af (try 1/3)
[ 3002.480000] wlan0: RX AssocResp from 00:04:0e:db:58:af (capab=0x411 status=0 aid=1)
[ 3002.480000] wlan0: associated

See also
https://forum.openwrt.org/viewtopic.php?pid=168240

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

The problem is that the 'wan' interface already has an assigned ifname (eth0.2) that is not a bridge.

Either remove eth0.2 from wan, or create a new interface without ifname and use that for wifi.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.