Modify

Opened 6 years ago

Closed 3 years ago

#11531 closed defect (invalid)

opkg install kmod-usb-storage block-mount block-hotplug kmod-fs-ext4

Reported by: ashkanull@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: kmod-usb-storage block-mount block-hotplug kmod-fs-ext4 Cc:

Description

...
Downloading http://downloads.openwrt.org/snapshots/trunk/x86/packages/kmod-fs-ext4_3.3.6-1_x86.ipk.
Configuring libblkid.
Configuring libuuid.
Configuring blkid.
Configuring swap-utils.
Configuring block-mount.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
  • kernel (= 3.3.6-1-06e8dc0e21c6891eb05dce4475cadf2b) * kernel (= 3.3.6-1-06e8dc0e21c6891eb05dce4475cadf2b) * kernel (= 3.3.6-1-06e8dc0e21c6891eb05dce4475cadf2b) * kernel (= 3.3.6-1-06e8dc0e21c6891eb05dce4475cadf2b) *
  • opkg_install_cmd: Cannot install package kmod-usb-storage.
  • opkg_install_cmd: Cannot install package block-hotplug.
  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 3.3.6-1-06e8dc0e21c6891eb05dce4475cadf2b) * kernel (= 3.3.6-1-06e8dc0e21c6891eb05dce4475cadf2b) *
  • opkg_install_cmd: Cannot install package kmod-fs-ext4.

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

Your build is too old.

comment:2 Changed 6 years ago by ashkanull <ashkanull@…>

  • Resolution wontfix deleted
  • Status changed from closed to reopened

I compiled from latest trunk build openwrt-x86-generic-combined-ext4 At revision 31858 !!!
maybe this has got to do with this patch https://dev.openwrt.org/changeset/31848/trunk

comment:3 Changed 6 years ago by anonymous

So use your modules, not from openwrt's trunk!

comment:4 Changed 6 years ago by ashkanull <ashkanull@…>

no difference same error

comment:5 Changed 6 years ago by hnyman <hannu.nyman@…>

Currently the version and options used to compile the kernel extensions need to match those used in compiling the main kernel. The checksum included in the module name (06e8dc0e21c6891eb05dce4475cadf2b) relates to that. In practice that means that you should always compile kmods at the same time as you compile the main kernel.

Current kernel for most targets is 3.3.7, so trying in install kmods built for 3.3.6 will not succeed.

I suggest that you rebuild your own system and include those kmods you need. Be sure to "make clean" first, so that there is no leftovers from the old kernel.

You should also be able to force installation regardless of the compatibility, but there might be crashes. Use command line to install a package: opkg --force-depends install <package path>. See e.g. https://forum.openwrt.org/viewtopic.php?pid=161617#p161617

comment:6 Changed 6 years ago by Cybjit <cybjit@…>

My guess is that you have done an opkg update, messing up the dependencies for your own packages. Try removing /tmp/opkg-lists first.

Example:

root@OpenWrt:/opt/ar71xx/packages# opkg install kmod-sit_3.3.6-1_ar71xx.ipk 
Installing kmod-sit (3.3.6-1) to root...
Configuring kmod-sit.

root@OpenWrt:/opt/ar71xx/packages# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.

root@OpenWrt:/opt/ar71xx/packages# opkg install kmod-sit_3.3.6-1_ar71xx.ipk 
Installing kmod-sit (3.3.6-1) to root...
Collected errors:
 * opkg_install_pkg: Package kmod-sit md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
 * opkg_install_cmd: Cannot install package kmod-sit.

root@OpenWrt:/opt/ar71xx/packages# rm -r /tmp/opkg-lists

root@OpenWrt:/opt/ar71xx/packages# opkg install kmod-sit_3.3.6-1_ar71xx.ipk 
Installing kmod-sit (3.3.6-1) to root...
Configuring kmod-sit.

comment:7 Changed 6 years ago by nbd

  • Resolution set to invalid
  • Status changed from reopened to closed

Even changing the kmod-* package selection changes the version string of the 'kernel' package, because such changes can lead to those packages being incompatible with a kernel from a different config.
Make sure that the configuration of packages that you want to install matches the image that you flashed.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:9 Changed 3 years ago by dim7@…

Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/nand/packages/base/kmod-usb-storage_3.18.11-1_ar71xx.ipk.

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
  • kernel (= 3.18.11-1-0e3e5badcf94901e766dd6120b0de6ed) * kernel (= 3.18.11-1-0e3e5badcf94901e766dd6120b0de6ed) *
  • opkg_install_cmd: Cannot install package kmod-usb-storage.

comment:10 Changed 3 years ago by gyurman

  • Resolution invalid deleted
  • Status changed from closed to reopened

I have same with:
root@OpenWrt:~# cat /proc/version
Linux version 3.18.14 (thepeople@trabant) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r45915) ) #1 Sun Jun 7 12:52:58 CEST 2015

comment:11 Changed 3 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.