Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11530 closed defect (fixed)

Script under /etc/ppp/ip-up.d/ not executed when PPPoE WAN i/f up, maybe netifd related regression

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: ppp netifd Cc:

Description

Router: TL-WR1043nd
Version: Trunk r31785

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by nbd

What are you using /etc/ppp/ip-up.d for? Can't you just use /etc/hotplug.d/iface?

comment:2 Changed 6 years ago by nbd

  • Priority changed from normal to response-needed

comment:3 Changed 6 years ago by anonymous

It's a dyndns update script for dns binding for pppoe wan. I think it can be moved to hotplug, but /etc/ppp/ip-up.d method is used for several years, why it should be changed?

comment:4 Changed 6 years ago by Nilfred <nilfred@…>

Why not? hotplug has been around for several years too ;)

comment:5 Changed 6 years ago by nbd

Ah, so it's a custom hacked-up dyndns update script and not one provided by openwrt.
I guess i could add back ip-up.d for compatibility reasons, but /etc/hotplug.d/iface is definitely better for use in packages/scripts, since it is not limited to ppp, but also works if you have wan as dhcp or static or anything else.

comment:6 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r31860

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.