Modify

Opened 6 years ago

Closed 2 years ago

#11507 closed defect (fixed)

Not build iproute2 for gcc-4.7.0/eglibc-2.14

Reported by: sav Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Not build iproute2 for gcc-4.7.0/eglibc

make[3]: Entering directory `/home/sysadmin/wl500/OpenWrt/build/package/iproute2'
CFLAGS="-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float  -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/usr/include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/usr/include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/include " CXXFLAGS="-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float  -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/usr/include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/usr/include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/include " LDFLAGS="-L/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/usr/lib -L/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/lib -L/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/usr/lib -L/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/lib " make  -j1 -C /home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0 AR=mipsel-openwrt-linux-gnu-ar AS="mipsel-openwrt-linux-gnu-gcc -c -Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float" LD=mipsel-openwrt-linux-gnu-ld NM=mipsel-openwrt-linux-gnu-nm CC="mipsel-openwrt-linux-gnu-gcc" GCC="mipsel-openwrt-linux-gnu-gcc" CXX="mipsel-openwrt-linux-gnu-g++" RANLIB=mipsel-openwrt-linux-gnu-ranlib STRIP=mipsel-openwrt-linux-gnu-strip OBJCOPY=mipsel-openwrt-linux-gnu-objcopy OBJDUMP=mipsel-openwrt-linux-gnu-objdump SIZE=mipsel-openwrt-linux-gnu-size CROSS="mipsel-openwrt-linux-gnu-" ARCH="mipsel" EXTRA_CCOPTS="-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -I../include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/usr/include/libnl-tiny" KERNEL_INCLUDE="/include" FPIC="-fpic" 
make[4]: Entering directory `/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0'
make[5]: Entering directory `/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0/lib'
make[5]: Nothing to be done for `all'.
make[5]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0/lib'
make[5]: Entering directory `/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0/ip'
mipsel-openwrt-linux-gnu-gcc -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -I../include -I/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/usr/include/libnl-tiny -I../include -DRESOLVE_HOSTNAMES -DLIBDIR=\"/usr/lib/\"   -c -o ipnetns.o ipnetns.c
ipnetns.c:32:12: error: static declaration of 'setns' follows non-static declaration
In file included from /home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/lib/gcc/mipsel-openwrt-linux-gnu/4.7.0/../../../../mipsel-openwrt-linux-gnu/sys-include/sched.h:43:0,
                 from ipnetns.c:11:
/home/sysadmin/wl500/OpenWrt/build/staging_dir/toolchain-mipsel_gcc-4.7.0_eglibc-2.14.1/lib/gcc/mipsel-openwrt-linux-gnu/4.7.0/../../../../mipsel-openwrt-linux-gnu/sys-include/bits/sched.h:93:12: note: previous declaration of 'setns' was here
make[5]: *** [ipnetns.o] Error 1
make[5]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0/ip'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0'
make[3]: *** [/home/sysadmin/wl500/OpenWrt/build/build_dir/target-mipsel_eglibc-2.14.1/iproute2-3.3.0/.built] Error 2
make[3]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build/package/iproute2'
make[2]: *** [package/iproute2/compile] Error 2
make[2]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build'
make[1]: *** [/home/sysadmin/wl500/OpenWrt/build/staging_dir/target-mipsel_eglibc-2.14.1/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build'

Attachments (1)

.config (138.4 KB) - added by sav 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by blogic

Worksforme ... can yu provide your .config ?

Changed 6 years ago by sav

comment:2 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r32103

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 Changed 3 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

The problem is still actual with current Barrier Breaker
and iproute2-3.15.0, gcc 4.8, eglibc 2.19 .

For myself I prepared this patch:

--- a/ip/ipnetns.c 2014-08-12 19:45:03.483899137 +0400
+++ b/ip/ipnetns.c 2014-08-12 19:45:08.915899348 +0400
@@ -43,7 +43,7 @@

#endif


#ifndef HAVE_SETNS

-static int setns(int fd, int nstype)
+int setns(int fd, int nstype)

{
#ifdef NR_setns

return syscall(NR_setns, fd, nstype);

It's quite obvious and quick decision. But I have no time to dig it deeper.

comment:5 Changed 2 years ago by anonymous

add
-DHAVE_SETNS=1
to EXTRA_CCOPTS

comment:6 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

barrier breaker is obsolete, this is fixed in CC (15.09)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.