Modify

Opened 6 years ago

Last modified 3 years ago

#11501 reopened defect

/tmp/resolv.conf.auto is empty

Reported by: anonymous Owned by: nbd
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Under r31822, the /tmp/resolv.conf.auto file is empty after boot, and gets overwritten without content when interfaces change ip addresses. My internet connection is via pppoe-wan, with peerdns and additional dns servers configured in /etc/config/network. As dnsmasq uses /tmp/resolv.conf.auto as its input, I loose the ability to resolve external IP addresses.

Attachments (0)

Change History (24)

comment:1 Changed 6 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

comment:2 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed in r31830

comment:3 Changed 6 years ago by anonymous

Exactly same error returned in r31853

comment:4 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:5 Changed 6 years ago by nbd

  • Priority changed from high to response-needed

show me your config

comment:6 Changed 6 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

comment:7 Changed 6 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

This happens to me too. But with manually configured DNS servers things work fine.

Device is a TP-Link TL-1043ND.

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option stp '1'
        option ipaddr '192.168.199.1'
        option ip6addr 'xxx/64'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option username 'xxx@xxx'
        option password 'xxx'
        option ipv6 '1'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'
        option keepalive '3 5'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

config interface 'modem'
        option proto 'static'
        option ifname 'eth0.2'
        option ipaddr '192.168.0.10'
        option netmask '255.255.255.0'

/etc/config/firewall

config defaults
        option syn_flood '1'
        option output 'ACCEPT'
        option input 'DROP'
        option forward 'DROP'

config zone
        option name 'lan'
        option network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan modem'
        option input 'DROP'
        option forward 'DROP'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

everything else is pretty much set to defaults. tried several fresh installs with latest revisions over the last month.

if I remove the modem interface or remove ipv6 configuration, it makes no difference. only thing I havent tried is to run without ipv6 modules.

when the problem occours a dirty fix is just to login to luci webui, and go wan interface and press "Save & Apply", then it will find the dns servers properly and things will work. but it does not work at bootup, or if internet connection goes down and it tries to reconnect, then DNS information will not end up in /tmp/resolv.conf.auto (it remains empty). so dnsmasq will not work with dns queries.

/tmp/resolv.conf.ppp will however (from my experience) always be populated with the correct dns servers.

comment:8 Changed 6 years ago by anonymous

simulated modem restart gives this in syslog;

Jul  2 01:36:48 dexter daemon.warn pppd[7744]: Timeout waiting for PADO packets
Jul  2 01:36:48 dexter daemon.err pppd[7744]: Unable to complete PPPoE Discovery
Jul  2 01:36:48 dexter daemon.info pppd[7744]: Exit.
Jul  2 01:36:48 dexter daemon.notice netifd: Interface 'wan' is now down
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:48 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:49 dexter daemon.info pppd[7787]: Plugin rp-pppoe.so loaded.
Jul  2 01:36:49 dexter daemon.info pppd[7787]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jul  2 01:36:49 dexter daemon.notice pppd[7787]: pppd 2.4.5 started by root, uid 0
Jul  2 01:36:49 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:49 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:54 dexter daemon.info pppd[7787]: PPP session is 4026
Jul  2 01:36:54 dexter daemon.warn pppd[7787]: Connected to 00:90:xx:xx:xx:xx via interface eth0.2
Jul  2 01:36:54 dexter daemon.info pppd[7787]: Using interface pppoe-wan
Jul  2 01:36:54 dexter daemon.notice pppd[7787]: Connect: pppoe-wan <--> eth0.2
Jul  2 01:36:54 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:54 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:54 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:54 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: PAP authentication succeeded
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: peer from calling number 00:90:1A:A1:03:5C authorized
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: local  LL address fe80::dcad:xxxx:xxxx:xxxx
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: remote LL address fe80::0215:xxxx:fexx:xxxx
Jul  2 01:36:55 dexter daemon.debug radvd[6978]: attempting to reread config file
Jul  2 01:36:55 dexter daemon.debug radvd[6978]: resuming normal operation
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: local  IP address xx.xx.xx.xx
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: remote IP address xx.xx.xx.xx
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: primary   DNS address 79.128.179.6
Jul  2 01:36:55 dexter daemon.notice pppd[7787]: secondary DNS address 79.128.179.5
Jul  2 01:36:55 dexter daemon.notice netifd: Interface 'wan' is now up
Jul  2 01:36:55 dexter user.notice ifup: Enabling Router Solicitations on wan (pppoe-wan)
Jul  2 01:36:56 dexter user.info firewall: adding wan (pppoe-wan) to zone wan
Jul  2 01:36:57 dexter daemon.notice miniupnpd[5831]: received signal 15, good-bye
Jul  2 01:36:59 dexter user.info syslog: SNet version started
Jul  2 01:36:59 dexter daemon.notice miniupnpd[8123]: HTTP listening on port 5000
Jul  2 01:36:59 dexter daemon.notice miniupnpd[8123]: Listening for NAT-PMP traffic on port 5351
Jul  2 01:36:59 dexter user.notice miniupnpd: adding firewall rules for pppoe-wan to zone wan
Jul  2 01:36:59 dexter daemon.warn dnsmasq[6952]: no servers found in /tmp/resolv.conf.auto, will retry

by incident noticed that "Save & Apply" on LAN interface also fixes this problem (guess it's reloading dnsmasq together with other stuff).

but '/etc/init.d/dnsmasq restart' doesn't work.

comment:9 Changed 6 years ago by anonymous

'ifup wan' seems to fix it too.

also for the first time even manually configured dns servers were not picked up by /tmp/resolv.conf.auto

comment:10 Changed 6 years ago by spock521@…

I see the same thing when I enable IPv6 on the PPPoE WAN interface (option ipv6 '1').

Fresh install;
packages installed: luci nano luci-app-radvd luci-app-ddns luci-app-pnp

Configuration is untouched (image from latest trunk), except for setting up WAN interface.

comment:11 Changed 5 years ago by nbd

please try latest trunk

comment:12 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

comment:13 Changed 5 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

I am seeing the same problem with AA beta2 on TL-1043-ND. Manually copying /tmp/resolv.conf.ppp to /tmp/resolv.conf.auto solves the problem.

I can provide more details if needed.

I also have ipv6 problems (everything was fine in 10.03.1) but did not investigate yet.

comment:14 Changed 5 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

No config and logs provided, cannot reproduce it here.

comment:15 Changed 5 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Here are some config files ; not very used to fill bug reports so I was not sure which files to include or not... If you need more data, I will provide it.

/etc/config/network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0.1'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option 'ip6addr' '2001:7a8:b4c5:1::1/64'

config 'interface' 'wan'
        option 'ifname' 'eth0.2'
        option '_orig_ifname' 'eth0.2'
        option '_orig_bridge' 'false'
        option 'proto' 'pppoe'
        option 'username' 'xxx'
        option 'password' 'xxx'
        option 'accept_ra' '1'
        option 'ipv6' '1'
        option 'mtu' '1452'

config 'switch'
        option 'name' 'rtl8366rb'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '1'
        option 'ports' '1 2 3 4 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '2'
        option 'ports' '0 5t'

/etc/config/firewall

config 'defaults'
        option 'syn_flood' '1'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'drop_invalid' '1'

config 'zone'
        option 'name' 'lan'
        option 'network' 'lan'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

config 'zone'
        option 'name' 'wan'
        option 'network' 'wan'
        option 'input' 'REJECT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'
        option 'masq' '1'
        option 'mtu_fix' '1'

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'udp'
        option 'dest_port' '68'
        option 'target' 'ACCEPT'
        option 'family' 'ipv4'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'icmp'
        option 'icmp_type' 'echo-request'
        option 'family' 'ipv4'
        option 'target' 'ACCEPT'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'icmp'
        list 'icmp_type' 'echo-request'
        list 'icmp_type' 'destination-unreachable'
        list 'icmp_type' 'packet-too-big'
        list 'icmp_type' 'time-exceeded'
        list 'icmp_type' 'bad-header'
        list 'icmp_type' 'unknown-header-type'
        list 'icmp_type' 'router-solicitation'
        list 'icmp_type' 'neighbour-solicitation'
        option 'limit' '1000/sec'
        option 'family' 'ipv6'
        option 'target' 'ACCEPT'

config 'rule'
        option 'src' 'wan'
        option 'dest' '*'
        option 'proto' 'icmp'
        list 'icmp_type' 'echo-request'
        list 'icmp_type' 'destination-unreachable'
        list 'icmp_type' 'packet-too-big'
        list 'icmp_type' 'time-exceeded'
        list 'icmp_type' 'bad-header'
        list 'icmp_type' 'unknown-header-type'
        option 'limit' '1000/sec'
        option 'family' 'ipv6'
        option 'target' 'ACCEPT'

config 'rule'
        option 'src' 'wan'
        option 'dest' 'lan'
        option 'proto' 'tcp'
        option 'dest_port' '53'
        option 'target' 'ACCEPT'
        option family 'ipv6'

config 'rule'
        option 'src' 'wan'
        option 'dest' 'lan'
        option 'proto' 'tcp'
        option 'dest_port' '80'
        option 'target' 'ACCEPT'
        option family 'ipv6'

config 'rule'
        option 'src' 'wan'
        option 'dest' 'lan'
        option 'proto' 'tcp'
        option 'dest_port' '222'
        option 'target' 'ACCEPT'
        option family 'ipv6'

config 'rule'
        option 'src' 'wan'
        option 'dest' 'lan'
        option 'proto' 'tcp'
        option 'dest_port' '443'
        option 'target' 'ACCEPT'
        option family 'ipv6'

config 'redirect'
        option 'src' 'wan'
        option 'proto' 'tcp'
        option 'src_dport' '222'
        option 'dest_ip' '192.168.1.246'
        option 'target' 'DNAT'
        option 'dest' 'lan'

config 'redirect'
        option 'src' 'wan'
        option 'proto' 'tcp'
        option 'src_dport' '80'
        option 'dest_ip' '192.168.1.246'
        option 'target' 'DNAT'
        option 'dest' 'lan'

config 'redirect'
        option 'src' 'wan'
        option 'proto' 'tcp'
        option 'src_dport' '53'
        option 'dest_ip' '192.168.1.246'
        option 'target' 'DNAT'
        option 'dest' 'lan'

config 'redirect'
        option 'src' 'wan'
        option 'proto' 'tcp'
        option 'src_dport' '443'
        option 'dest_ip' '192.168.1.246'
        option 'target' 'DNAT'
        option 'dest' 'lan'

config 'include'
        option 'path' '/etc/firewall.user'

logs :

Sep  8 16:39:04 OpenWrt kern.info kernel: [   10.630000] ip6_tables: (C) 2000-2006 Netfilter Core Team
Sep  8 16:39:04 OpenWrt kern.info kernel: [   10.870000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Sep  8 16:39:06 OpenWrt kern.debug kernel: [   14.020000] ar71xx: pll_reg 0xb8050014: 0x1a000000
Sep  8 16:39:06 OpenWrt daemon.notice netifd: Interface 'lan' is now up
Sep  8 16:39:06 OpenWrt daemon.notice netifd: Interface 'loopback' is now up
Sep  8 16:39:07 OpenWrt daemon.info pppd[657]: Plugin rp-pppoe.so loaded.
Sep  8 16:39:07 OpenWrt daemon.info pppd[657]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 16:39:07 OpenWrt daemon.notice pppd[657]: pppd 2.4.5 started by root, uid 0
Sep  8 16:39:07 OpenWrt daemon.err pppd[657]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Sep  8 16:39:07 OpenWrt daemon.err pppd[657]: This may cause serious connection problems.
Sep  8 16:39:07 OpenWrt kern.info kernel: [   14.320000] eth0: link up (1000Mbps/Full duplex)
Sep  8 16:39:07 OpenWrt kern.info kernel: [   14.330000] device eth0.1 entered promiscuous mode
Sep  8 16:39:07 OpenWrt kern.info kernel: [   14.330000] device eth0 entered promiscuous mode
Sep  8 16:39:07 OpenWrt kern.info kernel: [   14.340000] br-lan: port 1(eth0.1) entered forwarding state
Sep  8 16:39:07 OpenWrt kern.info kernel: [   14.350000] br-lan: port 1(eth0.1) entered forwarding state
Sep  8 16:39:07 OpenWrt user.info sysinit: 'radio0' is disabled
Sep  8 16:39:07 OpenWrt kern.info kernel: [   15.330000] ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Sep  8 16:39:07 OpenWrt user.notice ifup: Enabling Router Solicitations on lan (br-lan)
Sep  8 16:39:08 OpenWrt user.info sysinit: 'radio0' is disabled
Sep  8 16:39:08 OpenWrt user.info sysinit: 'radio0' is disabled
Sep  8 16:39:08 OpenWrt kern.info kernel: [   16.350000] br-lan: port 1(eth0.1) entered forwarding state
Sep  8 16:39:10 OpenWrt user.notice ifup: Enabling Router Solicitations on loopback (lo)
Sep  8 16:39:11 OpenWrt user.info sysinit: Loading defaults
Sep  8 16:39:11 OpenWrt user.info sysinit: Loading synflood protection
Sep  8 16:39:11 OpenWrt user.info sysinit: Adding custom chains
Sep  8 16:39:12 OpenWrt user.info sysinit: Loading zones
Sep  8 16:39:13 OpenWrt user.info sysinit: Loading forwardings
Sep  8 16:39:13 OpenWrt user.info sysinit: Loading rules
Sep  8 16:39:14 OpenWrt user.info sysinit: Loading redirects
Sep  8 16:39:14 OpenWrt user.info sysinit: Loading includes
Sep  8 16:39:14 OpenWrt user.info sysinit: Loading interfaces
Sep  8 16:39:14 OpenWrt user.info firewall: adding lan (br-lan) to zone lan
Sep  8 16:39:15 OpenWrt authpriv.info dropbear[1159]: Running in background
Sep  8 16:39:16 OpenWrt kern.debug kernel: [   24.430000] eth0: no IPv6 routers present
Sep  8 16:39:17 OpenWrt kern.debug kernel: [   25.010000] eth0.2: no IPv6 routers present
Sep  8 16:39:17 OpenWrt user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Sep  8 16:39:17 OpenWrt user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Sep  8 16:39:20 OpenWrt daemon.info dnsmasq[1207]: started, version 2.62 cachesize 150
Sep  8 16:39:20 OpenWrt daemon.info dnsmasq[1207]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
Sep  8 16:39:20 OpenWrt daemon.info dnsmasq-dhcp[1207]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Sep  8 16:39:20 OpenWrt daemon.info dnsmasq[1207]: using local addresses only for domain lan
Sep  8 16:39:20 OpenWrt daemon.warn dnsmasq[1207]: no servers found in /tmp/resolv.conf.auto, will retry
Sep  8 16:39:20 OpenWrt daemon.info dnsmasq[1207]: read /etc/hosts - 1 addresses
Sep  8 16:39:20 OpenWrt daemon.info dnsmasq-dhcp[1207]: read /etc/ethers - 0 addresses
Sep  8 16:39:20 OpenWrt user.info sysinit: setting up led USB
Sep  8 16:39:20 OpenWrt user.info sysinit: setting up led WLAN
Sep  8 16:39:22 OpenWrt daemon.warn pppd[657]: Timeout waiting for PADO packets
Sep  8 16:39:22 OpenWrt daemon.err pppd[657]: Unable to complete PPPoE Discovery
Sep  8 16:39:22 OpenWrt daemon.info pppd[657]: Exit.
Sep  8 16:39:22 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Sep  8 16:39:22 OpenWrt daemon.info pppd[1248]: Plugin rp-pppoe.so loaded.
Sep  8 16:39:22 OpenWrt daemon.info pppd[1248]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 16:39:22 OpenWrt daemon.notice pppd[1248]: pppd 2.4.5 started by root, uid 0
Sep  8 16:39:22 OpenWrt daemon.err pppd[1248]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Sep  8 16:39:22 OpenWrt daemon.err pppd[1248]: This may cause serious connection problems.
Sep  8 16:39:37 OpenWrt daemon.warn pppd[1248]: Timeout waiting for PADO packets
Sep  8 16:39:37 OpenWrt daemon.err pppd[1248]: Unable to complete PPPoE Discovery
Sep  8 16:39:37 OpenWrt daemon.info pppd[1248]: Exit.
Sep  8 16:39:37 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Sep  8 16:39:38 OpenWrt daemon.info pppd[1276]: Plugin rp-pppoe.so loaded.
Sep  8 16:39:38 OpenWrt daemon.info pppd[1276]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 16:39:38 OpenWrt daemon.notice pppd[1276]: pppd 2.4.5 started by root, uid 0
Sep  8 16:39:38 OpenWrt daemon.err pppd[1276]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Sep  8 16:39:38 OpenWrt daemon.err pppd[1276]: This may cause serious connection problems.
Sep  8 16:39:53 OpenWrt daemon.warn pppd[1276]: Timeout waiting for PADO packets
Sep  8 16:39:53 OpenWrt daemon.err pppd[1276]: Unable to complete PPPoE Discovery
Sep  8 16:39:53 OpenWrt daemon.info pppd[1276]: Exit.
Sep  8 16:39:53 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Sep  8 16:39:53 OpenWrt daemon.info pppd[1304]: Plugin rp-pppoe.so loaded.
Sep  8 16:39:53 OpenWrt daemon.info pppd[1304]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 16:39:53 OpenWrt daemon.notice pppd[1304]: pppd 2.4.5 started by root, uid 0
Sep  8 16:39:53 OpenWrt daemon.err pppd[1304]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Sep  8 16:39:53 OpenWrt daemon.err pppd[1304]: This may cause serious connection problems.
Sep  8 16:40:01 OpenWrt daemon.info pppd[1304]: PPP session is 1558
Sep  8 16:40:01 OpenWrt daemon.warn pppd[1304]: Connected to 00:e0:fc:43:6a:04 via interface eth0.2
Sep  8 16:40:01 OpenWrt daemon.info pppd[1304]: Using interface pppoe-wan
Sep  8 16:40:01 OpenWrt daemon.notice pppd[1304]: Connect: pppoe-wan <--> eth0.2
Sep  8 16:40:08 OpenWrt daemon.info pppd[1304]: CHAP authentication succeeded
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: CHAP authentication succeeded
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: peer from calling number 00:E0:FC:43:6A:04 authorized
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: local  LL address fe80::dd39:ebf7:67fa:f3b1
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: remote LL address fe80::020e:d6ff:fe98:a01b
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: local  IP address 213.41.244.197
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: remote IP address 178.132.16.234
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: primary   DNS address 195.5.209.150
Sep  8 16:40:08 OpenWrt daemon.notice pppd[1304]: secondary DNS address 194.79.128.150
Sep  8 16:40:09 OpenWrt daemon.notice netifd: Interface 'wan' is now up
Sep  8 16:40:09 OpenWrt user.notice ifup: Allowing Router Advertisements on wan (pppoe-wan)
Sep  8 16:40:09 OpenWrt user.notice ifup: Enabling Router Solicitations on wan (pppoe-wan)
Sep  8 16:40:10 OpenWrt user.info firewall: adding wan (pppoe-wan) to zone wan
Sep  8 16:40:18 OpenWrt authpriv.info dropbear[1469]: Child connection from 192.168.1.246:46441
Sep  8 16:40:21 OpenWrt authpriv.notice dropbear[1469]: Pubkey auth succeeded for 'root' with key md5 f3:5f:15:72:51:a3:54:f6:d2:aa:78:07:59:23:dc:7a from 192.168.1.246:46441
Sep  8 16:40:42 OpenWrt daemon.info dnsmasq[1207]: exiting on receipt of SIGTERM
Sep  8 16:40:43 OpenWrt user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Sep  8 16:40:43 OpenWrt user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Sep  8 16:40:46 OpenWrt daemon.info dnsmasq[1511]: started, version 2.62 cachesize 150
Sep  8 16:40:46 OpenWrt daemon.info dnsmasq[1511]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
Sep  8 16:40:46 OpenWrt daemon.info dnsmasq-dhcp[1511]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Sep  8 16:40:46 OpenWrt daemon.info dnsmasq[1511]: using local addresses only for domain lan
Sep  8 16:40:46 OpenWrt daemon.warn dnsmasq[1511]: no servers found in /tmp/resolv.conf.auto, will retry
Sep  8 16:40:46 OpenWrt daemon.info dnsmasq[1511]: read /etc/hosts - 1 addresses
Sep  8 16:40:46 OpenWrt daemon.info dnsmasq-dhcp[1511]: read /etc/ethers - 0 addresses
Sep  8 16:46:58 OpenWrt daemon.info pppd[1304]: Terminating on signal 15
Sep  8 16:46:58 OpenWrt daemon.info pppd[1304]: Connect time 6.9 minutes.
Sep  8 16:46:58 OpenWrt daemon.info pppd[1304]: Sent 45560 bytes, received 37630 bytes.
Sep  8 16:46:58 OpenWrt daemon.info dnsmasq[1511]: reading /tmp/resolv.conf.auto
Sep  8 16:46:58 OpenWrt daemon.info dnsmasq[1511]: using nameserver 195.5.209.150#53
Sep  8 16:46:58 OpenWrt daemon.info dnsmasq[1511]: using nameserver 194.79.128.150#53
Sep  8 16:46:58 OpenWrt daemon.info dnsmasq[1511]: using local addresses only for domain lan
Sep  8 16:46:58 OpenWrt daemon.notice pppd[1304]: Connection terminated.
Sep  8 16:46:58 OpenWrt daemon.info pppd[1304]: Connect time 6.9 minutes.
Sep  8 16:46:58 OpenWrt daemon.info pppd[1304]: Sent 45560 bytes, received 37630 bytes.
Sep  8 16:46:59 OpenWrt daemon.info pppd[1304]: Exit.
Sep  8 16:46:59 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Sep  8 16:46:59 OpenWrt daemon.info pppd[1592]: Plugin rp-pppoe.so loaded.
Sep  8 16:46:59 OpenWrt daemon.info pppd[1592]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 16:46:59 OpenWrt daemon.notice pppd[1592]: pppd 2.4.5 started by root, uid 0
Sep  8 16:46:59 OpenWrt daemon.err pppd[1592]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Sep  8 16:46:59 OpenWrt daemon.err pppd[1592]: This may cause serious connection problems.
Sep  8 16:46:59 OpenWrt user.info firewall: removing wan (pppoe-wan) from zone wan
Sep  8 16:47:14 OpenWrt daemon.warn pppd[1592]: Timeout waiting for PADO packets
Sep  8 16:47:14 OpenWrt daemon.err pppd[1592]: Unable to complete PPPoE Discovery
Sep  8 16:47:14 OpenWrt daemon.info pppd[1592]: Exit.
Sep  8 16:47:14 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Sep  8 16:47:14 OpenWrt daemon.info pppd[1685]: Plugin rp-pppoe.so loaded.
Sep  8 16:47:14 OpenWrt daemon.info pppd[1685]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 16:47:14 OpenWrt daemon.notice pppd[1685]: pppd 2.4.5 started by root, uid 0
Sep  8 16:47:14 OpenWrt daemon.err pppd[1685]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Sep  8 16:47:14 OpenWrt daemon.err pppd[1685]: This may cause serious connection problems.
Sep  8 16:47:21 OpenWrt daemon.info pppd[1685]: PPP session is 1560
Sep  8 16:47:21 OpenWrt daemon.warn pppd[1685]: Connected to 00:e0:fc:43:6a:04 via interface eth0.2
Sep  8 16:47:21 OpenWrt daemon.info pppd[1685]: Using interface pppoe-wan
Sep  8 16:47:21 OpenWrt daemon.notice pppd[1685]: Connect: pppoe-wan <--> eth0.2
Sep  8 16:47:25 OpenWrt daemon.info pppd[1685]: CHAP authentication succeeded
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: CHAP authentication succeeded
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: peer from calling number 00:E0:FC:43:6A:04 authorized
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: local  LL address fe80::c55e:3c65:431c:0687
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: remote LL address fe80::020e:d6ff:fe98:a01b
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: local  IP address 213.41.244.197
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: remote IP address 178.132.16.234
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: primary   DNS address 195.5.209.150
Sep  8 16:47:25 OpenWrt daemon.notice pppd[1685]: secondary DNS address 194.79.128.150
Sep  8 16:47:25 OpenWrt daemon.notice netifd: Interface 'wan' is now up
Sep  8 16:47:25 OpenWrt user.notice ifup: Allowing Router Advertisements on wan (pppoe-wan)
Sep  8 16:47:25 OpenWrt user.notice ifup: Enabling Router Solicitations on wan (pppoe-wan)
Sep  8 16:47:26 OpenWrt user.info firewall: adding wan (pppoe-wan) to zone wan
Sep  8 16:47:48 OpenWrt daemon.warn dnsmasq[1511]: no servers found in /tmp/resolv.conf.auto, will retry
Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: reading /tmp/resolv.conf.auto
Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: using nameserver 194.79.128.150#53
Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: using nameserver 195.5.209.150#53
Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: using local addresses only for domain lan
Sep  8 16:52:33 OpenWrt kern.info kernel: [  821.120000] xt_time: kernel timezone is -0000

(date/time is screwed up, did not investigate yet).

What I did was a sysupgrade from 10.03.1 to AA beta 2, keeping the old config.

comment:16 Changed 5 years ago by jow

  • Resolution set to wontfix
  • Status changed from reopened to closed

Looks okay to me:

 Sep  8 16:47:48 OpenWrt daemon.warn dnsmasq[1511]: no servers found in /tmp/resolv.conf.auto, will retry
 Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: reading /tmp/resolv.conf.auto
 Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: using nameserver 194.79.128.150#53
 Sep  8 16:48:54 OpenWrt daemon.info dnsmasq[1511]: using nameserver 195.5.209.150#53

comment:17 Changed 5 years ago by anonymous

yes, this is when I copied manually /tmp/resolv.conf.ppp to /tmp/resolv.conf.auto. But after reboot, this doesn't work (as described earlier in the ticket).

comment:18 Changed 5 years ago by anonymous

I have a backup of my config files, maybe I will reflash full image and configure things step by step to avoid compatibility issues of config files.

comment:19 Changed 5 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Before doing a reinstall from scratch, I just rebooted the device and the problem is still there. Here is the log again (similar to the previous one) :

Oct 23 11:51:08 OpenWrt kern.info kernel: [   15.390000] eth0: link up (1000Mbps/Full duplex)
Oct 23 11:51:08 OpenWrt kern.info kernel: [   15.390000] device eth0.1 entered promiscuous mode
Oct 23 11:51:08 OpenWrt kern.info kernel: [   15.400000] device eth0 entered promiscuous mode
Oct 23 11:51:08 OpenWrt kern.info kernel: [   15.410000] br-lan: port 1(eth0.1) entered forwarding state
Oct 23 11:51:08 OpenWrt kern.info kernel: [   15.410000] br-lan: port 1(eth0.1) entered forwarding state
Oct 23 11:51:08 OpenWrt daemon.info pppd[737]: Plugin rp-pppoe.so loaded.
Oct 23 11:51:08 OpenWrt daemon.info pppd[737]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Oct 23 11:51:08 OpenWrt daemon.notice pppd[737]: pppd 2.4.5 started by root, uid 0
Oct 23 11:51:08 OpenWrt daemon.err pppd[737]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Oct 23 11:51:08 OpenWrt daemon.err pppd[737]: This may cause serious connection problems.
Oct 23 11:51:08 OpenWrt kern.info kernel: [   16.670000] ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Oct 23 11:51:08 OpenWrt user.info sysinit: 'radio0' is disabled
Oct 23 11:51:09 OpenWrt user.info sysinit: 'radio0' is disabled
Oct 23 11:51:09 OpenWrt user.notice ifup: Enabling Router Solicitations on lan (br-lan)
Oct 23 11:51:09 OpenWrt kern.info kernel: [   17.410000] br-lan: port 1(eth0.1) entered forwarding state
Oct 23 11:51:11 OpenWrt user.info sysinit: Loading defaults
Oct 23 11:51:12 OpenWrt user.notice ifup: Enabling Router Solicitations on loopback (lo)
Oct 23 11:51:12 OpenWrt user.info sysinit: Loading synflood protection
Oct 23 11:51:12 OpenWrt user.info sysinit: Adding custom chains
Oct 23 11:51:13 OpenWrt user.info sysinit: Loading zones
Oct 23 11:51:14 OpenWrt user.info sysinit: Loading forwardings
Oct 23 11:51:14 OpenWrt user.info sysinit: Loading rules
Oct 23 11:51:15 OpenWrt user.info sysinit: Loading redirects
Oct 23 11:51:15 OpenWrt user.info sysinit: Loading includes
Oct 23 11:51:15 OpenWrt user.info sysinit: Loading interfaces
Oct 23 11:51:15 OpenWrt user.info firewall: adding lan (br-lan) to zone lan
Oct 23 11:51:17 OpenWrt authpriv.info dropbear[1242]: Running in background
Oct 23 11:51:17 OpenWrt daemon.info radvd[1249]: version 1.9.1 started
Oct 23 11:51:19 OpenWrt user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Oct 23 11:51:19 OpenWrt user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Oct 23 11:51:22 OpenWrt daemon.info dnsmasq[1300]: started, version 2.62 cachesize 150
Oct 23 11:51:22 OpenWrt daemon.info dnsmasq[1300]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
Oct 23 11:51:22 OpenWrt daemon.info dnsmasq-dhcp[1300]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Oct 23 11:51:22 OpenWrt daemon.info dnsmasq[1300]: using local addresses only for domain lan
Oct 23 11:51:22 OpenWrt daemon.warn dnsmasq[1300]: no servers found in /tmp/resolv.conf.auto, will retry
Oct 23 11:51:22 OpenWrt daemon.info dnsmasq[1300]: read /etc/hosts - 1 addresses
Oct 23 11:51:22 OpenWrt daemon.info dnsmasq-dhcp[1300]: read /etc/ethers - 0 addresses
Oct 23 11:51:22 OpenWrt user.info sysinit: setting up led USB
Oct 23 11:51:22 OpenWrt user.info sysinit: setting up led WLAN
Oct 23 11:51:23 OpenWrt daemon.warn pppd[737]: Timeout waiting for PADO packets
Oct 23 11:51:23 OpenWrt daemon.err pppd[737]: Unable to complete PPPoE Discovery
Oct 23 11:51:23 OpenWrt daemon.info pppd[737]: Exit.
Oct 23 11:51:23 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:23 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:24 OpenWrt daemon.info pppd[1337]: Plugin rp-pppoe.so loaded.
Oct 23 11:51:24 OpenWrt daemon.info pppd[1337]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Oct 23 11:51:24 OpenWrt daemon.notice pppd[1337]: pppd 2.4.5 started by root, uid 0
Oct 23 11:51:24 OpenWrt daemon.err pppd[1337]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Oct 23 11:51:24 OpenWrt daemon.err pppd[1337]: This may cause serious connection problems.
Oct 23 11:51:24 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:24 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:39 OpenWrt daemon.warn pppd[1337]: Timeout waiting for PADO packets
Oct 23 11:51:39 OpenWrt daemon.err pppd[1337]: Unable to complete PPPoE Discovery
Oct 23 11:51:39 OpenWrt daemon.info pppd[1337]: Exit.
Oct 23 11:51:39 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:39 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:39 OpenWrt daemon.info pppd[1370]: Plugin rp-pppoe.so loaded.
Oct 23 11:51:39 OpenWrt daemon.info pppd[1370]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Oct 23 11:51:39 OpenWrt daemon.notice pppd[1370]: pppd 2.4.5 started by root, uid 0
Oct 23 11:51:39 OpenWrt daemon.err pppd[1370]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Oct 23 11:51:39 OpenWrt daemon.err pppd[1370]: This may cause serious connection problems.
Oct 23 11:51:40 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:40 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:56 OpenWrt daemon.warn pppd[1370]: Timeout waiting for PADO packets
Oct 23 11:51:56 OpenWrt daemon.err pppd[1370]: Unable to complete PPPoE Discovery
Oct 23 11:51:56 OpenWrt daemon.info pppd[1370]: Exit.
Oct 23 11:51:56 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:56 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:57 OpenWrt daemon.info pppd[1398]: Plugin rp-pppoe.so loaded.
Oct 23 11:51:57 OpenWrt daemon.info pppd[1398]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Oct 23 11:51:57 OpenWrt daemon.notice pppd[1398]: pppd 2.4.5 started by root, uid 0
Oct 23 11:51:57 OpenWrt daemon.err pppd[1398]: Interface eth0.2 has MTU of 1452 -- should be at least 1500.
Oct 23 11:51:57 OpenWrt daemon.err pppd[1398]: This may cause serious connection problems.
Oct 23 11:51:57 OpenWrt daemon.info pppd[1398]: PPP session is 1560
Oct 23 11:51:57 OpenWrt daemon.warn pppd[1398]: Connected to 00:e0:fc:43:6a:04 via interface eth0.2
Oct 23 11:51:57 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:57 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:57 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:57 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:51:57 OpenWrt daemon.info pppd[1398]: Using interface pppoe-wan
Oct 23 11:51:57 OpenWrt daemon.notice pppd[1398]: Connect: pppoe-wan <--> eth0.2
Oct 23 11:51:57 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:51:57 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:52:04 OpenWrt daemon.info pppd[1398]: CHAP authentication succeeded
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: CHAP authentication succeeded
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: peer from calling number 00:E0:FC:43:6A:04 authorized
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: local  LL address fe80::78f3:0ce6:a7b8:b374
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: remote LL address fe80::0215:2cff:fe06:d01b
Oct 23 11:52:04 OpenWrt daemon.debug radvd[1252]: attempting to reread config file
Oct 23 11:52:04 OpenWrt daemon.debug radvd[1252]: resuming normal operation
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: local  IP address 213.41.244.197
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: remote IP address 178.132.16.253
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: primary   DNS address 195.5.209.150
Oct 23 11:52:04 OpenWrt daemon.notice pppd[1398]: secondary DNS address 194.79.128.150
Oct 23 11:52:04 OpenWrt daemon.notice netifd: Interface 'wan' is now up
Oct 23 11:52:05 OpenWrt user.notice ifup: Allowing Router Advertisements on wan (pppoe-wan)
Oct 23 11:52:05 OpenWrt user.notice ifup: Enabling Router Solicitations on wan (pppoe-wan)
Oct 23 11:52:05 OpenWrt user.info firewall: adding wan (pppoe-wan) to zone wan
Oct 23 11:54:09 OpenWrt authpriv.info dropbear[2124]: Child connection from 192.168.1.246:47209
Oct 23 11:54:11 OpenWrt authpriv.notice dropbear[2124]: Pubkey auth succeeded for 'root' with key md5 f3:5f:15:72:51:a3:54:f6:d2:aa:78:07:59:23:dc:7a from 192.168.1.246:47209

On the router, name resolution doesn't work after a reboot, so I still think there is a problem (as described earlier in the ticket), at least for people coming from 10.03.1.

As already said, I am ready to help. Please note I am not one of the previous reporters ; I tried to be polite and constructive so I do not understand why you seemed a bit upset by my answers. I am not used to reporting OpenWRT bugs (because 10.03.1 worked fine for me, even for IPv6 configuration) but I am not a technical newbie...

comment:20 Changed 5 years ago by victor@…

Same for me, since my last big update to Bleeding Edge, r33735 dnsmasq does not work properly anymore.
No nameservers at bootup, no DHCP for LAN on the ethernet interface.

No change at all in my UCI files whatsoever compared to previous build, and I never messed with any other conf files yet. Sorry for the not-very-informative report, but I really have no clue there, even after having tried quite a lot of stuff.

comment:21 Changed 5 years ago by anonymous

Problem still there in AA-rc1.

As said in 11824 (which seems duplicate), without "option ipv6 1" in pppoe config, everything is fine. With this option, /tmp/resolv.conf.auto remains empty.

Quick workaround is a cron job checking if file is empty and copying /tmp/resolv.conf.ppp when necessary, but would be better to understand the root cause.

Problem is there after reboot, but after some time of uptime, sometimes /tmp/resolv.conf.auto is populated correctly (ie without copying manually /tmp/resolv.conf.ppp).

comment:22 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r34500, will be backported to AA soon

comment:23 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:24 Changed 3 years ago by fschaefer.oss@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

It seems that this bug has not been fixed (completely) or is back.
Using bleeding edge (Chaos Calmer) I get:

...
Fri Oct 31 21:14:56 2014 kern.info kernel: [ 1451.480000] eth1: link up (100Mbps/Full duplex)
Fri Oct 31 21:14:56 2014 daemon.notice netifd: wan (3999): udhcpc: option -h NAME is deprecated, use -x hostname:NAME
Fri Oct 31 21:14:56 2014 daemon.notice netifd: wan (3999): udhcpc (v1.22.1) started
Fri Oct 31 21:14:56 2014 daemon.notice netifd: wan (3999): Sending discover...
Fri Oct 31 21:14:57 2014 daemon.notice netifd: wan (3999): Sending select for xxx.xxx.xxx.xxx...
Fri Oct 31 21:14:57 2014 daemon.notice netifd: wan (3999): Lease of xxx.xxx.xxx.xxx obtained, lease time 3325
Fri Oct 31 21:14:57 2014 daemon.warn dnsmasq[1869]: no servers found in /tmp/resolv.conf.auto, will retry
Fri Oct 31 21:14:57 2014 daemon.notice netifd: Interface 'wan' is now up
Fri Oct 31 21:14:57 2014 user.notice firewall: Reloading firewall due to ifup of wan (eth1)
Fri Oct 31 21:14:57 2014 user.notice root: DEBUG: NTPCLIENT: NTP SERVER #1 NOT AVAILABLE
Fri Oct 31 21:14:57 2014 user.notice root: DEBUG: NTPCLIENT: NTP SERVER #2 NOT AVAILABLE
Fri Oct 31 21:14:57 2014 user.notice root: DEBUG: NTPCLIENT: NTP SERVER #3 NOT AVAILABLE
Fri Oct 31 21:14:57 2014 user.notice root: DEBUG: NTPCLIENT: NTP SERVER #4 NOT AVAILABLE

ntpclient start fails due to this.
A while later (after a DNS lookup has been triggered):

Fri Oct 31 21:25:39 2014 daemon.info dnsmasq[1869]: reading /tmp/resolv.conf.auto
Fri Oct 31 21:25:39 2014 daemon.info dnsmasq[1869]: using local addresses only for domain lan
Fri Oct 31 21:25:39 2014 daemon.info dnsmasq[1869]: using nameserver xxx.xxx.xxx.xxx#53
Fri Oct 31 21:25:39 2014 daemon.info dnsmasq[1869]: using nameserver xxx.xxx.xxx.xxx#53
...

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.