Modify

Opened 6 years ago

Last modified 18 months ago

#11495 reopened defect

Luci Diagnostics nslookup error message

Reported by: Andre Maree <andrem@…> Owned by: jow
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

When using the nslookup diagnostics functionality Luci returns an error message stating "can't resolve ' (null) ' : name or service not known "

A number of other services such as Darkstat also fails to resolve hosts names, possibly related?

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by nbd

  • Owner changed from developers to jow
  • Status changed from new to assigned

comment:2 Changed 6 years ago by jow

Not a LuCI problem, seems related to busybox:

root@uplink:~# nslookup openwrt.org
nslookup: can't resolve '(null)': Name or service not known

Name:      openwrt.org
Address 1: 78.24.191.177 openwrt.org
root@uplink:~#

comment:3 Changed 6 years ago by anonymous

The same "can't resolve" message is seen on attempt to resolve local (xxx.lan) names.
The message disappears when nslookup is directly pointed to localhost:

root@openwrt:~# nslookup openwrt.org localhost

Name: openwrt.org
Address 1: 78.24.191.177 openwrt.org
root@openwrt:~#

comment:4 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r32555

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:6 Changed 2 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Got this issue in recent trunk r48648

nslookup d7800
nslookup: can't resolve '(null)': Name does not resolve

Name:      d7800
Address 1: 192.168.111.222 d7800.xxx.org
nslookup d7800 localhost
Server:    127.0.0.1
Address 1: 127.0.0.1 localhost

Name:      d7800
Address 1: 192.168.111.222 d7800.xxx.org

comment:7 follow-up: Changed 2 years ago by nbd

  • Resolution set to duplicate
  • Status changed from reopened to closed

the musl nslookup issue is tracked in #18333

comment:8 in reply to: ↑ 7 ; follow-up: Changed 20 months ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to nbd:

the musl nslookup issue is tracked in #18333


No, this is not a duplicate of that issue. As you can see above, nslookup has this issue even when there is no explicit server on the command line. The issue in 18333 is that nslookup ignores the explicit server and always uses the local server. Not the same thing.

comment:9 in reply to: ↑ 8 Changed 20 months ago by anonymous

It appears that this is fixed in the upstream dnsmasq 2.76. One line had to be added to one of the patches, but it compiled and works for me. Just needs to be pulled into the openwrt main branch.

Replying to anonymous:

Replying to nbd:

the musl nslookup issue is tracked in #18333


No, this is not a duplicate of that issue. As you can see above, nslookup has this issue even when there is no explicit server on the command line. The issue in 18333 is that nslookup ignores the explicit server and always uses the local server. Not the same thing.

comment:10 Changed 20 months ago by anonymous

the problem still there in current trunk
Bleeding Edge, r49388
root@openwrt:~# nslookup www.google.com
nslookup: can't resolve '(null)': Name does not resolve

Name: www.google.com
Address 1: 172.217.1.36 lax17s01-in-f4.1e100.net
Address 2: 2607:f8b0:4007:80b::2004 lax02s23-in-x04.1e100.net
root@openwrt:~# uname -a
Linux openwrt 4.1.23 #1 Sun Jun 19 01:49:12 UTC 2016 mips GNU/Linux
root@openwrt:~#

comment:11 Changed 18 months ago by anonymous

I'm seeing the same issue on Bleeding Edge, r48626

root@openwrt:~# nslookup www.google.com
nslookup: can't resolve '(null)': Name does not resolve

Name: www.google.com
Address 1: 216.239.38.120 any-in-2678.1e100.net

root@openwrt:~# uname -a
Linux openwrt 4.1.16 #191 Thu Aug 4 02:43:20 UTC 2016 mips GNU/Linux

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.