Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11470 closed defect (duplicate)

TP-Link WR2543ND VLAN4K does not appear to work

Reported by: lth@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

First of all a bit of background. I am currently using OpenWRT/Trunk on a TP-Link WR1043ND as my primary router and it works fine. My Internet connection is a bit peculiar as it requires (!!!) the Internet port to be using VLAN 500 and VLAN 600 both tagged (one is for Internet using PPPOE and the other for some IP TV I never bothered using). This setup works fine on the 1043.

Now I have been trying to configure the same setup on a WR2543ND and while I can configure everything the same way the PPPOE connection times out:

daemon.warn pppd[2578]: Timeout waiting for PADO packets

If I ssh into the router everything appears to be in order and the VLAN interface does exist:

75: eth0.500@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP

The relevant part of /etc/config/network

config interface 'wan'                                                                                                                                                                                                                                                         
        option _orig_ifname 'wan'                                                                                                                                                                                                                                              
        option _orig_bridge 'false'                                                                                                                                                                                                                                            
        option proto 'pppoe'                                                                                                                                                                                                                                                   
        option username 'xxx@unifi'                                                                                                                                                                                                                                      
        option password 'xxx'                                                                                                                                                                                                                                             
        option ifname 'eth0.500'                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                               
config switch                                                                                                                                                                                                                                                                  
        option name 'switch0'                                                                                                                                                                                                                                                  
        option reset '1'                                                                                                                                                                                                                                                       
        option enable_vlan '1'                                                                                                                                                                                                                                                 
        option enable_vlan4k '1'                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                               
config switch_vlan                                                                                                                                                                                                                                                             
        option device 'switch0'                                                                                                                                                                                                                                                
        option vlan '1'                                                                                                                                                                                                                                                        
        option ports '1 2 3 9t'                                                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                               
config switch_vlan                                                                                                                                                                                                                                                             
        option device 'switch0'                                                                                                                                                                                                                                                
        option vlan '500'                                                                                                                                                                                                                                                      
        option ports '0t 5t 8t 9t'   

I can only assume that vlan500 is not tagged on port 0.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Lars Bøgild Thomsen <lth@…>

First of all this does appear to be a duplicate of /ticket/11250.html - sorry about that.

Anyway - reading the other bug report I can basically confirm this.

root@gw:~ swconfig dev switch0 show
Global attributes:
	enable_vlan: 1
	enable_vlan4k: 1
	max_length: 1
Port 0:
	mib: Port 0 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:0 link:down
Port 1:
	mib: Port 1 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:1 link:down
Port 2:
	mib: Port 2 MIB counters
IfInOctets                          : 89573
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 531
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 190003
EtherStatsUnderSizePkts             : 6
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 346
EtherStatsPkts65to127Octets         : 363
EtherStatsPkts128to255Octets        : 191
EtherStatsPkts256to511Octets        : 100
EtherStatsPkts512to1023Octets       : 3
EtherStatsPkts1024to1518Octets      : 49
EtherStatsMulticastPkts             : 102
EtherStatsBroadcastPkts             : 55
IfOutOctets                         : 100430
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 370
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:2 link:up speed:100baseT full-duplex txflow rxflow auto
Port 3:
	mib: Port 3 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:3 link:down
Port 4:
	mib: Port 4 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 600
	link: port:4 link:down
Port 5:
	mib: Port 5 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:5 link:down
Port 6:
	mib: Port 6 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:6 link:down
Port 7:
	mib: Port 7 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:7 link:down
Port 8:
	mib: Port 8 MIB counters
IfInOctets                          : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:8 link:down
Port 9:
	mib: Port 9 MIB counters
IfInOctets                          : 111318
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
EtherStatsFragments                 : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 370
EtherStatsDropEvents                : 0
EtherStatsOctets                    : 203643
EtherStatsUnderSizePkts             : 153
EtherOversizeStats                  : 0
EtherStatsPkts64Octets              : 346
EtherStatsPkts65to127Octets         : 363
EtherStatsPkts128to255Octets        : 191
EtherStatsPkts256to511Octets        : 100
EtherStatsPkts512to1023Octets       : 3
EtherStatsPkts1024to1518Octets      : 49
EtherStatsMulticastPkts             : 102
EtherStatsBroadcastPkts             : 202
IfOutOctets                         : 92325
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 147
IfOutUcastPkts                      : 531
IfOutMulticastPkts                  : 102
IfOutBroadcastPkts                  : 55
OutOampduPkts                       : 0
InOampduPkts                        : 0
PktgenPkts                          : 0

	pvid: 1
	link: port:9 link:up speed:1000baseT full-duplex txflow rxflow 
VLAN 1:
	info: VLAN 1: Ports: '1239t', members=020e, untag=000e, fid=0
	ports: 1 2 3 9t 

I guess the interesting part here is that it reports vlan4k to be enabled. However:

root@gw:~# swconfig dev switch0 vlan 1 show
VLAN 1:
        info: VLAN 1: Ports: '1239t', members=020e, untag=000e, fid=0
        ports: 1 2 3 9t 
root@gw:~# swconfig dev switch0 vlan 500 show
VLAN 500:
        info: ???
        ports: ???

comment:2 Changed 6 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.