Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11451 closed defect (duplicate)

Upgrading TL-WR1043ND to trunk r31708 results ath9k kernel warning

Reported by: duvi Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

After 7 hours uptime this appeared in the log:

[24796.420000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000286c0
[24796.430000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
[24796.440000] ------------[ cut here ]------------
[24796.450000] WARNING: at /mnt/hda/openwrt/trunk/build_dir/linux-ar71xx_generic/compat-wireless-2012-04-17/drivers/net/wireless/ath/ath9k/recv.c:531 ath_stoprecv+0xd4/0x10c [ath9k]()
[24796.460000] Modules linked in: usblp ath79_wdt ohci_hcd ledtrig_usbdev xt_HL xt_hl xt_ecn ipt_ECN xt_CLASSIFY xt_time xt_tcpmss xt_statistic xt_mark xt_length xt_DSCP xt_dscp xt_string xt_layer7 ipt_MASQUERADE iptable_nat nf_nat xt_recent xt_helper xt_connmark xt_connbytes xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd pppoe pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables sit tunnel4 tun ppp_async ppp_generic slhc ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) usbcore usb_common nls_base ts_fsm ts_bm ts_kmp crc_ccitt ipv6 cfg80211(O) compat(O) arc4 aes_generic crypto_algapi leds_gpio gpio_button_hotplug(O)
[24796.530000] Call Trace:
[24796.530000] [<80268458>] dump_stack+0x8/0x34
[24796.540000] [<800715dc>] warn_slowpath_common+0x78/0xa4
[24796.540000] [<80071620>] warn_slowpath_null+0x18/0x24
[24796.550000] [<8142711c>] ath_stoprecv+0xd4/0x10c [ath9k]
[24796.550000] [<81422bec>] ath_descdma_cleanup+0x3d0/0xbb4 [ath9k]
[24796.560000]
[24796.560000] ---[ end trace 842a2d23627042e1 ]---

What's more important, is that there was no wireless traffic (both rx packets 0), and not a single station connected yet since reboot, when the warning happened.

wlan0     Link encap:Ethernet  HWaddr 00:23:CD:19:11:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7932 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:4137752 (3.9 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:23:CD:19:11:51
          inet addr:192.168.134.1  Bcast:192.168.134.255  Mask:255.255.255.0
          inet6 addr: fe80::23:cdff:fe19:1151/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:1076 (1.0 KiB)

I'll check if stations are still able to connect after this.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by duvi

Update: clients were still able to connect.

May 14 10:10:55 OpenWrt daemon.info hostapd: wlan0-1: STA 64:b9:e8:8c:d6:1a IEEE 802.11: authenticated
May 14 10:10:55 OpenWrt daemon.info hostapd: wlan0-1: STA 64:b9:e8:8c:d6:1a IEEE 802.11: associated (aid 1)
May 14 10:10:55 OpenWrt daemon.info hostapd: wlan0-1: STA 64:b9:e8:8c:d6:1a RADIUS: starting accounting session 0000000E-00000000
May 14 10:10:55 OpenWrt daemon.info hostapd: wlan0-1: STA 64:b9:e8:8c:d6:1a WPA: pairwise key handshake completed (RSN)

comment:2 Changed 6 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #9654

comment:3 Changed 6 years ago by duvi

Are you sure this is a duplicate? I'm not seeing this kernel warning in the other ticket.

comment:4 Changed 6 years ago by nbd

yes, the warning only happens the first time that rx dma fails to stop.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.