Modify

Opened 6 years ago

Closed 3 years ago

#11433 closed defect (wontfix)

Pyload requires packet "spidermonkey, ossp-js, pyv8 or rhino"

Reported by: spamjunkeater@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

opkg could install pyload but without JavaScript Engine.
If JS engine support is missing at pyload, it cannot download files almost all hosts. Instead give error of:
failed'Parse error (Unknown response - ajax_check_url) - plugin may be out of date'

So pyload became useless without supported JS engine...

Please add one of the this packages to let users download with pyload.
Supported JS engines by pyload are:
*spidermonkey
*ossp-js
*pyv8
*rhino

Attachments (0)

Change History (15)

comment:1 Changed 6 years ago by ryzhov_al

Please note, that ossp-js will be installed with a pyload. Just take a look at

$ opkg info pyload | grep Depends

comment:2 Changed 6 years ago by EUA <spamjunkeater@…>

root@TPLink-WR703N:/etc/init.d# opkg info pyload | grep Depends
Depends: python, pyopenssl, python-curl, python-crypto, python-django, python-expat, python-imaging-library, python-sqlite3, js, tesseract, unrar

Also cannot find ossp-js (or the others) package on the address:

http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/

comment:3 Changed 6 years ago by EUA <spamjunkeater@…>

Also it depends on json also , started from 0.4.8...

comment:4 Changed 6 years ago by anonymous

bump

comment:5 Changed 5 years ago by cave

Spidermonkey, ossp-js, pyv8 or rhino missing for pyLoad ... :(

bump

comment:6 Changed 5 years ago by Oliver Ertl <oliver@…>

bump

comment:7 Changed 4 years ago by anonymous

bump

comment:8 Changed 4 years ago by anonymous

bump too

comment:9 Changed 4 years ago by anonymous

bump too

comment:10 Changed 4 years ago by anonymous

Even I need an help for this :(

comment:11 Changed 4 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed in r40647.

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:13 Changed 3 years ago by spamjunkeater@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hey!
I said JS Engine. Not TESSERACT!

comment:14 Changed 3 years ago by ryzhov_al

pyLoad is not maintained anymore and moved to oldpackages feed. It will not be updated in anyway until personal maintainer will be found.

You may be volunteer to maintain pyLoad, no?:)

https://forum.openwrt.org/viewtopic.php?id=51078

comment:15 Changed 3 years ago by nbd

  • Resolution set to wontfix
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.