Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11404 closed enhancement (duplicate)

add package for daemonlogger

Reported by: Robert Vineyard <vineyard@…> Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: daemonlogger, makefile, package, patch Cc:

Description

Daemonlogger is a packet logger and soft tap developed by Martin Roesch.
This patch adds a Makefile to build it as an OpenWRT ipk package.

Note: This patch is against trunk, but it also builds cleanly on Backfire.

Signed-off-by: Robert Vineyard <vineyard@tuffmail.com>

---

Index: feeds/packages/net/daemonlogger/Makefile
===================================================================
--- feeds/packages/net/daemonlogger/Makefile	(revision 0)
+++ feeds/packages/net/daemonlogger/Makefile	(revision 0)
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2007-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=daemonlogger
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=463
+PKG_SOURCE_URL:=http://www.snort.org/downloads/
+PKG_CAT:=zcat
+PKG_MD5SUM:=acb64aa6cd5777e297569f100b5c39ee
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/daemonlogger
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpcap +libdnet
+  TITLE:=Software Network Tap
+  URL:=http://www.snort.org/snort-downloads/additional-downloads
+endef
+
+CONFIGURE_VARS += \
+	BUILD_CC="$(TARGET_CC)" \
+	HOSTCC="$(HOSTCC)"
+
+MAKE_FLAGS := CCOPT="$(TARGET_CFLAGS)" INCLS="-I. $(TARGET_CPPFLAGS)"
+
+define Package/daemonlogger/install
+	$(INSTALL_DIR) $(1)/usr/bin
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daemonlogger $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,daemonlogger))

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by nbd

no need to create a ticket when you've already posted the patch to the list.
the mailing list is the preferred form of submitting patches.

comment:2 Changed 6 years ago by blogic

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of patchwork listed patch ... closing ... please refrain from increasing the noise even more

comment:3 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.