Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11403 closed defect (invalid)

make fail of backfire 10.03.01 for TP-Link TL-WR1043ND

Reported by: hayderlejri@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: 10.03.1
Keywords: TL-WR1043ND make fail Cc:

Description

hi all

in the SDK folder tool for atheros AR71xx , I taped make in order to
compile the new configuration filled in the SDK: chose target then tape
make

build fails at the end with this message format :

cc -O2 -I/home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/staging_dir/host/include -include
 endian.h -o /home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/build_dir/host/firmware-
 utils/bin/imagetag src/imagetag.c
 In file included from src/imagetag.c:19:0:
 src/bcm_tag.h:1:6: error: expected '=', ',', ';', 'asm' or '__attribute__'
 before '.' token
 src/imagetag.c:46:24: error: 'NUM_PIRELLI' undeclared here (not in a
 function)
 src/imagetag.c:46:37: error: 'BOARDID_LEN' undeclared here (not in a
 function)
 src/imagetag.c:46:52: error: 'PIRELLI_BOARDS' undeclared here (not in a
 function)
 src/imagetag.c: In function 'tagfile':
 src/imagetag.c:135:17: error: storage size of 'tag' isn't known
 src/imagetag.c:140:22: error: 'IMAGETAG_CRC_START' undeclared (first use
 in this function)
 src/imagetag.c:140:22: note: each undeclared identifier is reported only
 once for each function it appears in
 src/imagetag.c:145:24: error: storage size of 'intchar' isn't known
 src/imagetag.c:149:25: error: invalid application of 'sizeof' to
 incomplete type 'struct bcm_tag'
 src/imagetag.c:252:31: error: 'TAGVER_LEN' undeclared (first use in this
 function)
 src/imagetag.c:270:45: error: 'RSASIG_LEN' undeclared (first use in this
 function)
 src/imagetag.c:274:45: error: 'TAGLAYOUT_LEN' undeclared (first use in
 this function)
 src/imagetag.c:285:3: error: invalid application of 'sizeof' to incomplete
 type 'union int2char'
 src/imagetag.c:287:10: error: invalid application of 'sizeof' to
 incomplete type 'union int2char'
 src/imagetag.c:289:9: error: invalid application of 'sizeof' to incomplete
 type 'union int2char'
 src/imagetag.c:290:9: error: invalid application of 'sizeof' to incomplete
 type 'union int2char'
 src/imagetag.c:291:2: error: invalid application of 'sizeof' to incomplete
 type 'union int2char'
 src/imagetag.c:292:2: error: invalid application of 'sizeof' to incomplete
 type 'union int2char'
 make[3]: *** [/home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/build_dir/host/firmware-
 utils/.built] Error 1
 make[3]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/tools/firmware-utils'
 make[2]: *** [tools/firmware-utils/compile] Error 2
 make[2]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1'
 make[1]: *** [/home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/staging_dir/target-
 mips_r2_uClibc-0.9.30.1/stamp/.tools_install_nnynn] Error 2
 make[1]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-
 Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1'
 make: *** [world] Error 2

Attachments (0)

Change History (12)

comment:1 follow-up: Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

see #11401

comment:2 Changed 6 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:3 Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:4 in reply to: ↑ 1 Changed 6 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to jow:

see #11401

lease delete #11401 and conserve this ticket more clear

comment:5 follow-up: Changed 6 years ago by jow

Both tickets are equally incomprehensible but okay...

comment:6 in reply to: ↑ 5 Changed 6 years ago by anonymous

Replying to jow:

Both tickets are equally incomprehensible but okay...

hi jow , i downloaded the SDK from
http://downloads.openwrt.org/backfire/10.03.1-rc6/ar71xx/ in order to compile the backfire 10.03.1 for TP-linl TL WR1043ND , the added sources (backfire 10.03.1 filesystem to SDK concerned filesystem )

then tape make menuconfig

i have correct interface configuration so i can select target and profile

after exit and saving the new configuration , i tape make command , but fails at the end of buil

the tape make V=99 in order to have more details about errors

comment:7 follow-up: Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

It seems your checkout is corrupt. The file tools/firmware-utils/src/bcm_tag.h is supposed to be a symlink which gets resulved when you checkout the source, but in your case it appears to be a text file containing the word "link" followed by a path.

Please ensure that your svn client is checking the source out properly. ALso perform the checkout on the target system, do not do it e.g. on windows and copy the source afterwards.

comment:8 in reply to: ↑ 7 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to jow:

It seems your checkout is corrupt. The file tools/firmware-utils/src/bcm_tag.h is supposed to be a symlink which gets resulved when you checkout the source, but in your case it appears to be a text file containing the word "link" followed by a path.

Please ensure that your svn client is checking the source out properly. ALso perform the checkout on the target system, do not do it e.g. on windows and copy the source afterwards.

thank you for your reply jaw , I restarted all from the beginning and downloaded the source via : svn co svn://svn.openwrt.org/openwrt/backfire_10.03.1 and the listed errors when SDK make disappeared

otherwise , other errors appeared when installing toolchain/gcc through buil process
make [3] toolchain /gcc install

here are more details after taping make V=99

build/genattrtab.o build/rtl.o build/read-rtl.o build/ggc-none.o build/vec.o build/min-insn-modes.o build/gensupport.o build/print-rtl.o build/errors.o ../build-i686-linux-gnu/libiberty/libiberty.a
build/genattrtab /home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/build_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/gcc-4.3.3/gcc/config/mips/mips.md \
          insn-conditions.md > tmp-attrtab.c
make[6]: *** [s-attrtab] Error 1
make[6]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/build_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/gcc-4.3.3-final/gcc'
make[5]: *** [all-gcc] Error 2
make[5]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/build_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/gcc-4.3.3-final'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/build_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/gcc-4.3.3-final'
make[3]: *** [/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/stamp/.gcc_installed] Error 2
make[3]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/toolchain/gcc'
make[2]: *** [toolchain/gcc/install] Error 2
make[2]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1'
make[1]: *** [/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc-0.9.30.1/stamp/.toolchain_install] Error 2
make[1]: Leaving directory `/home/hlejri/OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1/backfire_10.03.1'
make: *** [world] Error 2

the problem is in the gcc 4.3.3 compiler and associated libraries ?

thanks

comment:9 follow-up: Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

Your machine ran out of virtual memory during build.

comment:10 in reply to: ↑ 9 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to jow:

Your machine ran out of virtual memory during build.

exact , i use colinux , how can i fix this ?

thanks

hayder

comment:11 Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Please stop reopening this ticket for every minor issue you encounter - this is a bug tracker and no support forum! So far none of your issues where OpenWrt problems but issues with your particular setup. Refer to the forum or mailing list for general help.

comment:12 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.