Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11367 closed defect (fixed)

syscalls hang indefinitely on an ntfs-3g file system mountpoint

Reported by: Lukasz Golec-Biernat <mojedokumenty+openwrt@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: ntfs-3g ntfs hang Cc:

Description

Any commands accessing a ntfs-3g mountpoint hang indefinitely (df, ls, find all hang on the ntfs mountpoint).

Upon inspection with strace, it appears the syscalls fail to return when accessing the mountpoint:

statfs("/ntfs", 

A manual mount is successful with the following info logged:

$ mount /dev/sda1 /ntfs
$ logread -f
Apr 29 22:52:19 multicast daemon.notice ntfs-3g[4877]: Version 2011.4.12 integrated FUSE 27
Apr 29 22:52:19 multicast daemon.notice ntfs-3g[4877]: Mounted /dev/sda1 (Read-Write, label "ntfs", NTFS 3.1)
Apr 29 22:52:19 multicast daemon.notice ntfs-3g[4877]: Cmdline options: 
Apr 29 22:52:19 multicast daemon.notice ntfs-3g[4877]: Mount options: allow_other,nonempty,atime,fsname=/dev/sda1,blkdev,blksize=4096
Apr 29 22:52:19 multicast daemon.notice ntfs-3g[4877]: Ownership and permissions disabled, configuration type 1
$ grep fuse /proc/mounts
/dev/sda1 /ntfs fuseblk rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0

The modules in use are:

$ opkg list-installed |grep fuse
kmod-fuse - 3.3.3-1
ntfs-3g - 2011.4.12-1-fuseint

Trunk release: r31488

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by anonymous

It seems like FUSE dcache bug and there are two patches for brcm47xx with a workaround. I don't know why they're applied only for this architecture, but ar71xx seems to be plagued with this problem too.

Quick and dirty solution that might work is to copy patches 301-kmod-fuse-dcache-bug-r4k.patch and 302-kmod-fuse-dcache-bug-fuse.patch from target/linux/brcm47xx/patches-3.3 to target/<your architecture>/patches-3.3.

This solution worked on my router (ar71xx, trunk r31576), but ntfs-3g performance is very disappointing compared to other filesystems and even NTFS via kernel driver.

comment:2 Changed 6 years ago by flux242@…

suggested solution is proved to work with the latest trunk (r32018) on the ar71xx platform (buffalo WZR-HP-A300H). Please consider to add these patch files into the ar71xx branch untill this problem is fixed by the ntfs-3g developer

comment:3 Changed 6 years ago by djbruno@…

I can confirm that this bug is happening to me on the ar71xx platform as well.

comment:4 Changed 6 years ago by anonymous

This bug also happening on Linksys WRT160NL which is ar71xx.

comment:5 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r32395

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.