Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11318 closed defect (fixed)

Failed to join a STA network in the new build (After switching to kernel 3.3.2 on ar71xx platform)

Reported by: anonymous Owned by: nbd
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

I've problem having an OpenWRT router joining an STA network on another OpenWRT router after switching to kernel 3.3.2 on the new build. The previous build (on 3.2 kernel works flawlessly).

The setup is like this:

Internet -- OpenWRT Router WNDR3700 -- OpenWRT Router WZR-HP-AG300H

The build that it is still working is R31345, the new build is right after updating to kernel 3.3.2 (Can't recall build number since I've rolled back to R31345 already).

Don't have a lot of logs (cause I've already rolled back) but basically it shows that the AG300H seems repeating associated with the WNDR3700. The AG300H is using a static IP address and that's how I rolled back to the working build using Ethernet cable.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by duvi

I'm facing the same problem, after upgrading the main AP to 3.3.2. It's a Mikrotik RB433UAH with an R52N card, so it uses ath9k.
Openwrt client devices (Fonera) can't connect any more using wds (and problably also without wds).

comment:2 Changed 6 years ago by anonymous

I confirm the same bug with r31360, on TL-WR1043ND as the WDS AP, and TL-WR940N as WDS client with latest vendor firmware.
The client is authenticating in every 5 seconds, making itself and the devices behind it unreachable.
I restored r29918 with kernel 2.6.39 to the 1043ND and the issue is gone.

comment:3 Changed 6 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

please try r31515

comment:4 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed in r31517

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.