Modify

Opened 6 years ago

Last modified 4 years ago

#11279 new defect

Multiple SSID order matters with respect to encryption type

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: 10.03.1
Keywords: Cc:

Description

After creation of multiple SSID's on a single interface (specifically on both a Netgear WNDR3700v1 and WNDR3700v2) the order of the interfaces seems to be important from how they are stored in /etc/config/wireless

=====================================================
Test 1:
=====================================================
config 'wifi-device' 'radio0'
		option 'type' 'mac80211'
		option 'macaddr' 'aa:bb:cc:dd:ee:ff'
		list 'ht_capab' 'SHORT-GI-40'
		list 'ht_capab' 'TX-STBC'
		list 'ht_capab' 'RX-STBC1'
		list 'ht_capab' 'DSSS_CCK-40'
		option 'txpower' '27'
		option 'country' 'US'
		option 'channel' '11'
		option 'hwmode' '11ng'
		option 'htmode' 'HT20'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'WPA1'
		option 'key' '1234'
		option 'network' 'lan'
		option 'encryption' 'psk2+ccmp'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'Wep1'
		option 'encryption' 'wep-shared'
		option 'key' '1'
		option 'key1' '11111111111111111111111111'
		option 'network' 'WepNet'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'WPA2'
		option 'network' 'lan'
		option 'key' '2345'
		option 'encryption' 'psk2+ccmp'


WPA1 works as expected, as does WEP1, however WPA2 will never authenticate properly

=====================================================
Test 2:
=====================================================
config 'wifi-device' 'radio0'
		option 'type' 'mac80211'
		option 'macaddr' 'aa:bb:cc:dd:ee:ff'
		list 'ht_capab' 'SHORT-GI-40'
		list 'ht_capab' 'TX-STBC'
		list 'ht_capab' 'RX-STBC1'
		list 'ht_capab' 'DSSS_CCK-40'
		option 'txpower' '27'
		option 'country' 'US'
		option 'channel' '11'
		option 'hwmode' '11ng'
		option 'htmode' 'HT20'
config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'Wep1'
		option 'encryption' 'wep-shared'
		option 'key' '1'
		option 'key1' '11111111111111111111111111'
		option 'network' 'lan'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'WPA1'
		option 'key' '1234'
		option 'network' 'lan'
		option 'encryption' 'psk2+ccmp'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'WPA2'
		option 'network' 'lan'
		option 'key' '2345'
		option 'encryption' 'psk2+ccmp'

WEP1 works, WPA1 and WPA2 will never authenticate

=====================================================
Test 3
=====================================================
config 'wifi-device' 'radio0'
		option 'type' 'mac80211'
		option 'macaddr' 'aa:bb:cc:dd:ee:ff'
		list 'ht_capab' 'SHORT-GI-40'
		list 'ht_capab' 'TX-STBC'
		list 'ht_capab' 'RX-STBC1'
		list 'ht_capab' 'DSSS_CCK-40'
		option 'txpower' '27'
		option 'country' 'US'
		option 'channel' '11'
		option 'hwmode' '11ng'
		option 'htmode' 'HT20'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'WPA1'
		option 'key' '1234'
		option 'network' 'lan'
		option 'encryption' 'psk2+ccmp'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'WPA2'
		option 'network' 'lan'
		option 'key' '2345'
		option 'encryption' 'psk2+ccmp'

config 'wifi-iface'
		option 'device' 'radio0'
		option 'mode' 'ap'
		option 'ssid' 'Wep1'
		option 'encryption' 'wep-shared'
		option 'key' '1'
		option 'key1' '11111111111111111111111111'
		option 'network' 'lan'

All 3 networks work as expected

=====================================================

I haven't seen anything that indicates that the order matters, and the only way to fix this without deleting and readding is to edit /etc/config/wireless directly and force a wireless restart, or reboot.

I'm also unsure if this is more a luci bug (the web interface) or how the wireless is brought up. Filing it against luci for now.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by jow

  • Component changed from luci to base system
  • Owner set to developers

Not a LuCI issue.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.