Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11261 closed defect (fixed)

ar71xx with new trunk, WDS client mode cannot get IP from dhcp server

Reported by: anonymous Owned by: nbd
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Recently I have tried trunk r31214 and 21219 for ar71xx
but WDS client mode (WDS STA) seems not working, can't get IP from dhcp server, in static IP mode it still can't communicate with the AP.
If revert back to trunk r30xxx no such problem.
is it possible to fix it?

Attachments (0)

Change History (17)

comment:1 Changed 6 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

comment:2 Changed 6 years ago by anonymous

Here is some more info for developers.
WDS client side, using today latest r31219
WDS AP side, using r30919
network is working.

For WDS AP also update to r31219, or any version after 30919.
Wifi status is connected, but WDS client cannot communicate to WDS AP, cannot get IP from dhcp server, and even static IP used still not work.
(all settings untouched)
It seems that WDS AP has problems.

comment:3 Changed 6 years ago by anonymous

Finally I've found what's the problem is.
It is due to non-ASCII characters ESSID.
However in r30919 or older builds all don't have this problem.
And this problem only occur in WDS, but doesn't affect normal AP via STA.

comment:4 Changed 6 years ago by anonymous

Another problem, if WDS AP is "hidden" ESSID,
WDS STA connection established, but packets not going through,
means that no connection at all.

comment:5 Changed 6 years ago by Elphidium

On a rspro with r31285 r52h ath5k mode ap wds i got:

root@rspro:~# iwinfo wlan0-1 assoclist
F6:EC:xx:xx:xx:xx  -54 dBm / -94 dBm (SNR 40)  5160 ms ago
        RX: 54.0 MBit/s, MCS 0, 20MHz                    903 Pkts.
        TX: 1.0 MBit/s, MCS 0, 20MHz                       3 Pkts.

F6:EC:xx:xx:xx:xx  -57 dBm / -94 dBm (SNR 37)  281130 ms ago
        RX: 1.0 MBit/s, MCS 0, 20MHz                       4 Pkts.
        TX: 1.0 MBit/s, MCS 0, 20MHz                       3 Pkts.

root@rspro:~#
root@rspro:~# iwinfo wlan0-1.sta1 assoclist
F6:EC:38:A7:6E:31  -57 dBm / -94 dBm (SNR 37)  1864400 ms ago
        RX: 1.0 MBit/s, MCS 0, 20MHz                       4 Pkts.
        TX: 1.0 MBit/s, MCS 0, 20MHz                       3 Pkts.

root@rspro:~#

wlan0-1   Link encap:Ethernet  HWaddr 02:02:xx:xx:xx:xx
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1800 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:361 (361.0 B)  TX bytes:463575 (452.7 KiB)

wlan0-1.sta1 Link encap:Ethernet  HWaddr 00:02:xx:xx:xx:xx
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

On wr741nd v2 r31285 mode sta wds i got:

root@wr741:~# iwinfo wlan0-1 assoclist
02:02:xx:xx:xx:xx  -63 dBm / -92 dBm (SNR 29)  511250 ms ago
        RX: 1.0 MBit/s, MCS 0, 20MHz                   10709 Pkts.
        TX: 54.0 MBit/s, MCS 0, 20MHz                   1336 Pkts.

root@wr741:~#

wlan0-1   Link encap:Ethernet  HWaddr F6:EC:xx:xx:xx:xx
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1701 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:992 (992.0 B)  TX bytes:444093 (433.6 KiB)

When it used to work, on ap side wlan0-1 does not show wds sta via iwinfo, only in wlan0-1.sta1. Hope this helps.

comment:6 Changed 6 years ago by Elphidium

Mine got working again in r31429.
Thanks a lot !

comment:7 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:8 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

It doesn't seem to be fixed.
WDS Clients (ar71xx or brcm43xx) still cannot get an IP from DHCP server via WDS Access Point (ar71xx). I do not use non-ASCII characters in ESSID.
I use r31441.

comment:9 Changed 6 years ago by duvi

Something like the same here also.

AP: ath9k, wds mode
Log:

Apr 24 13:17:28 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:28 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:32 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:32 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:36 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:36 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:40 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:40 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:44 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:44 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:48 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:48 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:52 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:52 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:17:56 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:17:56 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)
Apr 24 13:18:00 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: authenticated
Apr 24 13:18:00 OpenWrt daemon.info hostapd: wlan1: STA 00:18:84:2a:22:4d IEEE 802.11: associated (aid 1)

Station: ath5k, wds mode
Log:

Jan  1 01:00:54 OpenWrt kern.debug kernel: wlan0: authenticate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:00:54 OpenWrt kern.debug kernel: wlan0: authenticated
Jan  1 01:00:54 OpenWrt kern.debug kernel: wlan0: associate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:00:54 OpenWrt kern.debug kernel: wlan0: RX ReassocResp from 00:0c:42:61:a4:41 (capab=0x411 status=0 aid=1)
Jan  1 01:00:54 OpenWrt kern.debug kernel: wlan0: associated
Jan  1 01:00:54 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:00:54 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:00:57 OpenWrt kern.debug kernel: wlan0: deauthenticated from 00:0c:42:61:a4:41 (Reason: 2)
Jan  1 01:00:57 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:00:58 OpenWrt kern.debug kernel: wlan0: authenticate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:00:58 OpenWrt kern.debug kernel: wlan0: authenticated
Jan  1 01:00:58 OpenWrt kern.debug kernel: wlan0: associate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:00:58 OpenWrt kern.debug kernel: wlan0: RX ReassocResp from 00:0c:42:61:a4:41 (capab=0x411 status=0 aid=1)
Jan  1 01:00:58 OpenWrt kern.debug kernel: wlan0: associated
Jan  1 01:00:58 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:00:58 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:01 OpenWrt kern.debug kernel: wlan0: deauthenticated from 00:0c:42:61:a4:41 (Reason: 2)
Jan  1 01:01:01 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:02 OpenWrt kern.debug kernel: wlan0: authenticate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:02 OpenWrt kern.debug kernel: wlan0: authenticated
Jan  1 01:01:02 OpenWrt kern.debug kernel: wlan0: associate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:02 OpenWrt kern.debug kernel: wlan0: RX ReassocResp from 00:0c:42:61:a4:41 (capab=0x411 status=0 aid=1)
Jan  1 01:01:02 OpenWrt kern.debug kernel: wlan0: associated
Jan  1 01:01:02 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:02 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:05 OpenWrt kern.debug kernel: wlan0: deauthenticated from 00:0c:42:61:a4:41 (Reason: 2)
Jan  1 01:01:05 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:06 OpenWrt kern.debug kernel: wlan0: authenticate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:06 OpenWrt kern.debug kernel: wlan0: authenticated
Jan  1 01:01:06 OpenWrt kern.debug kernel: wlan0: associate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:06 OpenWrt kern.debug kernel: wlan0: RX ReassocResp from 00:0c:42:61:a4:41 (capab=0x411 status=0 aid=1)
Jan  1 01:01:06 OpenWrt kern.debug kernel: wlan0: associated
Jan  1 01:01:06 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:06 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:09 OpenWrt kern.debug kernel: wlan0: deauthenticated from 00:0c:42:61:a4:41 (Reason: 2)
Jan  1 01:01:09 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:10 OpenWrt kern.debug kernel: wlan0: authenticate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:10 OpenWrt kern.debug kernel: wlan0: authenticated
Jan  1 01:01:10 OpenWrt kern.debug kernel: wlan0: associate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:10 OpenWrt kern.debug kernel: wlan0: RX ReassocResp from 00:0c:42:61:a4:41 (capab=0x411 status=0 aid=1)
Jan  1 01:01:10 OpenWrt kern.debug kernel: wlan0: associated
Jan  1 01:01:10 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:10 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:13 OpenWrt kern.debug kernel: wlan0: deauthenticated from 00:0c:42:61:a4:41 (Reason: 2)
Jan  1 01:01:13 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:14 OpenWrt kern.debug kernel: wlan0: authenticate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:14 OpenWrt kern.debug kernel: wlan0: authenticated
Jan  1 01:01:14 OpenWrt kern.debug kernel: wlan0: associate with 00:0c:42:61:a4:41 (try 1)
Jan  1 01:01:14 OpenWrt kern.debug kernel: wlan0: RX ReassocResp from 00:0c:42:61:a4:41 (capab=0x411 status=0 aid=1)
Jan  1 01:01:14 OpenWrt kern.debug kernel: wlan0: associated
Jan  1 01:01:14 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:14 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state
Jan  1 01:01:17 OpenWrt kern.debug kernel: wlan0: deauthenticated from 00:0c:42:61:a4:41 (Reason: 2)
Jan  1 01:01:17 OpenWrt kern.info kernel: br-lan: port 2(wlan0) entering forwarding state

The problem is with the ath9k ap, because the client can connect to a different ap that runs ath5k.

comment:10 Changed 6 years ago by digitaltuner

I got similar system log as duvi's. I am using version r31469. I have this problem for several versions back then. Didn't keep track which version started to have problem. My setup is a WR1043ND as the WDS AP and a WR941ND as the WDS STA. If I set the wireless security to "No Encryption", the WDS will be set up successfully. I have checked that my routers already have wpad-mini installed. I also found that if I installed backfire 10.03.1 in the WDS AP, the wireless security can use WPA2 encryption with r31469 in the WDS STA.

comment:11 Changed 6 years ago by nbd

please try r31515

comment:12 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r31517

comment:13 Changed 6 years ago by duvi

I can confirm it's working for me.

comment:14 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

A WDS-client (WR1043ND) is able to associate with a WDS-AP (WNDR3700) now again.
But the client does this not automatically when it comes up. I have to restart the wifi (wpa2 encrypted) manually.
r31541

comment:15 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

the issue described in the ticket is fixed, the other issue mentioned in that last comment is tracked in #11291

comment:16 Changed 6 years ago by anonymous

It is working. Thanks.

comment:17 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.