Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11250 closed defect (fixed)

VLAN > 31 failed to create

Reported by: aneip@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: vlan Cc:

Description

I'm using TPlink tl-wr2543.

When I create vlan > 31 (eg 500), the interface eth0.500 is created but swconfig show nothing (for vlan 500). If I lowered the vlan no to 31 both interface and swconfig show correctly.

Manually issues following command also failed

swconfig dev switch0 vlan 500 set ports '0 9t'

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

You need to set "option enable_vlan4k 1".

comment:2 Changed 6 years ago by aneip@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I do have the option enable in network config. Need any other place? do you try with vlan > 31? as far as I know without 4k vlan enable you can only create vlan <16.. I can create vlan up to 31.. after that swconfig will respond failed.

below is my network file

config interface 'loopback'                                                                                                    
        option ifname 'lo'                                                                                                     
        option proto 'static'                                                                                                  
        option ipaddr '127.0.0.1'                                                                                              
        option netmask '255.0.0.0'                                                                                             
                                                                                                                               
config interface 'lan'                                                                                                         
        option ifname 'eth0.1'                                                                                                 
        option type 'bridge'                                                                                                   
        option proto 'static'                                                                                                  
        option netmask '255.255.255.0'                                                                                         
        option ipaddr '192.168.10.8'                                                                                           
        option gateway '192.168.10.1'                                                                                          
        option dns '192.168.10.1'                                                                                              
                                                                                                                               
config interface 'wan'                                                                                                         
        option ifname 'eth0.200'                                                                                               
        option proto 'dhcp'                                                                                                    
                                                                                                                               
config switch                                                                                                                  
        option name 'switch0'                                                                                                  
        option reset '1'                                                                                                       
        option enable_vlan '1'                                                                                                 
        option enable_vlan4k '1'                                                                                               
        option max_length '3'                                                                                                  
                                                                                                                               
config switch_vlan                                                                                                             
        option device 'switch0'                                                                                                
        option vlan '1'                                                                                                        
        option ports '1 2 3 4 9t'                                                                                              
                                                                                                                               
config switch_vlan                                                                                                             
        option device 'switch0'                                                                                                
        option vlan '200'                                                                                                      
        option ports '0 9t'         

comment:3 Changed 6 years ago by Lars Bøgild Thomsen <lth@…>

It was closed as a duplicate (which indeed it was) but I can confirm this one and got a few more comments here: /ticket/11470.html

comment:4 Changed 6 years ago by juhosg

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r31914.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.