Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11184 closed defect (fixed)

WNDR3700 and r31071 have complelty broken wifi

Reported by: luminoso@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

wifi detect with r31071

config wifi-device  radio0
        option type     mac80211
        option channel  36
        option macaddr  00:24:b2:d8:28:b7
        option hwmode   11na
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

config wifi-device  radio1
        option type     mac80211
        option channel  36
        option macaddr  00:24:b2:d8:28:b9
        option hwmode   11na
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   TX-STBC
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio1
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

wifi detect with RC6

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option macaddr	00:24:b2:d8:28:b7
	option hwmode	11ng
	option htmode	HT20
	list ht_capab	SHORT-GI-40
	list ht_capab	TX-STBC
	list ht_capab	RX-STBC1
	list ht_capab	DSSS_CCK-40
	# REMOVE THIS LINE TO ENABLE WIFI:
	option disabled 1

config wifi-iface
	option device   radio0
	option network  lan
	option mode     ap
	option ssid     OpenWrt
	option encryption none

config wifi-device  radio1
	option type     mac80211
	option channel  36
	option macaddr	00:24:b2:d8:28:b9
	option hwmode	11na
	option htmode	HT20
	list ht_capab	SHORT-GI-40
	list ht_capab	TX-STBC
	list ht_capab	RX-STBC1
	list ht_capab	DSSS_CCK-40
	# REMOVE THIS LINE TO ENABLE WIFI:
	option disabled 1

config wifi-iface
	option device   radio1
	option network  lan
	option mode     ap
	option ssid     OpenWrt
	option encryption none

-I've also tested r31071 with TP-LINK 1043ND and no problems at all.

-I've tested wndr3700 with both 3.2.13 and 3.3 kernel

-With backfire RC6 no problems at all

-r31071 'briked' both routers (TP-LINK 1043ND and WNDR3700) configuration. No idea why. Connectivity was completely lost and I had to clear the overlay in order to make the routers work again

Attachments (1)

WNDR3700.log (15.8 KB) - added by vov4ik.n@… 6 years ago.
Log from serial console. Without patch trunk/package/mac80211/patches/501-ath9k-eeprom_endianess.patch Wi-Fi work perfectly

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by vov4ik.n@…

Log from serial console. Without patch trunk/package/mac80211/patches/501-ath9k-eeprom_endianess.patch Wi-Fi work perfectly

comment:1 Changed 6 years ago by luminoso@…

That log is because of flash saving configuration or because wireless not working? Because with r31071 I had two issues:

1) Router freeze after boot when I kept configuration files
2) Wireless not working even if flashing without keeping configuration files (problem described in this ticket)

for problem 1) I had freezing in other ar71xx routers as well, solved with reseting preferences and for problem 2) it only happens in WNDR3700 for me.

(But problem 1) is a PITA as well, since you must enter failsafe mode to reset, but I've managed to solve it.)

comment:2 Changed 6 years ago by vov4ik.n@…

This log because wireles not working.
1) when restore old configuration from file - kernel panic
2) when flashing without keeping configuration and enable wifi in luci - kernel panic
3) mac adresses in log
[ 34.390000] ath: eeprom contains invalid mac address: 91:00:b4:f5:19:22
[ 34.400000] ath: random mac address will be used: ee:65:3d:1c:53:9f
is not MAC from router. After delete the file trunk/package/mac80211/patches/501-ath9k-eeprom_endianess.patch all problems gone.
Sorry fo my english.

comment:3 Changed 6 years ago by luminoso@…

Fix confirmed by deleting trunk/package/mac80211/patches/501-ath9k-eeprom_endianess.patch in WNDR3700.

comment:4 follow-up: Changed 6 years ago by Goofball <goofball222@…>

I had compiled r31017 and had the same issues listed here on my WNDR3700 after flashing with a freeze on boot if config was retained and no wireless. I reverted to an older trunk revision via recovery mode and restored my config files from backup.

I updated, compiled and flashed again tonight with the latest version of trunk and this appears to be resolved at some point between r31071 and r31146. I'm guessing from the notes that r31084 cleared up the issue.

comment:5 in reply to: ↑ 4 Changed 6 years ago by vov4ik.n@…

I confirm. In r31084 Wi-Fi issue fixed.

comment:6 Changed 6 years ago by juhosg

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r31084.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.