Modify

Opened 6 years ago

Last modified 4 years ago

#11136 reopened defect

strange txpower bug (AR9381 here on WZR-HP-G450H)

Reported by: Halo2 Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

        option diversity '0'

--

        option txantenna '0'
        option rxantenna '0'
        option txpower '1'

reboot

wlan0     unknown transmit-power information.

          Current Tx-Power=19 dBm       (79 mW)
        option txantenna '1'
        option rxantenna '1'

wifi

wlan0     unknown transmit-power information.

          Current Tx-Power=19 dBm       (79 mW)

1(or2):

        option txpower '2'

wifi

wlan0     unknown transmit-power information.

          Current Tx-Power=14 dBm       (25 mW)

reboot

wlan0     unknown transmit-power information.

          Current Tx-Power=14 dBm       (25 mW)

2(or1):

        option txpower '20'

wifi

wlan0     unknown transmit-power information.

          Current Tx-Power=15 dBm       (31 mW)

reboot

wlan0     unknown transmit-power information.

          Current Tx-Power=15 dBm       (31 mW)

-

        option txantenna '1'
        option rxantenna '1'
        option txpower '1'

reboot

wlan0     unknown transmit-power information.

          Current Tx-Power=14 dBm       (25 mW)
        option txantenna '0'
        option rxantenna '0'

wifi

wlan0     unknown transmit-power information.

          Current Tx-Power=14 dBm       (25 mW)

1(or2):

        option txpower '2'

wifi

wlan0     unknown transmit-power information.

          Current Tx-Power=14 dBm       (25 mW)

reboot

wlan0     unknown transmit-power information.

          Current Tx-Power=19 dBm       (79 mW)

2(or1):

        option txpower '20'

wifi

wlan0     unknown transmit-power information.

          Current Tx-Power=15 dBm       (31 mW)

reboot

wlan0     unknown transmit-power information.

          Current Tx-Power=20 dBm       (100 mW)

---

So - conclusion:

switching from antenna 0->1 and calling wifi does nothing on iwlist txpower

switching from antenna 1->0 and calling wifi does nothing on iwlist txpower

switching from antenna 0->1 and changing txpower then calling wifi shows the (buggy) values as it should on "new" antenna 1

switching from antenna 1->0 and changing txpower then calling wifi shows the (buggy) values as if still on "old" antenna 1

compareable to ticket #10894 but in more detail and with an additional bug involved (see also ticket #11135).

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #11135

comment:2 Changed 6 years ago by Halo2

Faster closed as the strange behaviour is analyzed.. .

Deprecated or not, this is still a good hint on other devices.

So I think it would be time to take care of ticket #10897 some time, at least when not bothering about anything which has to do with checking txpower.

comment:3 in reply to: ↑ 1 Changed 6 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to jow:

Dupe of #11135

Deprecated okay, but definitely not a dupe of 11135.

The ticket is about needing a reboot when you change tx/rxantenna for the txpower values to be the same as after a reboot.

Or changing i.e. txpower helps too.

But even thats inconsinstent, it only works when going from tx/rxantenna 0 to 1. When going from 1 to 0 and then changing txpower wifi is still not enough, the reboot is still needed then.

comment:4 Changed 6 years ago by nbd

  • Priority changed from normal to response-needed

please try a recent version, it should be fixed now.

comment:5 follow-ups: Changed 6 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

comment:6 in reply to: ↑ 5 ; follow-up: Changed 6 years ago by Halo2

  • Resolution no_response deleted
  • Status changed from closed to reopened

Replying to nbd:

Sorry for not responding, but when testing #10894 i saw that this issue is still there too..

comment:7 in reply to: ↑ 6 Changed 6 years ago by Halo2

Replying to Halo2:

Replying to nbd:

Sorry for not responding, but when testing #10894 i saw that this issue is still there too..

So this means that the values are not updated correctly (see conclusion)!

If you meant #11135 - so only 14 and 15 or 19 and 20 dBm are shown - i will retest this in the next days.. .

comment:8 in reply to: ↑ 5 Changed 6 years ago by Halo2

Replying to nbd:

So as i thought - #11135 is solved now (which state invalid was wrong).
But this behaviour of having to change txpower or reboot when antenna is changed to see the correct and updated values is still an issue, and not only on this device.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.