Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11112 closed defect (fixed)

Unknown symbols in ath5k/mac80211 on a fonera trunk r30871

Reported by: duvi Owned by: hauke
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Wireless interface does not come up. Please see the log:

[    0.000000] Linux version 2.6.37.6 (duvi@anneke) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Sun Mar 11 16:04:45 CET 2012
[    0.000000] ar2315-gpio: registered 22 GPIOs
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019064 (MIPS 4KEc)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 01000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00001000
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00001000
[    0.000000] On node 0 totalpages: 4096
[    0.000000] free_area_init_node: node 0, pgdat 802a5020, node_mem_map 802e1000
[    0.000000]   Normal zone: 32 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 4064 pages, LIFO batch:0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
[    0.000000] Kernel command line:  console=ttyS0,9600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 64 (order: -4, 256 bytes)
[    0.000000] Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
[    0.000000] Memory: 13236k/16384k available (1997k kernel code, 3148k reserved, 452k data, 148k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.000000] console [ttyS0] enabled, bootconsole disabled
[    0.010000] Calibrating delay loop... 199.47 BogoMIPS (lpj=997376)
[    0.220000] pid_max: default: 32768 minimum: 301
[    0.230000] Mount-cache hash table entries: 512
[    0.250000] NET: Registered protocol family 16
[    0.930000] bio: create slab <bio-0> at 0
[    0.950000] pci 0000:00:00.0: [168c:ff18] type 0 class 0x000200
[    0.950000] pci 0000:00:00.0: reg 10: [mem 0x00000000-0x0001ffff]
[    0.950000] pci 0000:00:00.0: reg 14: [mem 0x00000000-0x03ffffff]
[    0.950000] pci 0000:00:00.0: reg 18: [mem 0x00000000-0x003fffff]
[    0.950000] pci 0000:00:03.0: [168c:ff18] type 0 class 0x000200
[    0.950000] pci 0000:00:03.0: reg 10: [mem 0x00000000-0x0001ffff]
[    0.950000] pci 0000:00:03.0: reg 14: [mem 0x00000000-0x03ffffff]
[    0.950000] pci 0000:00:03.0: reg 18: [mem 0x00000000-0x003fffff]
[    0.950000] pci 0000:00:00.0: BAR 1: can't assign mem (size 0x4000000)
[    0.960000] pci 0000:00:03.0: BAR 1: can't assign mem (size 0x4000000)
[    0.970000] pci 0000:00:00.0: BAR 2: assigned [mem 0x80800000-0x80bfffff]
[    0.980000] pci 0000:00:00.0: BAR 2: set to [mem 0x80800000-0x80bfffff] (PCI address [0x80800000-0x80bfffff])
[    0.990000] pci 0000:00:03.0: BAR 2: assigned [mem 0x80c00000-0x80ffffff]
[    1.000000] pci 0000:00:03.0: BAR 2: set to [mem 0x80c00000-0x80ffffff] (PCI address [0x80c00000-0x80ffffff])
[    1.010000] pci 0000:00:00.0: BAR 0: assigned [mem 0x81000000-0x8101ffff]
[    1.020000] pci 0000:00:00.0: BAR 0: set to [mem 0x81000000-0x8101ffff] (PCI address [0x81000000-0x8101ffff])
[    1.030000] pci 0000:00:03.0: BAR 0: assigned [mem 0x81020000-0x8103ffff]
[    1.040000] pci 0000:00:03.0: BAR 0: set to [mem 0x81020000-0x8103ffff] (PCI address [0x81020000-0x8103ffff])
[    1.050000] Switching to clocksource MIPS
[    1.070000] NET: Registered protocol family 2
[    1.130000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    1.210000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    1.290000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    1.370000] TCP: Hash tables configured (established 512 bind 512)
[    1.440000] TCP reno registered
[    1.480000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    1.550000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    1.630000] NET: Registered protocol family 1
[    1.680000] PCI: CLS 0 bytes, default 32
[    1.690000] Radio config found at offset 0xf8(0x1f8)
[    1.770000] Radio MAC is blank; using board-data
[    1.830000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    1.910000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    2.020000] msgmni has been set to 25
[    2.070000] io scheduler noop registered
[    2.110000] io scheduler deadline registered (default)
[    2.180000] gpiodev: gpio device registered with major 254
[    2.250000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    2.350000] serial8250: ttyS0 at MMIO 0xb1100003 (irq = 37) is a 16550A
[    2.440000] cmdlinepart partition parsing not available
[    2.500000] Searching for RedBoot partition table in spiflash at offset 0x7d0000
[    2.940000] Searching for RedBoot partition table in spiflash at offset 0x7e0000
[    3.370000] 6 RedBoot partitions found on MTD device spiflash
[    3.440000] Creating 6 MTD partitions on "spiflash":
[    3.500000] 0x000000000000-0x000000030000 : "RedBoot"
[    3.570000] 0x000000030000-0x000000110000 : "vmlinux.bin.l7"
[    3.640000] 0x000000110000-0x0000007e0000 : "rootfs"
[    3.710000] mtd: partition "rootfs" set to be root filesystem
[    3.780000] mtd: partition "rootfs_data" created automatically, ofs=260000, len=580000
[    3.880000] 0x000000260000-0x0000007e0000 : "rootfs_data"
[    3.950000] 0x0000007e0000-0x0000007ef000 : "FIS directory"
[    4.020000] 0x0000007ef000-0x0000007f0000 : "RedBoot config"
[    4.100000] 0x0000007f0000-0x000000800000 : "boardconfig"
[    4.250000] eth0: Atheros AR231x: 00:18:84:2a:22:4c, irq 4
[    4.380000] ar231x_eth_mii: probed
[    4.420000] eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr=0:00)
[    4.510000] TCP westwood registered
[    4.550000] NET: Registered protocol family 17
[    4.610000] 802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
[    4.690000] All bugs added by David S. Miller <davem@redhat.com>
[    4.800000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    4.890000] Freeing unused kernel memory: 148k freed
[    6.000000] eth0: Configuring MAC for full duplex
[   17.540000] JFFS2 notice: (271) jffs2_build_xattr_subsystem: complete building xattr subsystem, 16 of xdatum (0 unchecked, 15 orphan) and 17 of xref (0 dead, 15 orphan) found.
[   19.720000] Compat-wireless backport release: compat-wireless-2012-02-27-1-r30871
[   19.810000] Backport based on wireless-testing.git master-2012-02-27
[   20.250000] cfg80211: Calling CRDA to update world regulatory domain
[   22.450000] NET: Registered protocol family 10
[   22.510000] lo: Disabled Privacy Extensions
[   24.370000] mac80211: Unknown symbol ewma_add (err 0)
[   24.520000] mac80211: Unknown symbol kstrtou8_from_user (err 0)
[   24.590000] mac80211: Unknown symbol _kstrtoul (err 0)
[   24.680000] mac80211: Unknown symbol ewma_init (err 0)
[   24.820000] mac80211: Unknown symbol kstrtoull (err 0)
[   25.000000] cfg80211: World regulatory domain updated:
[   25.060000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   25.160000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   25.250000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   25.350000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   25.440000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   25.530000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   26.670000] ath5k: Unknown symbol ewma_add (err 0)
[   26.750000] ath5k: Unknown symbol ieee80211_free_hw (err 0)
[   26.820000] ath5k: Unknown symbol ieee80211_alloc_hw (err 0)
[   26.900000] ath5k: Unknown symbol ieee80211_register_hw (err 0)
[   26.970000] ath5k: Unknown symbol ieee80211_ctstoself_duration (err 0)
[   27.060000] ath5k: Unknown symbol ieee80211_generic_frame_duration (err 0)
[   27.140000] ath5k: Unknown symbol ieee80211_wake_queue (err 0)
[   27.220000] ath5k: Unknown symbol __ieee80211_get_tx_led_name (err 0)
[   27.300000] ath5k: Unknown symbol ieee80211_get_buffered_bc (err 0)
[   27.390000] ath5k: Unknown symbol __ieee80211_get_rx_led_name (err 0)
[   27.470000] ath5k: Unknown symbol ewma_init (err 0)
[   27.530000] ath5k: Unknown symbol wiphy_to_ieee80211_hw (err 0)
[   27.610000] ath5k: Unknown symbol ieee80211_queue_delayed_work (err 0)
[   27.690000] ath5k: Unknown symbol kstrtoint (err 0)
[   27.760000] ath5k: Unknown symbol ieee80211_rx (err 0)
[   27.820000] ath5k: Unknown symbol ieee80211_wake_queues (err 0)
[   27.900000] ath5k: Unknown symbol ieee80211_tx_status (err 0)
[   27.970000] ath5k: Unknown symbol ieee80211_stop_queue (err 0)
[   28.050000] ath5k: Unknown symbol ieee80211_stop_queues (err 0)
[   28.120000] ath5k: Unknown symbol ieee80211_iterate_active_interfaces_atomic (err 0)
[   28.220000] ath5k: Unknown symbol ieee80211_unregister_hw (err 0)
[   28.300000] ath5k: Unknown symbol ieee80211_beacon_get_tim (err 0)
[   28.390000] ath5k: Unknown symbol ieee80211_queue_work (err 0)
[   28.460000] ath5k: Unknown symbol ieee80211_rts_duration (err 0)
[   33.810000] device eth0 entered promiscuous mode
[   33.970000] br-lan: port 1(eth0) entering forwarding state
[   34.040000] br-lan: port 1(eth0) entering forwarding state
[   41.760000] device eth0 left promiscuous mode
[   41.820000] br-lan: port 1(eth0) entering forwarding state
[   46.300000] device eth0 entered promiscuous mode
[   46.350000] br-lan: port 1(eth0) entering forwarding state
[   46.420000] br-lan: port 1(eth0) entering forwarding state

Attachments (4)

970-ewma.patch (4.5 KB) - added by Viktar Palstsiuk <viktar.palstsiuk@…> 6 years ago.
971-improve_ewma.patch (3.0 KB) - added by Viktar Palstsiuk <viktar.palstsiuk@…> 6 years ago.
982-make-config-average-selectable.patch (391 bytes) - added by Viktar Palstsiuk <viktar.palstsiuk@…> 6 years ago.
051-compat_for_2.6.37.patch (360 bytes) - added by Viktar Palstsiuk <viktar.palstsiuk@…> 6 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

see #11112

comment:2 Changed 6 years ago by duvi

Duplicate of itself? (:

comment:3 Changed 6 years ago by jow

Oh I am sorry, I meant to link to #10507

comment:4 Changed 6 years ago by duvi

  • Resolution duplicate deleted
  • Status changed from closed to reopened

According to that ticket, I did not install mac80211 later from a package.
I built it into the sysupgrade image using same config options I've used for a long time.
I also did 'make dirclean' before running 'make'.

comment:5 Changed 6 years ago by Jonman409

I can also reproduce the above issue under the same scenario. I used dirclean followed by making. I will try to bisect as to what broke it

comment:6 Changed 6 years ago by Jonman409

Looking at compat-2.6.38.c I see where ewma settings were backported. http://pastebin.com/jzudfHaT
However they are not done for 2.6.37. Seems like we should upgrade the kernel anyway ;-)

comment:7 Changed 6 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from reopened to accepted

comment:8 Changed 6 years ago by hauke

You are both getting these error messages:

[   24.370000] mac80211: Unknown symbol ewma_add (err 0)
[   24.520000] mac80211: Unknown symbol kstrtou8_from_user (err 0)
[   24.590000] mac80211: Unknown symbol _kstrtoul (err 0)
[   24.680000] mac80211: Unknown symbol ewma_init (err 0)
[   24.820000] mac80211: Unknown symbol kstrtoull (err 0)

and you are both using atheros target on kernel 2.6.37.6?

ewma_* should be provided by the kernel and kstrt* from compat.ko

comment:9 Changed 6 years ago by Jonman409

hauke, I am linking to a pastebin that shows more from the dmesg.
http://pastebin.com/mRQen8DF

Changed 6 years ago by Viktar Palstsiuk <viktar.palstsiuk@…>

Changed 6 years ago by Viktar Palstsiuk <viktar.palstsiuk@…>

Changed 6 years ago by Viktar Palstsiuk <viktar.palstsiuk@…>

comment:10 Changed 6 years ago by Viktar Palstsiuk <viktar.palstsiuk@…>

These patches provide ewma_add and ewma_init.

Changed 6 years ago by Viktar Palstsiuk <viktar.palstsiuk@…>

comment:11 Changed 6 years ago by jonbither@…

I don't know why it isn't being loaded, but as a temporary work-around users can disable "CONFIG_PACKAGE_MAC80211_DEBUGFS" to get the wireless back operational. The function is being called in debugfs.c for uapsd_queues_write if that helps anyone.

comment:12 Changed 6 years ago by anonymous

I found the same issue on a Ubiquiti Picostation. Seems to me the entire atheros with ath5k target is shot is trunk.

comment:13 Changed 6 years ago by anonymous

Patches posted above do no longer apply in trunk r31279, and workaround of disabling "CONFIG_PACKAGE_MAC80211_DEBUGFS" does not work - at least not for Picostation 2 or Picostation 2HP work. As I stated before ath5k on trunk appears utterly broken.

comment:14 Changed 6 years ago by duvi

I also built trunk 31270 for Fonera, with the named "Export mac80211 internals in DebugFS - CONFIG_PACKAGE_MAC80211_DEBUGFS" disabled, and still getting unknown symbols.

I just wonder, why the openwrt build from http://downloads.openwrt.org/snapshots/trunk/atheros/ does not have this error..

comment:15 Changed 6 years ago by duvi

This can be closed, seems fixed with last night's changes.

comment:16 Changed 6 years ago by hauke

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:17 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.