Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11098 closed defect (duplicate)

asterisk compile error

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: asterisk, trunk Cc:

Description

I have an error while compiling asterisk with trunk r30857:

mips-openwrt-linux-uclibc-gcc  -o asterisk -Wl,--export-dynamic -Wl,--version-script,asterisk.exports -Wl,--dynamic-list,asterisk.dynamics  -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/usr/lib -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/lib -L/home/user/openwrt/trunk/staging_dir/toolchain-mips_gcc-4.6-linaro_uClibc-0.9.33/usr/lib -L/home/user/openwrt/trunk/staging_dir/toolchain-mips_gcc-4.6-linaro_uClibc-0.9.33/lib -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/usr/lib -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/lib -L/home/user/openwrt/trunk/staging_dir/toolchain-mips_gcc-4.6-linaro_uClibc-0.9.33/usr/lib -L/home/user/openwrt/trunk/staging_dir/toolchain-mips_gcc-4.6-linaro_uClibc-0.9.33/lib  -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/usr/lib -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/lib -L/home/user/openwrt/trunk/staging_dir/toolchain-mips_gcc-4.6-linaro_uClibc-0.9.33/usr/lib -L/home/user/openwrt/trunk/staging_dir/toolchain-mips_gcc-4.6-linaro_uClibc-0.9.33/lib ../res/res_adsi.o abstract_jb.o acl.o alaw.o aoc.o app.o ast_expr2.o ast_expr2f.o asterisk.o astfd.o astmm.o astobj2.o audiohook.o autochan.o autoservice.o bridging.o callerid.o ccss.o cdr.o cel.o channel.o chanvars.o cli.o config.o data.o datastore.o db.o devicestate.o dial.o dns.o dnsmgr.o dsp.o enum.o event.o features.o file.o fixedjitterbuf.o frame.o framehook.o fskmodem.o global_datastores.o hashtab.o heap.o http.o image.o indications.o io.o jitterbuf.o loader.o lock.o logger.o manager.o md5.o netsock.o netsock2.o pbx.o plc.o poll.o privacy.o rtp_engine.o say.o sched.o security_events.o sha1.o slinfactory.o srv.o ssl.o stdtime/localtime.o strcompat.o strings.o stun.o syslog.o taskprocessor.o tcptls.o tdd.o term.o test.o threadstorage.o timing.o translate.o udptl.o ulaw.o utils.o version.o xml.o xmldoc.o editline/libedit.a db1-ast/libdb1.a  buildinfo.o -lssl -lcrypto    -ldl -lpthread -L/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/usr/lib -lncurses  -lm -lresolv  
dns.o: In function `ast_search_dns':
dns.c:(.text+0xcc): undefined reference to `res_nsearch'
collect2: ld returned 1 exit status
make[5]: *** [asterisk] Error 1
make[5]: Leaving directory `/home/user/openwrt/trunk/build_dir/target-mips_uClibc-0.9.33/asterisk-1.8.8.0/main'
make[4]: *** [main] Error 2
make[4]: Leaving directory `/home/user/openwrt/trunk/build_dir/target-mips_uClibc-0.9.33/asterisk-1.8.8.0'
make[3]: *** [/home/user/openwrt/trunk/build_dir/target-mips_uClibc-0.9.33/asterisk-1.8.8.0/.built] Error 2
make[3]: Leaving directory `/home/user/openwrt/trunk/feeds/packages/net/asterisk-1.8.x'
make[2]: *** [package/feeds/packages/asterisk-1.8.x/compile] Error 2
make[2]: Leaving directory `/home/user/openwrt/trunk'
make[1]: *** [/home/user/openwrt/trunk/staging_dir/target-mips_uClibc-0.9.33/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/user/openwrt/trunk'
make: *** [world] Errore 2

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #10974.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.