Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11075 closed defect (worksforme)

scp does not like filenames containing a colon

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: scp Cc:

Description

echo 1> a:a

scp a:a user@host

ssh: Could not resolve hostname a: Name or service not known

same for

scp 'a:a' user@host

FYI:

# uname -a

Linux OpenWrt 2.6.32.27 #5 Wed Dec 21 01:59:33 CET 2011 mips GNU/Linux

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Kenyon Ralph <kenyon@…>

Not a bug. Specify the path to the local file: scp ./a:a user@host

comment:2 Changed 6 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.