Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11074 closed defect (worksforme)

TL-WR1043ND image boot error (build from trunk r30798)

Reported by: risa2000 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Building factory image for tl-wr1043nd (openwrt-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin) from trunk. r30755 was fine. Now (using build from r30798) the booting aborts with error

U-Boot 1.1.4 (Nov 17 2009 - 11:56:26)

AP83 (ar9100) U-boot 0.0.11
DRAM:
sri
32 MB
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
eth0
Autobooting in 1 seconds## Booting image at bf020000 ...
   Uncompressing Kernel Image ... Error: Bad gzipped data
GUNZIP ERROR - must RESET board to recover

Resetting...

U-Boot 1.1.4 (Nov 17 2009 - 11:56:26)

Attachments (2)

make_image.log (34.9 KB) - added by risa2000 6 years ago.
make image TLWR1043 (Makefile r30860 => boot fails)
make_image_2.log (35.5 KB) - added by risa2000 6 years ago.
make image TLWR1043NDV1 (Makefile r29441 => boots ok)

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by risa2000

make image TLWR1043 (Makefile r30860 => boot fails)

Changed 6 years ago by risa2000

make image TLWR1043NDV1 (Makefile r29441 => boots ok)

comment:1 Changed 6 years ago by risa2000

I have been able to narrow down the details to:

1) Error reported above comes from u-boot, so it seems the gzipped lzma-loader is the culprit. The strange thing is that lzma-loader has been working fine in previous revision (r30755), so it means the gzip format that lzma-loader uses had to change in between.

2) I did check out source:trunk/target/linux/ar71xx/image/Makefile@29441, which does not use lzma-loader and LZMA compressed kernel (i.e. it uses gzipped kernel), and use it in otherwise unchanged environment, and the built image works fine too. So it seems, at least current gzip works fine as well.

So the problem is either the gzip format (or corruption) of lzma-loader (which had to change recently), or the format of final image produced by "make image TLWR1043" (which had to change recently too).

comment:2 follow-up: Changed 6 years ago by risa2000

Just forgot to add. I am using ImageBuilder to build the image.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 6 years ago by juhosg

It seems that the prebuilt loaders are missing in your ImageBuilder:

dd: opening `/home/risa/openwrt/OpenWrt-ImageBuilder-ar71xx-for-Linux-x86_64/build_dir
/linux-ar71xx_generic/loader-tl-wr1043nd-v1.gz': No such file or directory

comment:4 in reply to: ↑ 3 Changed 6 years ago by risa2000

Replying to juhosg:
Thanks! Even though I did thorough scan of the log, I missed this one point :(.
Maybe, it would be better if the script fail completely in this case?

Anyway, the problem comes from the fact that when ImageBuilder package is built (OpenWrt-ImageBuilder-ar71xx-for-Linux-x86_64.tar.bz2), the directory OpenWrt-ImageBuilder-ar71xx-for-Linux-x86_64/build_dir/linux-ar71xx_generic always comes empty. I thought this was a bug in build process, but never really reported it and just copied there all vmlinux* from ~/build_dir/linux-ar71xx_generic.

Now, when new loader-* silently came in, my script did not move them and therefore I missed them in image generation phase.

Could you please have a look at ImageBuilder make script and see why OpenWrt-ImageBuilder-ar71xx-for-Linux-x86_64/build_dir/linux-ar71xx_generic is not correctly populated?

comment:5 Changed 6 years ago by risa2000

I would close this one (if I could), and I am creating a new one #11117, which reports the root cause.

comment:6 Changed 6 years ago by juhosg

  • Resolution set to worksforme
  • Status changed from new to closed

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.