Modify

Opened 6 years ago

Last modified 4 years ago

#11071 reopened defect

10.03.1 on WRT160NL creates the same MAC addr on every device

Reported by: peter.sarossy@… Owned by: developers
Priority: normal Milestone: Bugs Paradise
Component: base system Version: 10.03.1
Keywords: mac address duplicate Cc:

Description

On boot time I see the following:
ar71xx: using random MAC address for eth0
ar71xx: using random MAC address for eth1

I have 2 of these devices, both get the same MAC address for the LAN device. This of course renders both of them unusable on the same network as the frames have multiple destinations.

Changing the MAC address via the web interface only populates br-lan, but eth0 stays the same.
If I change the mac address manually (ifconfig eth0 hw ether) to match the br-lan one, then the link comes up and works as intended.

I want to use the device as an AP so I've disabled the dhcp server and enabled the dhcp client for LAN. If I modify the MAC address, I see on my main router logs that there are requests, but they get lost on the OpenWRT end.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

please use 12.09 or newer

comment:2 Changed 4 years ago by peter.sarossy@…

  • Resolution obsolete deleted
  • Status changed from closed to reopened

The current released under http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/ have exactly the same problem.

comment:3 Changed 4 years ago by anonymous

Load oryginal firmware, change timezone, save and load openwrt.

Some nvram variables is missing.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.