Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11070 closed defect (fixed)

mysql -uroot -p

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: mysql Cc:

Description

mysql: can't load library 'libncursesw.so.5'

running r30753 at tl-mr3420

Attachments (0)

Change History (9)

comment:1 in reply to: ↑ description Changed 6 years ago by anonymous

Replying to anonymous:

mysql: can't load library 'libncursesw.so.5'

running r30753 at tl-mr3420

root@OpenWrt:~# opkg install libncurses
Package libncurses (5.7-5) installed in root is up to date.
root@OpenWrt:~# mysql -uroot -p
mysql: can't load library 'libncursesw.so.5'

comment:2 Changed 6 years ago by НКВД

mysql binary is linked against wide char version of ncurses (libncursesw). So:

opkg install libncursesw

should fix your issue.

comment:3 Changed 6 years ago by thistac

Thanks!

comment:4 Changed 6 years ago by xiangfu@…

Then mysql should be DEPENDS on libncursesw ?

comment:5 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r32201

comment:6 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have the same problem with mysqld aborting because it cannot load libncursesw. I have added libncursesw to menuconfig and rebuilt. Menuconfig shows both libncurses and libncursesw as being selected for build. When I look at the modules that are actually included in the router, I see only libncurses. Are these two libs mutually exclusive or something or do we have another issue? Running trunk r33676.

Thanks, Perazim

comment:7 Changed 5 years ago by anonymous

Further info: Learned at ncurses site that libs do not conflict and both may be installed at same time. I added libncursesw using opkg. This allowed mysqld to run however I soon discovered other problems in the openwrt port of opensips that will be reported on another ticket. mysqld is the database used by opensips.

So it appears to me that there is a bug in the build system that causes libncursesw to not be included in flash image even when it is specifically set to be included in menuconfig.

comment:8 Changed 5 years ago by jogo

  • Resolution set to fixed
  • Status changed from reopened to closed

mysql now depends on libncursesw.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.