Modify

Opened 6 years ago

Last modified 4 years ago

#11035 new defect

[ar71xx] tl-wr1043nd - bridging to vlans does not work

Reported by: Damian Kaczkowski <damian.kaczkowski@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Hello.

I want to bridge lan iface and wan iface (or any other two vlans) on TL-WR1043ND in order to be able to sniff passing traffic through rtl8366rb switch with tcpdump. Such bridge does not work on newest trunk. As I remember bridging two vlans works ok on some older revisions (I did this once and it was working ok).

Here is the uci network config that does not work:

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'switch'
        option 'name' 'rtl8366rb'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '1'
        option 'ports' '1 2 3 4 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '2'
        option 'ports' '0 5t'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'ifname' 'eth0.1 eth0.2'
        option 'proto' 'static'
        option 'ipaddr' '10.10.111.111'
        option 'netmask' '255.255.0.0'
        option 'gateway' '10.10.254.254'
        option 'dns' '8.8.8.8'

#config 'interface' 'wan'
#       option 'ifname' 'eth0.2'
#       option 'proto' 'dhcp'

After few '/etc/init.d/network restarts' brctl shows that bridge is created

root@b0487ad67c4a:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.b0487ad67c4a       no              eth0.1
                                                        eth0.2

but still it does not work. After a while router becomes inaccessible. After a power reset router still remains inaccessible.

Any chance for fix or any suggestions on how to sniff passing traffic through rtl8366rb swtich?

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by anonymous

Have you referred to #8701? You may need to add a fid parameter to /etc/config/network, and patch swconfig accordingly, to set the fid for the vlan on the switch.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.