Modify

Opened 6 years ago

Closed 4 years ago

#11011 closed defect (wontfix)

java don't compile

Reported by: andreykyz@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: jamvm, javac Cc: rev, 30668

Description

checking for __attribute__... yes
checking how many arguments gethostbyname_r() takes... six
checking for ld used by GCC... mips-openwrt-linux-uclibc-ld
checking if the linker (mips-openwrt-linux-uclibc-ld) is GNU ld... yes
checking for shared library run path origin... done
checking for iconv... no, consider installing GNU libiconv
checking for MSG_NOSIGNAL... yes
checking for SO_NOSIGPIPE ... no
checking for MSG_WAITALL... yes
checking for __gmpz_mul_si in -lgmp... no
checking gmp.h usability... no
checking gmp.h presence... no
checking for gmp.h... no
checking jni_md.h support... configure: WARNING: no
checking whether to enable maintainer-specific portions of Makefiles... no
checking for mkdir... /bin/mkdir
checking for cp... /home/andrey/sandbox/openwrt-trunk/staging_dir/host/bin/cp
checking for date... /bin/date
checking for find... /usr/bin/find
checking for zip... /usr/bin/zip
checking for a jar-like tool... trying fastjar, gjar and jar
checking for fastjar... no
checking for gjar... no
checking for jar... /usr/bin/jar
checking whether to regenerate parsers with jay... no
checking for stdint types... stdint.h (shortcircuit)
make use of stdint.h in include/config-int.h (assuming C99 compatible system)
checking for cacao... no
checking for jamvm... no
checking for kaffe... no
checking for gij... no
checking for java... java
checking for uudecode... no
configure: WARNING: I have to compile Test.class from scratch
checking for ecj... no
checking for ecj-3.3... no
checking for ecj-3.2... no
checking for javac... javac -Xlint:unchecked,cast,divzero,empty,finally,overrides
checking if javac -Xlint:unchecked,cast,divzero,empty,finally,overrides is a version of gcj... javac: invalid flag: --version
Usage: javac <options> <source files>
use -help for a list of possible options

checking if javac -Xlint:unchecked,cast,divzero,empty,finally,overrides works... yes
checking if java works... configure: error: The Java VM java failed (see config.log, check the CLASSPATH?)
make[3]: *** [/home/andrey/sandbox/openwrt-trunk/build_dir/target-mips_r2_uClibc-0.9.33/classpath-0.98/.configured_] Error 1
make[3]: Leaving directory `/home/andrey/sandbox/openwrt-trunk/feeds/packages/libs/classpath'
make[2]: *** [package/feeds/packages/classpath/compile] Error 2
make[2]: Leaving directory `/home/andrey/sandbox/openwrt-trunk'
make[1]: *** [/home/andrey/sandbox/openwrt-trunk/staging_dir/target-mips_r2_uClibc-0.9.33/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/andrey/sandbox/openwrt-trunk'
make: *** [world] Ошибка 2

I selected "Languages-> Java -> <*> jamvm" and openwrt don't compile with said error.

I see one mistake. javac don't have --version option, change this on -version.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by andreykyz@…

I confirmed this error. Need to install ecj compiller because standart java compiller don't work for gnu classpath.
Solution:
sudo apt-get install ecj

comment:2 Changed 4 years ago by anonymous

  • Cc rev 30668 added; rev 30668 removed

worked

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 Changed 4 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

This package is currently unmaintained. No changes will be made to it until it is picked up.
Non-core packages are maintained at the GitHub project: https://github.com/openwrt/packages
If you want to maintain this package, you can send a pull request there.
See https://github.com/openwrt/packages/blob/master/CONTRIBUTING.md for more information.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.