Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10973 closed defect (duplicate)

Vlan broken in TL-743ND - trunk: r30479

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Hello.. my router have r30310 and i upgraded to r30479

openwrt-ar71xx-generic-tl-wr743nd-v1-squashfs-s..> 13-Feb-2012 04:43 2490372

I use multiwan script (vlan working good in r30310)

so in r30479 i installed luci

I go to network > switch and i got more ports and diference in numbers:

r30310: CPU port 1 port 2 port 3 port 4

r30479: port 0 port 1 port 2 port 3 port 4 port 5 CPU

I created the new vlan and make my new virtual interfaces to wan2 for example and checked and is not working (in older revision yes)

I did all good and try it and try it to make this work.. but NOTHING

I use winscp connection too to change network configuration (nothing)

if I use vlan for my lan.. my ports do not get router connection. (no ping, no gateway, no ip)

It is working in new Kernel? 3.xx.xx.xx

I will like get: TL-743ND image profile into backfire 10.3.1 (since is the same hardware of TL-741ND)

Thanks you

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by anonymous

It happened something similar on my TL-wr1043nd.
I flashed using sysupgrade the trunk version 'openwrt-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin' built of feb 10 using kernel version 3.2.5.

I flashed it over backfire 10.03.1 and wan bridge was not working (with my custom dual wan config). after few things i did (tried to restore the default settings) the lan bridge failed to work and i was able to recover the router via wifi as it seems wifi was accessible.

comment:2 follow-up: Changed 6 years ago by totev

Hi,

I'm not 100% sure that my problem is related to this issue, but sounds like it.

Yesterday i flashed my TL-WR740N ver. 4 with the latest trunk image (kernel 3.2.X). Vlans config in the Network->Vlan tab is the default and the following issue was observed:

  1. Wireless clients were able to communicate with clients attached to the LAN ports
  1. Clients attached to LAN ports were unable to communicate with each other, but all of the were reachable from the router itself
  1. Every station did have internet access

Re-flashing back to a any 2.6.X version of the image solves the problem.

comment:3 in reply to: ↑ 2 Changed 6 years ago by anonymous

hi,
got the same here on tp-link 841nd.

switch on eth0 configured to only one vlan. wireless clients can connect to clients attached to the lan ports (1-4, not 5, which is eth1 WAN).

wired clients CANNOT communicate with each other.

i found that the switch does not get configured properly, since swconfg is segfaulting. turning vlan off does not improve the situation, so its really about swconfig.

some things i found:

/etc/init.d/network produces a segfault in setup_switch()

config uses /sys/calss/net/eth0.1 to set up vlan 1 on eth0, but the file descriptor doesn't exist.

root@OpenWrt:~# dmesg | grep switch
[ 1.730000] eth0: Found an AR7240/AR9330 built-in switch
root@OpenWrt:~# swconfig dev eth0 help
Segmentation fault
root@OpenWrt:~# swconfig dev eth0 show
Segmentation fault

Replying to totev:

Hi,

I'm not 100% sure that my problem is related to this issue, but sounds like it.

Yesterday i flashed my TL-WR740N ver. 4 with the latest trunk image (kernel 3.2.X). Vlans config in the Network->Vlan tab is the default and the following issue was observed:

  1. Wireless clients were able to communicate with clients attached to the LAN ports
  1. Clients attached to LAN ports were unable to communicate with each other, but all of the were reachable from the router itself
  1. Every station did have internet access

Re-flashing back to a any 2.6.X version of the image solves the problem.

comment:4 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9765.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.