Modify

Opened 6 years ago

Last modified 4 years ago

#10970 new defect

error building just gdbserver

Reported by: Basil Nutmeg <basil+openwrt@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I want to build gdbserver for my (resource constrained) target:

CONFIG_PACKAGE_gdbserver=y
# CONFIG_PACKAGE_gdb is not set
# CONFIG_PACKAGE_libncurses is not set
# CONFIG_INSTALL_LIBSTDCPP is not set

However, this configuration fails to build. Even though gdb is a separate
package from gdbserver, the build system still builds gdb's dependencies,
which includes ncurses. And even though gdb doesn't need ncurses' C++
wrapper, it's part of the ncurses package. And since C++ isn't enabled,
this fails to build, cryptically:

ccache: FATAL: Could not find compiler "no" in PATH

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.