Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#10957 closed defect (fixed)

vpnc package in backfire resets permission on /etc to 700

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: vpnc Cc: non7top@…

Description

Board wr1043nd, arch ar71xx

root@r /root # ls -ld /etc/
drwxr-xr-x   12 root     root            0 Feb 12 11:19 /etc/
root@r /root # opkg install vpnc
Installing vpnc (0.5.3-1) to root...
Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages//vpnc_0.5.3-1_ar71xx.ipk.
Configuring vpnc.
root@r /root # ls -ld /etc/ /etc/vpnc/
drwx------   13 root     root            0 Feb 12 11:19 /etc/
drwx------    2 root     root            0 Feb 12 11:19 /etc/vpnc/

Apparently this is caused by opkg installing the files incorrectly since in ipk file i see

drwxr-xr-x root/root         0 2012-02-12 11:16 ./etc/
drwx------ root/root         0 2012-02-12 11:16 ./etc/vpnc/

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r33042

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.