Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10950 closed defect (duplicate)

Lates trunk (30423) won't boot on RouterStation Pro

Reported by: gencho.bonev@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Hi,

I've just compiled trunk version 30423 and flashed it on UBNT RouterStation pro, compilation ends without errors.
below are the boot messages:

TFTPD: Incoming connection from 192.168.1.10:51134
Received: 2425244 bytes
Firmware Version: RSPRO.ar7100pro.OpenWrt.r30423
Initializing default partitions for 16M flash size.
Created 'kernel' - base: 0xBF030000, mem base; 0x80060000, entry: 0x80060000, size: 0x000E0000
Created 'rootfs' - base: 0xBF110000, mem base; 0xBF170000, entry: 0x00000000, size: 0x00A20000

Updating FIS directory!
... Erase from 0xbfff0000-0xc0000000: .
... Program from 0x87ff0000-0x88000000 at 0xbfff0000: .

Flashing partition 'kernel' (size: 0x000E0000, actual data: 0x000E0000)
... Erase from 0xbf030000-0xbf110000: ..............
... Program from 0x8006e144-0x8014e144 at 0xbf030000: ..............

Flashing partition 'rootfs' (size: 0x00A20000, actual data: 0x00180000)
... Erase from 0xbf110000-0xbfb30000: ..................................................................................................................................................................
... Program from 0x8014e184-0x802ce184 at 0xbf110000: ........................
... Resetting.+
AR8316 PHY found on MAC0
AR8316 PHY found on MAC1
Ethernet eth0: MAC address 00:15:6d:c5:c2:b0
IP: 192.168.1.20/255.255.255.0, Gateway: 0.0.0.0
Default server: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [ROMRAM]
Ubiquiti Networks certified release, version 0.9.00318M.0905121200 - built 12:01:38, May 12 2009

Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.

Board: Ubiquiti RouterStation PRO

Arch: ar7100pro

RAM: 0x80000000-0x88000000, [0x8003bf00-0x87fe1000] available

Flash: 0xbf000000-0xc0000000, in 256 blocks of 0x00010000 bytes each

Executing boot script in 1.000 seconds - enter C to abort

RedBoot> fis load -d -e kernel
Trying LZMA decompression...
Image loaded from 0x80060000-0x802f6b40
Image is not ELF, skipping ELF parsing...
RedBoot> exec
Now booting linux kernel:

Base address 0x80050000 Entry 0x80060000
memsize=0x08000000
modetty0=0,n,8,1,hw
board=RouterStation PRO
ethaddr=00.15.6d.c5.c2.b0

[ 0.000000] Linux version 3.2.5 (gencho@lamq) (gcc version 4.5.4 20120105 (prerelease) (Linaro GCC 4.5-2012.01) ) #1 Fri Feb 10 21:08:55 EET 2012
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[ 0.000000] SoC: Atheros AR7161 rev 2
[ 0.000000] Clocks: CPU:720.000MHz, DDR:360.000MHz, AHB:180.000MHz, Ref:40.000MHz
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 08000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone PFN ranges:
[ 0.000000] Normal 0x00000000 -> 0x00008000
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0x00000000 -> 0x00008000
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512
[ 0.000000] Kernel command line: board=UBNT-RSPRO console=ttyS0,115200 ethaddr=00.15.6d.c5.c2.b0 rootfstype=squashfs,jffs2 noinitrd
[ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Writing ErrCtl register=00075ed2
[ 0.000000] Readback ErrCtl register=00075ed2
[ 0.000000] Memory: 126768k/131072k available (2059k kernel code, 4304k reserved, 397k data, 192k init, 0k highmem)
[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:48
[ 0.000000] Calibrating delay loop... 479.23 BogoMIPS (lpj=2396160)
[ 0.060000] pid_max: default: 32768 minimum: 301
[ 0.060000] Mount-cache hash table entries: 512
[ 0.070000] NET: Registered protocol family 16
[ 0.070000] MIPS: machine is Ubiquiti RouterStation Pro
[ 0.370000] registering PCI controller with io_map_base unset
[ 2.680000] bio: create slab <bio-0> at 0
[ 2.680000] Switching to clocksource MIPS
[ 2.690000] NET: Registered protocol family 2
[ 2.690000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 2.700000] TCP established hash table entries: 4096 (order: 3, 32768 bytes)
[ 2.710000] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[ 2.710000] TCP: Hash tables configured (established 4096 bind 4096)
[ 2.720000] TCP reno registered
[ 2.720000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 2.730000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 2.730000] NET: Registered protocol family 1
[ 2.750000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 2.760000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 2.770000] msgmni has been set to 247
[ 2.770000] io scheduler noop registered
[ 2.780000] io scheduler deadline registered (default)
[ 2.780000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 2.810000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[ 2.810000] console [ttyS0] enabled, bootconsole disabled
[ 2.810000] console [ttyS0] enabled, bootconsole disabled
[ 2.830000] m25p80 spi0.0: found mx25l12805d, expected m25p80
[ 2.830000] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
[ 2.840000] Searching for RedBoot partition table in spi0.0 at offset 0xfe0000
[ 2.960000] Searching for RedBoot partition table in spi0.0 at offset 0xff0000
[ 3.080000] 6 RedBoot partitions found on MTD device spi0.0
[ 3.090000] Creating 6 MTD partitions on "spi0.0":
[ 3.090000] 0x0000377035b0-0x0000377335b0 : "RedBoot"
[ 3.100000] mtd: partition "RedBoot" is out of reach -- disabled
[ 3.100000] 0x0000377335b0-0x0000378135b0 : "kernel"
[ 3.110000] mtd: partition "kernel" is out of reach -- disabled
[ 3.120000] 0x0000378135b0-0x0000386f0000 : "rootfs"
[ 3.120000] mtd: partition "rootfs" is out of reach -- disabled
[ 3.130000] mtd: partition "rootfs" set to be root filesystem
[ 3.130000] split_squashfs: no squashfs found in "spi0.0"
[ 3.140000] 0x0000386f35b0-0x0000387025b0 : "FIS directory"
[ 3.140000] mtd: partition "FIS directory" is out of reach -- disabled
[ 3.150000] 0x0000387025b0-0x0000387035b0 : "RedBoot config"
[ 3.160000] mtd: partition "RedBoot config" is out of reach -- disabled
[ 3.170000] 0x0000387035b0-0x000001000000 : "boardconfig"
[ 3.170000] mtd: partition "boardconfig" is out of reach -- disabled
[ 4.280000] ag71xx_mdio: probed
[ 4.280000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[ 4.810000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.0:04 [uid=004dd041, driver=Atheros AR8216/AR8316/AR8326]
[ 4.820000] eth1: Atheros AG71xx at 0xba000000, irq 5
[ 5.340000] eth1: AR8316 switch driver attached.
[ 5.360000] ar8316: Using port 4 as PHY
[ 6.320000] ag71xx ag71xx.1: eth1: connected to PHY at ag71xx-mdio.0:00 [uid=004dd041, driver=Atheros AR8216/AR8316/AR8326]
[ 6.330000] TCP westwood registered
[ 6.330000] NET: Registered protocol family 17
[ 6.330000] 8021q: 802.1Q VLAN Support v1.8
[ 6.340000] end_request: I/O error, dev mtdblock2, sector 0
[ 6.350000] SQUASHFS error: squashfs_read_data failed to read block 0x0
[ 6.350000] SQUASHFS error: unable to read squashfs_super_block
[ 6.360000] VFS: Cannot open root device "(null)" or unknown-block(31,2)
[ 6.360000] Please append a correct "root=" boot option; here are the available partitions:
[ 6.370000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by juhosg

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #10951.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.