Modify

Opened 6 years ago

Closed 2 years ago

Last modified 2 years ago

#10946 closed defect (invalid)

Trouble with kmod-fs-ext4 installation

Reported by: wizfrk@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: kmod-fs-ext4, dependencies, Cc:

Description

Hey,
I'm on a Buffalo wzr-hp-g300nh2, with the following openwrt:

http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-wzr-hp-g300nh2-squashfs-sysupgrade.bin

I am trying to get support for my external usb, that is formatted to ext4, but when I try to install kmod-fs-ext4 I get:

opkg install kmod-fs-ext4
Installing kmod-fs-ext4 (2.6.39.4-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/kmod-fs-ext4_2.6.39.4-1_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
 *      kernel (= 2.6.39.4-1-b589cbd61bd8226af58758bd51f35f55) *        kernel (= 2.6.39.4-1-b589cbd61bd8226af58758bd51f35f55) *
 * opkg_install_cmd: Cannot install package kmod-fs-ext4.

I've tried googling everywhere, but I can't seem to work out what's wrong, kernel incompatibilities?

Anyway thank you for your time and effort, I hope I'm not wasting anyones time.

P.S. List of install pakages:

root@OpenWrt:~# opkg list_installed
base-files - 103-r29981
base-files-network - 3
blkid - 1.41.12-2
block-mount - 0.2.0-7
busybox - 1.19.3-9
crda - 1.1.1-1
dnsmasq - 2.59-2
dropbear - 2011.54-1
firewall - 2-44
hotplug2 - 1.0-beta-4
iptables - 1.4.10-4
iptables-mod-conntrack - 1.4.10-4
iptables-mod-nat - 1.4.10-4
iw - 3.1-2
kmod-ath - 2.6.39.4+2011-12-01-2
kmod-ath9k - 2.6.39.4+2011-12-01-2
kmod-ath9k-common - 2.6.39.4+2011-12-01-2
kmod-button-hotplug - 2.6.39.4-3
kmod-cfg80211 - 2.6.39.4+2011-12-01-2
kmod-crypto-aes - 2.6.39.4-1
kmod-crypto-arc4 - 2.6.39.4-1
kmod-crypto-core - 2.6.39.4-1
kmod-input-core - 2.6.39.4-1
kmod-input-gpio-keys-polled - 2.6.39.4-1
kmod-input-polldev - 2.6.39.4-1
kmod-ipt-conntrack - 2.6.39.4-1
kmod-ipt-core - 2.6.39.4-1
kmod-ipt-nat - 2.6.39.4-1
kmod-ipt-nathelper - 2.6.39.4-1
kmod-leds-gpio - 2.6.39.4-1
kmod-ledtrig-usbdev - 2.6.39.4-1
kmod-lib-crc-ccitt - 2.6.39.4-1
kmod-mac80211 - 2.6.39.4+2011-12-01-2
kmod-nls-base - 2.6.39.4-1
kmod-ppp - 2.6.39.4-1
kmod-pppoe - 2.6.39.4-1
kmod-scsi-core - 2.6.39.4-1
kmod-usb-core - 2.6.39.4-1
kmod-usb-ohci - 2.6.39.4-1
kmod-usb-storage - 2.6.39.4-1
kmod-usb2 - 2.6.39.4-1
libblkid - 1.41.12-2
libc - 0.9.32-103
libcom_err - 1.41.12-2
libcurl - 7.23.1-1
libevent2 - 2.0.16-1
libext2fs - 1.41.12-2
libgcc - 4.5-linaro-103
libip4tc - 1.4.10-4
libiwinfo - 24
libiwinfo-lua - 24
liblua - 5.1.4-8
libnl-tiny - 0.1-2
libopenssl - 1.0.0g-1
libpthread - 0.9.32-103
librt - 0.9.32-103
libuci - 2011-11-14.1-1
libuci-lua - 2011-11-14.1-1
libuuid - 1.41.12-2
libxtables - 1.4.10-4
lua - 5.1.4-8
luci - trunk+svn8222-1
luci-app-firewall - trunk+svn8222-1
luci-i18n-english - trunk+svn8222-1
luci-lib-core - trunk+svn8222-1
luci-lib-ipkg - trunk+svn8222-1
luci-lib-lmo - trunk+svn8222-1
luci-lib-nixio - trunk+svn8222-1
luci-lib-sys - trunk+svn8222-1
luci-lib-web - trunk+svn8222-1
luci-mod-admin-core - trunk+svn8222-1
luci-mod-admin-full - trunk+svn8222-1
luci-proto-core - trunk+svn8222-1
luci-proto-ppp - trunk+svn8222-1
luci-sgi-cgi - trunk+svn8222-1
luci-theme-base - trunk+svn8222-1
luci-theme-openwrt - trunk+svn8222-1
mtd - 17
opkg - 618-2
ppp - 2.4.5-4
ppp-mod-pppoe - 2.4.5-4
swap-utils - 2.13.0.1-4
swconfig - 10
transmission-cli - 2.42-4
transmission-daemon - 2.42-4
transmission-remote - 2.42-4
transmission-web - 2.42-4
uboot-envtools - 2011.06-4
uci - 2011-11-14.1-1
uhttpd - 30
wireless-tools - 29-4
wpad-mini - 20111103-3
zlib - 1.2.5-1

Attachments (0)

Change History (20)

comment:1 Changed 6 years ago by packboy5

Hello,
I am having the same issue with the TP-Link TL-WR703N. At first it gave the same error message for kmod-usb-storage as well as kmod-fs-ext4.

root@OpenWrt:/usr/share/minipwner# opkg install kmod-usb-storage
Multiple packages (kmod-usb-storage and kmod-usb-storage) providing same name marked HOLD or PREFER. Using latest.
Upgrading kmod-usb-storage on root from 3.3.2-1 to 3.3.6-1...
Downloading downloads.openwrt.org/snapshots/trunk/ar..._3.3.6-1_ar71xx.ipk.
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
  • kernel (= 3.3.6-1-a74494b168fe5348046737544dfa4087) *
  • opkg_install_cmd: Cannot install package kmod-usb-storage.

root@OpenWrt:/usr/share/minipwner# opkg install kmod-fs-ext4
Installing kmod-fs-ext4 (3.3.6-1) to root...
Downloading downloads.openwrt.org/snapshots/trunk/ar..._3.3.6-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 3.3.6-1-a74494b168fe5348046737544dfa4087) * kernel (= 3.3.6-1-a74494b168fe5348046737544dfa4087) *
  • opkg_install_cmd: Cannot install package kmod-fs-ext4.

I then installed the kmod-usb-storage from a different source (www.lapooh.com/kmod-usb-storage_3.3.2-1_ar71xx.ipk) and it installed. After installing it the kmod-fs-ext4 still came up with this error:

root@OpenWrt:/usr/share/minipwner# opkg install kmod-fs-ext4
Unknown package 'kmod-fs-ext4'.
Collected errors:

  • opkg_install_cmd: Cannot install package kmod-fs-ext4.

Then,

root@OpenWrt:/tmp# wget downloads.openwrt.org/snapshots/trunk/ar71xx
/packages/kmod-fs-ext4_3.3.6-1_ar71xx.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
kmod-fs-ext4_3.3.6-1 100% || 178k 0:00:00 ETA
root@OpenWrt:/tmp# opkg --force-depends install kmod-fs-ext4_3.3.6-1_ar71xx
.ipk
Installing kmod-fs-ext4 (3.3.6-1) to root...
Configuring kmod-fs-ext4.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 3.3.6-1-a74494b168fe5348046737544dfa4087) * kmod-lib-crc16 *

Any help with this would be greatly appreciated. Thanks in advance for help with. this.

comment:2 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

the build that the package was from does not match the build that you flashed. both need to come from the exact same build with the same configuration, otherwise it won't work.

comment:3 Changed 6 years ago by packboy5

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Thank you. How can I fix that?

comment:4 Changed 6 years ago by nbd

  • Resolution set to invalid
  • Status changed from reopened to closed

either make a new build yourself (which includes all the packages that you need) or flash a new build from the snapshot side

comment:5 Changed 6 years ago by felmoltor@…

Hello,

I'm having the same problem as packboy5, and also with the TP-Link TL-WR703N trying to build the minipwner.

How can we create a new build with all the packages needed by myself?

Thanks.

comment:6 Changed 4 years ago by celtic_tigger1@…

The problem is common. you installed your openWRT firmware to the router, and somewhere between the time you installed that firmware and the time you tried installing some packages, the build was modified (could just be time stamps changed ..who really knows). Therefore the checksums on some packages won't match that of your current kernel. Simple solution... download the most recent firmware from OpenWRT's download page, and reflash. On my TP-Link703N this is what i do:

firstboot
wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
mtd write openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin firmware
reboot

comment:7 Changed 4 years ago by celtic_tigger1@…

The problem is common. you installed your openWRT firmware to the router, and somewhere between the time you installed that firmware and the time you tried installing some packages, the build was modified (could just be time stamps changed ..who really knows). Therefore the checksums on some packages won't match that of your current kernel. Simple solution... download the most recent firmware from OpenWRT's download page, and reflash. On my TP-Link703N this is what i do:

firstboot
wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
mtd write openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin firmware
reboot

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:9 Changed 3 years ago by gyurman

root@OpenWrt:~# opkg info kmod-fs-ext4
Package: kmod-fs-ext4
Version: 3.18.14-1
Depends: kernel (= 3.18.14-1-602a5bf2b6c088438900e0771bab6c9f), kmod-lib-crc16, kmod-crypto-hash
Status: unknown hold not-installed
Section: kernel
Architecture: ar71xx
MD5Sum: 231b6e85ba69247d7b3f0ff7d925bc78
Size: 225146
Filename: kmod-fs-ext4_3.18.14-1_ar71xx.ipk
Source: package/kernel/linux
Description: Kernel module for EXT4 filesystem support

root@OpenWrt:~# opkg install kmod-fs-ext4
Installing kmod-fs-ext4 (3.18.14-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/base/kmod-fs-ext4_3.18.14-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 3.18.14-1-602a5bf2b6c088438900e0771bab6c9f) * kernel (= 3.18.14-1-602a5bf2b6c088438900e0771bab6c9f) * kernel (= 3.18.14-1-602a5bf2b6c088438900e0771bab6c9f) *
  • opkg_install_cmd: Cannot install package kmod-fs-ext4.

comment:10 Changed 3 years ago by gyurman

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:11 Changed 3 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:12 Changed 3 years ago by br3ttski

I found this page after flashing a sysupgrade image and broke opkg - all packages failed to install.

I resolved by finding my firmware's directory at downloads.openwrt.org then editing /etc/opkg.conf to match the correct directories.

In my case it was http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/
So I edited opkg.conf:

root@OpenWrt:/# vi /etc/opkg.conf

Where sources were pointing to the old firmware directories, I updated them to the new ones:

src/gz chaos_calmer_base http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/packages/base
src/gz chaos_calmer_luci http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/packages/luci
src/gz chaos_calmer_management http://downloads.openwrt.org/chaos_calmer/15.05-rc2/ar71xx/generic/packages/management
etc...

Hope this helps :)

comment:13 Changed 2 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I am facing similar problem with netgear wndr3800 router. I even selected the kmod packages from make menuconfig interface, but the problem is that the generated image does not contain the package i selected. After upgrading the image with custom built firmware, when i try to install the packages usinf opkg install command. It shows the similar error as shown:

opkg install kmod-fs-ext4
Installing kmod-fs-ext4 (2.6.39.4-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/kmod-fs-ext4_2.6.39.4-1_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-ext4:
  • kernel (= 2.6.39.4-1-b589cbd61bd8226af58758bd51f35f55) * kernel (= 2.6.39.4-1-b589cbd61bd8226af58758bd51f35f55) *
  • opkg_install_cmd: Cannot install package kmod-fs-ext4.

comment:14 Changed 2 years ago by anonymous

Very old trunk. Upgrade to current version.

comment:15 Changed 2 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:16 Changed 2 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

I upgraded it to latest Openwrt chaos calmer base, but still the issue remains the same. It is still not generating the packages I mention in make menuconfig, an opkg is throwing the kernel dependency error(as its not from the custom build firmware)

comment:17 Changed 2 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

Copy /rom/etc/opkg.conf to /etc, or reset your router to defaults and rebuild your config.

comment:18 Changed 2 years ago by anonymous

  • Resolution not_a_bug deleted
  • Status changed from closed to reopened

I did copy /rom/etc/opkg.conf, but it isnt resolving the issue. Here is what i did from the begening:
1)Downloded github code of chaos calmer
2)./scripts/feeds update -a
3)./scripts/feeds install -a
4) make menuconfig, from there i selected target(ar71xx) and image(netgear wndr3800). Also kmod-sched and kmod-tun under kernel-modules->networksupport and openflow from networking, save the config file
5) make
6) Flashed the openwrt custom built image on the actual hardware
7) On the router I cannot see the packages i mentioned in the opkg list-installed packages.

Please help what could be wrong.

comment:19 Changed 2 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

You cannot use repository kmods with custom builds, build the kmods you need yourself. And please stop reopening this ticket for support questions, it is getting annoying.

comment:20 Changed 2 years ago by anonymous

ok thanks jow.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.