Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10937 closed defect (fixed)

Unable to compile vsftpd

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: vsftpd ftp Cc:

Description

I get an error while trying to build the latest OpenWRT trunk with "make world V=99".
When it tries to compile vsftpd I get these errors and the compiler aborts.

sysutil.o: In function `vsf_sysutil_setmodtime':
sysutil.c:(.text+0x3500): warning: the use of OBSOLESCENT `utime' is discouraged, use `utimes'
sysutil.o: In function `vsf_sysutil_dns_resolve':
sysutil.c:(.text+0x2b98): warning: gethostbyname is obsolescent, use getnameinfo() instead.
sysdeputil.o: In function `vsf_sysdep_has_capabilities':
sysdeputil.c:(.text+0x238): undefined reference to `cap_get_proc'
sysdeputil.c:(.text+0x244): undefined reference to `cap_free'
sysdeputil.o: In function `vsf_sysdep_adopt_capabilities':
sysdeputil.c:(.text+0x28c): undefined reference to `cap_init'
sysdeputil.c:(.text+0x2bc): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x2d4): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x300): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x318): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x320): undefined reference to `cap_set_proc'
sysdeputil.c:(.text+0x338): undefined reference to `cap_free'
collect2: ld returned 1 exit status
make[4]: *** [vsftpd] Error 1
make[4]: Leaving directory `/media/OpenWRT/trunk/build_dir/target-mips_r2_uClibc-0.9.32/vsftpd-2.3.4'
make[3]: *** [/media/OpenWRT/trunk/build_dir/target-mips_r2_uClibc-0.9.32/vsftpd-2.3.4/.built] Error 2
make[3]: Leaving directory `/media/OpenWRT/trunk/feeds/packages/net/vsftpd'
make[2]: *** [package/feeds/packages/vsftpd/compile] Error 2
make[2]: Leaving directory `/media/OpenWRT/trunk'
make[1]: *** [/media/OpenWRT/trunk/staging_dir/target-mips_r2_uClibc-0.9.32/stamp/.package_compile] Error 2
make[1]: Leaving directory `/media/OpenWRT/trunk'
make: *** [world] Error 2

I already tried to deleting everything and re-checkout the SVN, but no success.

Attachments (1)

.config (133.7 KB) - added by brezerk@… 6 years ago.
This is my .config file. Just in case…

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by obsy

I cant reproduce this issue. On ar71xx vsftpd builds fine, without any problem. Did you try recompile SDK without vsftpd?

comment:2 Changed 6 years ago by netprince

I am having the same problem, building on Linux ubuntu 3.0.0-15-generic

comment:3 Changed 6 years ago by anonymous

obsy: I tried building for ar71xx too.
I tried recompiling with SDK and without vsftpd and that worked.

Well, for now I just installed vsftpd with opkg.

comment:4 Changed 6 years ago by anonymous

I tried compiling vsftpd with r30000 and it worked.
So the problem appears somewhere between r30000 and r30387.

In between those revisions are only a few "big" changes (everything else are just packages and stuff which shouldn't affect vsftpd).
So I think one of these broke it: r30374 r30372 r30345 r30026

r30374 is the only one that could've broke it, I guess. So this is related to that ticket?
#10974

comment:5 Changed 6 years ago by anonymous

Same issue, new clean buildroot, ar71xx.

comment:6 Changed 6 years ago by anonymous

anyone?

comment:7 Changed 6 years ago by anonymous

Is this in any way related to this?

It seems that uClibc 0.9.33 in OpenWRT has dropped res_n* functions and Asterisk fails to build. Maybe we should fix the toolchain? 

/ticket/10974.html

comment:8 Changed 6 years ago by anonymous

Ubuntu 11.04 + updates

OpenWrt trunk 30850. The vsftpd was compiled today without problems.

$ ls -l OPENWRT/trunk/bin/ar71xx/packages/vsftpd*
-rw-r--r-- 1 yohimba yohimba 41691 2012-03-08 17:27 OPENWRT/trunk/bin/ar71xx/packages/vsftpd_2.3.4-3_ar71xx.ipk

comment:9 Changed 6 years ago by anonymous

make package/vsftpd/{clean,compile} V=99

comment:10 in reply to: ↑ description Changed 6 years ago by brezerk@…

Just tested revision: 30940

And got the same error using uClibc-0.9.33 or uClibc 0.9.32-git :(

mips-openwrt-linux-uclibc-gcc -o vsftpd main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o tunables.o ftpdataio.o secbuf.o ls.o postprivparent.o logging.o str.o netstr.o sysstr.o strlist.o banner.o filestr.o parseconf.o secutil.o ascii.o oneprocess.o twoprocess.o privops.o standalone.o hash.o tcpwrap.o ipaddrparse.o access.o features.o readwrite.o opts.o ssl.o sslslave.o ptracesandbox.o ftppolicy.o sysutil.o sysdeputil.o  -lcrypt -lnsl 
sysdeputil.o: In function `vsf_sysdep_has_capabilities':
sysdeputil.c:(.text+0x238): undefined reference to `cap_get_proc'
sysdeputil.c:(.text+0x248): undefined reference to `cap_free'
sysdeputil.o: In function `vsf_sysdep_adopt_capabilities':
sysdeputil.c:(.text+0x28c): undefined reference to `cap_init'
sysdeputil.c:(.text+0x2bc): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x2d4): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x300): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x318): undefined reference to `cap_set_flag'
sysdeputil.c:(.text+0x320): undefined reference to `cap_set_proc'
sysdeputil.c:(.text+0x338): undefined reference to `cap_free'
collect2: ld returned 1 exit status
make[3]: *** [vsftpd] Error 1

Changed 6 years ago by brezerk@…

This is my .config file. Just in case...

comment:11 follow-up: Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r30941

comment:12 in reply to: ↑ 11 Changed 6 years ago by brezerk@…

Replying to jow:

Fixed in r30941

Tested. Works like a charm :)
Thank you!

comment:13 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.