Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10930 closed defect (fixed)

Instant crash on fonera with trunk r30347

Reported by: duvi Owned by: nbd
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

With ath5k, wds station mode. The device hangs at the moment wpa_supplicant tries to connect, then reboots. The config:

config wifi-device  radio0
        option disabled 0
        option type     mac80211
        option channel  auto
        option macaddr  00:18:84:27:a3:c9
        option hwmode   11g
        option txpower  18
        option diversity 0
        option rxantenna 1
        option txantenna 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     sta
        option wds      1
        option ssid     ***
        option encryption psk2
        option key      ***

However, r30345 is working perfectly, so the problem is caused by wireless-testing 2012-02-06 (r30346) or iw 3.3 (r30347).

See the log from serial:

[   44.760000] CPU 0 Unable to handle kernel paging request at virtual address 00000004, epc == 80433220, ra == 80401e70
[   44.890000] Oops[#1]:
[   44.890000] Cpu 0
[   44.890000] $ 0   : 00000000 10009c00 00000000 80fa0bd8
[   44.890000] $ 4   : 00000000 00000000 80fa0bc0 805b8000
[   44.890000] $ 8   : 00000000 00000000 00000005 00000001
[   44.890000] $12   : 00000004 ffffffff 00000050 00470000
[   44.890000] $16   : 80536c00 80fa0bd8 80e28a60 80fa0bc0
[   44.890000] $20   : 803dd822 80e2ccc0 00000001 80fa0bd8
[   44.890000] $24   : 0047540c 804331e0                  
[   44.890000] $28   : 805a8000 805a9de8 0000b000 80401e70
[   44.890000] Hi    : 00000000
[   44.890000] Lo    : 00000000
[   44.890000] epc   : 80433220 0x80433220
[   44.890000]     Not tainted
[   44.890000] ra    : 80401e70 0x80401e70
[   44.890000] Status: 10009c03    KERNEL EXL IE 
[   44.890000] Cause : 00800008
[   44.890000] BadVA : 00000004
[   44.890000] PrId  : 00019064 (MIPS 4KEc)
[   44.890000] Modules linked in: ath5k ath mac80211 ipv6 cfg80211 compat arc4 aes_generic crypto_algapi
[   44.890000] Process wpa_supplicant (pid: 618, threadinfo=805a8000, task=803ec1c8, tls=2aee22d0)
[   44.890000] Stack : 00000001 80d23124 00000001 7fc31f70 80fa0bc0 8058aca0 805870c4 00273097
[   44.890000]         00273097 800aa1dc 00000000 00000001 00000000 80e296fc 803dd826 00000000
[   44.890000]         00000000 803dd82c 80e29600 803c45d0 80fa0bd8 80fa0bc0 80e29600 80e2ccc0
[   44.890000]         00000000 80e2ccc8 80460000 8044f90c 80d23124 8058aca0 00000001 7fc31f70
[   44.890000]         00000000 8004cf8c 07010100 00160003 00000161 00000100 80e2ccc8 80e2ccb4
[   44.890000]         ...
[   44.890000] Call Trace:[<800aa1dc>] 0x800aa1dc
[   44.890000] [<8044f90c>] 0x8044f90c
[   44.890000] [<8004cf8c>] 0x8004cf8c
[   44.890000] [<8005df6c>] 0x8005df6c
[   44.890000] [<800883c0>] 0x800883c0
[   44.890000] [<8005e67c>] 0x8005e67c
[   44.890000] [<8005e7a0>] 0x8005e7a0
[   44.890000] [<80043644>] 0x80043644
[   44.890000] 
[   44.890000] 
[   44.890000] Code: 8ce90034  01091021  00004021 <8c580004> 13050007  00497823  25080001  00a87823  15edfffa 
[   44.890000] Disabling lock debugging due to kernel taint
[   47.120000] Kernel panic - not syncing: Fatal exception in interrupt
[   61.340000] watchdog expired, rebooting system

Full bootlog attached.

Attachments (2)

fonera_log_r30347.log (12.8 KB) - added by duvi 6 years ago.
fonera_log_r30347_symbols.log (12.1 KB) - added by duvi 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by duvi

comment:1 Changed 6 years ago by jow

  • Owner changed from developers to nbd
  • Status changed from new to assigned

Please rebuild your kernel with symbol table information so we can see what is going on.

comment:2 Changed 6 years ago by duvi

Is this what you need?

[   45.360000] CPU 0 Unable to handle kernel paging request at virtual address 00000004, epc == 80433220, ra == 80401e70
[   45.490000] Oops[#1]:
[   45.490000] Cpu 0
[   45.490000] $ 0   : 00000000 10009c00 00000000 80930638
[   45.490000] $ 4   : 00000000 00000000 80930620 80686000
[   45.490000] $ 8   : 00000000 00000000 00000005 00000001
[   45.490000] $12   : 00000004 ffffffff 00000050 00470000
[   45.490000] $16   : 804c7400 80930638 80348a60 80930620
[   45.490000] $20   : 8048b022 8034ccc0 00000000 80930638
[   45.490000] $24   : 00000000 804331e0                  
[   45.490000] $28   : 805c8000 805c98c0 0000b000 80401e70
[   45.490000] Hi    : 00000000
[   45.490000] Lo    : 00000000
[   45.490000] epc   : 80433220 mesh_path_tx_root_frame+0xf0/0xcfc [mac80211]
[   45.490000]     Not tainted
[   45.490000] ra    : 80401e70 ieee80211_tx_status+0x368/0xdcc [mac80211]
[   45.490000] Status: 10009c03    KERNEL EXL IE 
[   45.490000] Cause : 00800008
[   45.490000] BadVA : 00000004
[   45.490000] PrId  : 00019064 (MIPS 4KEc)
[   45.490000] Modules linked in: ath5k ath mac80211 ipv6 cfg80211 compat arc4 aes_generic crypto_algapi
[   45.490000] Process wpa_supplicant (pid: 632, threadinfo=805c8000, task=80db01a8, tls=2ac672d0)
[   45.490000] Stack : 00000000 805c98e0 805c99ef 80148590 80930620 80148590 00000000 00000003
[   45.490000]         30303030 36330003 00000000 00000001 00000000 803496fc 8048b026 00000000
[   45.490000]         8048b022 8048b02c 80349600 80d985d0 80930638 80930620 80349600 8034ccc0
[   45.490000]         00000000 8034ccc8 80460000 8044f90c 80930638 80410afc 805c99e0 805c99ef
[   45.490000]         00000000 00000000 07010100 00160002 0000005f 00000100 8034ccc8 8034ccb4
[   45.490000]         ...
[   45.490000] Call Trace:
[   45.490000] [<80433220>] mesh_path_tx_root_frame+0xf0/0xcfc [mac80211]
[   45.490000] 
[   45.490000] 
[   45.490000] Code: 8ce90034  01091021  00004021 <8c580004> 13050007  00497823  25080001  00a87823  15edfffa 
[   45.490000] Disabling lock debugging due to kernel taint
[   47.550000] Kernel panic - not syncing: Fatal exception in interrupt
[   60.870000] watchdog expired, rebooting system

Changed 6 years ago by duvi

comment:3 Changed 6 years ago by duvi

Seems fixed with r30388, thanks!

comment:4 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.