Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10923 closed defect (duplicate)

ath: Failed to stop TX DMA, queues=0x004! and Slow Speed on Wireless LAN

Reported by: Thytum@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

BusyBox v1.19.3 (2012-02-05 12:33:42 MST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r30310) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@VKengRouterNordeste:~# uname -a ; dmesg | grep ath
Linux VKengRouterNordeste 2.6.39.4 #1 Sun Feb 5 22:39:29 MST 2012 mips GNU/Linux
[   13.320000] ath: EEPROM regdomain: 0x0
[   13.320000] ath: EEPROM indicates default country code should be used
[   13.320000] ath: doing EEPROM country->regdmn map search
[   13.320000] ath: country maps to regdmn code: 0x3a
[   13.320000] ath: Country alpha2 being used: US
[   13.320000] ath: Regpair used: 0x3a
[   78.190000] ath: Failed to stop TX DMA, queues=0x004!
[  154.570000] ath: Failed to stop TX DMA, queues=0x004!
[  175.210000] ath: Failed to stop TX DMA, queues=0x004!
[  216.960000] ath: Failed to stop TX DMA, queues=0x004!
[  230.520000] ath: Failed to stop TX DMA, queues=0x004!
[  244.370000] ath: Failed to stop TX DMA, queues=0x004!
[  407.220000] ath: Failed to stop TX DMA, queues=0x004!
[  410.350000] ath: Failed to stop TX DMA, queues=0x004!
root@VKengRouterNordeste:/proc# cat version 
Linux version 2.6.39.4 (openwrt@OpenWRTBuild) (gcc version 4.5.4 20120105 (prerelease) (Linaro GCC 4.5-2012.01) ) #1 Sun Feb 5 22:39:29 MST 2012
Full Dmesg description : 

root@VKengRouterNordeste:~# dmesg 
[    0.000000] Linux version 2.6.39.4 (openwrt@OpenWRTBuild) (gcc version 4.5.4 20120105 (prerelease) (Linaro GCC 4.5-2012.01) ) #1 Sun Feb 5 22:39:29 MST 2012
[    0.000000] prom: fw_arg0=00000001, fw_arg1=80a01920, fw_arg2=00000000, fw_arg3=00000000
[    0.000000] MyLoader: sysp=00000000, boardp=81a14800, parts=00000020
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9132 rev 2
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00002000
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00002000
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 802d8c00, node_mem_map 81000000
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8128 pages, LIFO batch:0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=TL-WR1043ND console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 29224k/32768k available (2120k kernel code, 3544k reserved, 412k data, 192k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:80
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.090000] MIPS: machine is TP-LINK TL-WR1043ND
[    0.350000] bio: create slab <bio-0> at 0
[    0.360000] Switching to clocksource MIPS
[    0.360000] NET: Registered protocol family 2
[    0.370000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.370000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.380000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.380000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.390000] TCP reno registered
[    0.390000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.400000] NET: Registered protocol family 1
[    0.410000] PCI: CLS 0 bytes, default 32
[    0.420000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.430000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.440000] msgmni has been set to 57
[    0.440000] io scheduler noop registered
[    0.450000] io scheduler deadline registered (default)
[    0.450000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.480000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.490000] console [ttyS0] enabled, bootconsole disabled
[    0.500000] Atheros AR71xx SPI Controller driver version 0.2.4
[    0.510000] m25p80 spi0.0: found s25sl064a, expected m25p80
[    0.510000] m25p80 spi0.0: s25sl064a (8192 Kbytes)
[    0.520000] 5 tp-link partitions found on MTD device spi0.0
[    0.520000] Creating 5 MTD partitions on "spi0.0":
[    0.530000] 0x000000000000-0x000000020000 : "u-boot"
[    0.540000] 0x000000020000-0x000000110000 : "kernel"
[    0.540000] 0x000000110000-0x0000007f0000 : "rootfs"
[    0.550000] mtd: partition "rootfs" set to be root filesystem
[    0.560000] split_squashfs: no squashfs found in "spi0.0"
[    0.560000] 0x0000007f0000-0x000000800000 : "art"
[    0.570000] 0x000000020000-0x0000007f0000 : "firmware"
[    0.580000] Realtek RTL8366RB ethernet switch driver version 0.2.3
[    0.580000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[    0.590000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[    0.650000] rtl8366rb: probed
[    0.660000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[    0.960000] eth0: using fixed link parameters
[    0.960000] Atheros AR71xx hardware watchdog driver version 0.1.0
[    0.970000] ar71xx-wdt: timeout=15 secs (max=21)
[    0.970000] TCP westwood registered
[    0.980000] NET: Registered protocol family 17
[    0.980000] Bridge firewalling registered
[    0.980000] 802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
[    0.990000] All bugs added by David S. Miller <davem@redhat.com>
[    3.390000] JFFS2 notice: (1) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[    3.400000] VFS: Mounted root (jffs2 filesystem) readonly on device 31:2.
[    3.410000] Freeing unused kernel memory: 192k freed
[    6.860000] input: gpio-keys-polled as /devices/platform/gpio-keys-polled/input/input0
[    6.890000] Button Hotplug driver version 0.4.1
[    6.920000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[    6.920000] eth0: link up (1000Mbps/Full duplex)
[    6.960000] Registered led device: tp-link:green:usb
[    6.970000] Registered led device: tp-link:green:system
[    6.970000] Registered led device: tp-link:green:qss
[    6.970000] Registered led device: tp-link:green:wlan
[   10.190000] eth0: link down
[   11.320000] Compat-wireless backport release: compat-wireless-2011-11-29
[   11.320000] Backport based on wireless-testing.git master-2011-12-01
[   11.620000] cfg80211: Calling CRDA to update world regulatory domain
[   12.060000] usbcore: registered new interface driver usbfs
[   12.060000] usbcore: registered new interface driver hub
[   12.080000] cfg80211: World regulatory domain updated:
[   12.080000] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   12.090000] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   12.100000] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   12.100000] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   12.110000] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   12.120000] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   12.130000] usbcore: registered new device driver usb
[   13.320000] ath: EEPROM regdomain: 0x0
[   13.320000] ath: EEPROM indicates default country code should be used
[   13.320000] ath: doing EEPROM country->regdmn map search
[   13.320000] ath: country maps to regdmn code: 0x3a
[   13.320000] ath: Country alpha2 being used: US
[   13.320000] ath: Regpair used: 0x3a
[   13.320000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   13.320000] ieee80211 phy0: Atheros AR9100 MAC/BB Rev:7 AR2133 RF Rev:a2 mem=0xb80c0000, irq=2
[   13.340000] cfg80211: Calling CRDA for country: US
[   13.420000] cfg80211: Regulatory domain changed to country: US
[   13.430000] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   13.440000] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[   13.450000] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[   13.450000] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.460000] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.470000] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.480000] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[   13.540000] PPP generic driver version 2.4.2
[   13.770000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   13.950000] NET: Registered protocol family 24
[   14.080000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   14.090000] ar71xx-ehci ar71xx-ehci: Atheros AR91xx built-in EHCI controller
[   14.100000] ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
[   14.130000] ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
[   14.150000] ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
[   14.150000] hub 1-0:1.0: USB hub found
[   14.160000] hub 1-0:1.0: 1 port detected
[   14.310000] nf_conntrack version 0.5.0 (459 buckets, 1836 max)
[   14.730000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   15.830000] ar71xx: pll_reg 0xb8050014: 0x1a000000
[   16.130000] eth0: link up (1000Mbps/Full duplex)
[   17.930000] ar71xx-wdt: enabling watchdog timer
[   18.550000] device wlan0 entered promiscuous mode
[   19.720000] device eth0.1 entered promiscuous mode
[   19.730000] device eth0 entered promiscuous mode
[   21.370000] br-lan: port 2(eth0.1) entering forwarding state
[   21.380000] br-lan: port 2(eth0.1) entering forwarding state
[   21.380000] br-lan: port 1(wlan0) entering forwarding state
[   21.390000] br-lan: port 1(wlan0) entering forwarding state
[   21.570000] device wlan0 left promiscuous mode
[   21.580000] br-lan: port 1(wlan0) entering forwarding state
[   21.700000] device wlan0 entered promiscuous mode
[   21.710000] br-lan: port 1(wlan0) entering forwarding state
[   21.710000] br-lan: port 1(wlan0) entering forwarding state
[   36.400000] br-lan: port 2(eth0.1) entering forwarding state
[   36.720000] br-lan: port 1(wlan0) entering forwarding state
[   78.190000] ath: Failed to stop TX DMA, queues=0x004!
[  154.570000] ath: Failed to stop TX DMA, queues=0x004!
[  175.210000] ath: Failed to stop TX DMA, queues=0x004!
[  216.960000] ath: Failed to stop TX DMA, queues=0x004!
[  230.520000] ath: Failed to stop TX DMA, queues=0x004!
[  244.370000] ath: Failed to stop TX DMA, queues=0x004!
[  407.220000] ath: Failed to stop TX DMA, queues=0x004!
[  410.350000] ath: Failed to stop TX DMA, queues=0x004!
[  594.610000] ath: Failed to stop TX DMA, queues=0x004!
[  596.110000] ath: Failed to stop TX DMA, queues=0x004!
[  622.890000] ath: Failed to stop TX DMA, queues=0x004!
config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' 'f8:d1:11:50:f0:62'
        option 'hwmode' '11ng'
        option 'htmode' 'HT20'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'channel' 'auto'
        option 'txpower' '27'
        option 'country' 'US'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'mode' 'ap'
        option 'ssid' 'VKeng_Projetos'
        option 'encryption' 'psk'

Good Morning :)

Im having problems with wireless network, im new on OpenWrt, so i try few things:
Upgrade the System to Trunk : http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
The old System was a : http://downloads.openwrt.org/backfire/10.03.1-rc6/ar71xx/openwrt-ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin

I was looking for infomation about the fixies, but i dont understand about apply a "patch or a fix", that´s why i just try to upgrade to a Trunk version.

My Router is a TP-Link WR1043ND Ver. 1.8

Can anyone help me with this please?

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9693

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.