Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10894 closed defect (duplicate)

strange txpower bug

Reported by: Halo2 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Here on Buffalo wzr-hp-ag300h:

5GHz (2,4GHz is affected the same way, but has an additional strange behaviour which i describe in the next ticket):

option 'diversity' '0'
option 'txantenna' '0'
option 'rxantenna' '0'
option 'txpower' '17'

iwlist txpower:

Current Tx-Power=17 dBm       (50 mW)

changing antenna settings (i.e.):

option 'txantenna' '2'
option 'rxantenna' '2'

wifi, and iwlist txpower still on:

Current Tx-Power=17 dBm       (50 mW)

reboot
iwlist txpower now at:

Current Tx-Power=14 dBm       (25 mW)

changing back to:

option 'txantenna' '0'
option 'rxantenna' '0'

wifi, and iwlist txpower still at:

Current Tx-Power=14 dBm       (25 mW)

reboot and iwlist txpower is back on:

Current Tx-Power=17 dBm       (50 mW)

So as soon as you set an antenna (1 or 2 in these cases)
5GHz goes down to 14 (for all from 14 to ("max") 17))
and 2,4GHz goes down to 12 (for all from 12 to ("max") 16 (but real "max" 15)).

Attachments (0)

Change History (10)

comment:1 follow-up: Changed 6 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

That's normal. The power output display shows the combined output power of all tx chains. If you disable some of them, the combined tx power gets reduced.

comment:2 in reply to: ↑ 1 Changed 6 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to nbd:

That's normal. The power output display shows the combined output power of all tx chains. If you disable some of them, the combined tx power gets reduced.

Okay, but then the little bug would be that iwlist txpower does not correctly display until you reboot under this configuration change?!

And I'm not sure, but could it be that it was so that with diversity 0 and antenna 0 only the first, so the same as with antenna 1, was used and not both. So then the iwlist txpower output would be incorrect in this situation anyways (I hope I don't bolix this with the device which only had one chain..)

comment:3 follow-up: Changed 6 years ago by nbd

Does it have to be a reboot, or does multiple invocations of 'wifi' also fix it?

comment:4 in reply to: ↑ 3 Changed 6 years ago by Halo2

Replying to nbd:

Does it have to be a reboot, or does multiple invocations of 'wifi' also fix it?

It has to be a reboot

comment:5 in reply to: ↑ description Changed 6 years ago by Halo2

retested on r30428

comment:6 follow-up: Changed 6 years ago by nbd

please try latest trunk to see if the issue is still there

comment:7 in reply to: ↑ 6 Changed 6 years ago by Halo2

Replying to nbd:

please try latest trunk to see if the issue is still there

Yes the issue is still there.

comment:8 follow-up: Changed 6 years ago by nbd

  • Resolution set to duplicate
  • Status changed from reopened to closed

too many tx power tickets with vague titles make things a bit confusing, marking this as a duplicate of #11136

comment:9 in reply to: ↑ 8 Changed 6 years ago by Halo2

Yes thats okay, #11136 describes the same issue in more detail (but unfortunately with the additional now solved bug of #11135)

Replying to nbd:

too many tx power tickets with vague titles make things a bit confusing, marking this as a duplicate of #11136

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.