Modify

Opened 6 years ago

Last modified 4 years ago

#10892 new defect

easy-rsa package: build-ca fails error in line 151 openssl.cnf

Reported by: anonymous Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version: Backfire 10.03.1 RC6
Keywords: Cc:

Description

I tried to build a CA with build-ca like it is described in the openvpn tutorial in the wiki (http://wiki.openwrt.org/inbox/vpn.howto).

But it failed with the error:

root@taurus:/etc/easy-rsa# build-ca
NOTE: If you run ./clean-all, I will be doing a rm -rf on /etc/easy-rsa/keys
error on line 151 of /etc/easy-rsa/openssl.cnf
9010:error:0E065068:lib(14):func(101):reason(104):NA:0:line 151

Seems like some of the options in the default vars file are not set.
After i added

KEY_OU=""
KEY_CN=""
KEY_NAME=""

to the /etc/easy-rsa/vars

it worked.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.