Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10873 closed defect (fixed)

build for r29946 fails unrecognized option '-Qy'

Reported by: Alfred Ganz <alfred-ganz+openwrt@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: Cc:

Description

I just tried to build for the first time, and I get an error in:

make[3] -C toolchain/gcc/minimal compile.

The checked out version is:

Checked out revision 29946.

The build environment is:

CentOS release 6.2 (Final)

with the latest vanilla updates.

Here is part of the V=99 output:

{{{make[5]: Entering directory `/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01-minimal/gcc'

i686-redhat-linux-gcc -c -DIN_GCC -DCROSS_DIRECTORY_STRUCTURE -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wc++-compat -DHAVE_CONFIG_H -DGENERATOR_FILE -I. -Ibuild -I/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc -I/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc/build -I/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc/../include -I/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc/../libcpp/include -I/home/openwrt/trunk/staging_dir/host/include -I/home/openwrt/trunk/staging_dir/host/include -I/home/openwrt/trunk/staging_dir/host/include -I/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc/../libdecnumber -I/home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc/../libdecnumber/dpd -I../libdecnumber -I/usr/include/libelf \

-o build/genmodes.o /home/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/gcc-linaro-4.5-2012.01/gcc/genmodes.c

/home/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.5-linaro_uClibc-0.9.32/mips-openwrt-linux-uclibc/bin/as: unrecognized option '-Qy'
make[5]: * [build/genmodes.o] Error 1
}}}

What am I doing wrong?

Thanks, AG

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by jow

It is probably a problem with your environment, make sure there is no "./" in PATH, check whether "as" indeed points to the system assembler and not some other executable.

comment:2 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

Jow, thanks for the hint, the . in the PATH was the cause for my trouble! AG

comment:3 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

I added a filter for this in r29951 and r29952.

comment:4 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

Jow, I am sorry to hassle you with this, but my PATH contains a plain ".",
which is actually legit, so to do this right, "." should also be removed.

Thanks for your work! AG

comment:5 Changed 6 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

Which the change linked above already does. Please verify the claims before reopening a ticket.

comment:6 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

  • Resolution invalid deleted
  • Status changed from closed to reopened

Jow, Sorry, but I just tried to build with a PATH that contains:
".:/usr/bin:/bin", and the build failed, then I changed the PATH to:
"/usr/bin:/bin", and the build now proceeds.

A Path element of "." is not treated the same way as "./" by the latest fix.

Thanks, AG

comment:7 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

P.S. svn up trunk shows: At revision 29953

comment:8 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

Here is an extract from the above build:

make[2] toolchain/install
make[3] -C toolchain/binutils prepare
make[3] -C toolchain/binutils compile
make[3] -C toolchain/binutils install
make[3] -C toolchain/gcc/minimal prepare
make[3] -C toolchain/gcc/minimal compile

make -r world: build failed. Please re-run make with V=99 to see what's going on
make: * [world] Error 1

network:ganz(47) echo $PATH

.:/usr/bin:/bin

network:ganz(48) setenv PATH /usr/bin:/bin

network:ganz(49) echo $PATH

/usr/bin:/bin

network:ganz(50) make

make[1] world
make[2] toolchain/install
make[3] -C toolchain/binutils prepare
make[3] -C toolchain/binutils compile
make[3] -C toolchain/binutils install
make[3] -C toolchain/gcc/minimal prepare
make[3] -C toolchain/gcc/minimal compile
make[3] -C toolchain/gcc/minimal install
make[3] -C toolchain/kernel-headers prepare

and the build goes all the way.

Sorry, but I really think a PATH with a starting "." isn't fixed.

Thanks for bearing with me, AG

comment:9 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

Jow, you are correct. I have spent a lot of time trying to understand why I had all
the above problems. After many long experiments, the explanation is that I did the
"svn up trunk" in the trunk directory and not in its parent directory. Doing it in
the right directory made all the difference.

I am sorry to have complained too early.

Thanks for your patience, AG

comment:10 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

okay

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.