Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10868 closed defect (wontfix)

luci fails after installing luci-app-qos through web interface

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: 10.03.1
Keywords: Cc:

Description

Steps to reproduce:

  1. Go to the System > Software tab
  2. Update the package lists
  3. View available packages
  4. Type 'qos' in the filter without the quotes
  5. install luci-app-qos

Result:
After a minute or so, the following error text is served back to the browser:

/usr/lib/lua/luci/dispatcher.lua:449: Failed to execute call dispatcher target for entry '/admin/system/packages'.
The called action terminated with an exception:
/usr/lib/lua/luci/template.lua:105: Failed to execute template 'admin_system/packages'.
A runtime error occured: /usr/lib/lua/luci/ccache.lua:81: error loading module 'luci.tools.webadmin' from file '/usr/lib/lua/luci/tools/webadmin.lua':
	/usr/lib/lua/luci/tools/webadmin.lua: bad header in precompiled chunk
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:449: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

After this, /cgi-bin/luci returns totally empty HTTP responses, even after a reboot. In order to fix it, I have to reflash using sysupgrade, since I don't know how to debug the problem any further.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by anonymous

Installing from the command line shows that my system was subscribed to an old opkg repository version:

# opkg update
Downloading http://downloads.openwrt.org/backfire/10.03/brcm47xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/backfire/10.03/brcm47xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/packages.
# opkg install luci-app-qos
Installing luci-app-qos (0.9.0-1) to root...
Downloading http://downloads.openwrt.org/backfire/10.03/brcm47xx/packages/luci-app-qos_0.9.0-1_brcm47xx.ipk.
Installing luci-core (0.9.0-1) to root...
Downloading http://downloads.openwrt.org/backfire/10.03/brcm47xx/packages/luci-core_0.9.0-1_brcm47xx.ipk.
Collected errors:
 * check_data_file_clashes: Package luci-core wants to install file /usr/lib/lua/luci/ip.lua
	But that file is already provided by package  * luci-lib-core
 * check_data_file_clashes: Package luci-core wants to install file /usr/lib/lua/luci/debug.lua
	But that file is already provided by package  * luci-lib-core
[...]

I'm guessing that the web interface tells opkg to ignore these errors and install anyway, resulting in a broken system. It would also be nice if the upgrade process were to update old versions of the OpenWRT repository URL in /etc/opkg.conf, to avoid this being an issue. Perhaps this bug should be split into two, to handle each of these issues.

comment:2 Changed 6 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

There is nothing left to fix for us. opkg.conf is not marked as config file anymore and a simple reset to defaults will fix this issue too. Alternatively you can manually fixup opkg.conf after restoring old backups to make sure it points to the correct repo.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.