Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10850 closed enhancement (fixed)

mount related errors at boot: mount: mounting /dev/mtdblock0 on /mnt/mtdblock0 failed: Invalid argument

Reported by: hnyman <hannu.nyman@…> Owned by: cshore
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: fstab mount mtdblock Cc: hannu.nyman@…

Description

After updating to the newest trunk version (29890), I noticed that system log contains errors related to fstab/mount of mtdblocks. Additionally, /mnt directory has 6 empty subdirectories /mnt/mtdblock0 , mtdblock1, ...

The errors and the empty directories were not present with previous firmware (29844).

The errors materialized both with initial boot and with subsequent boots.

This is ar71xx/WNDR3700 firmware built with default kernel 2.6.39.4 and generally rather default options. Both builds done after make dirclean, so the build system should be clean.

Jan 24 18:44:05 OpenWrt kern.debug kernel: [   39.110000] ar71xx: pll_reg 0xb8050010: 0x11110000
Jan 24 18:44:05 OpenWrt kern.info kernel: [   39.110000] eth0: link up (1000Mbps/Full duplex)
Jan 24 18:44:06 OpenWrt kern.info kernel: [   39.460000] ADDRCONF(NETDEV_UP): eth1: link is not ready
Jan 24 18:44:06 OpenWrt user.notice ifup: Enabling Router Solicitations on loopback (lo)
Jan 24 18:44:09 OpenWrt user.notice fstab: mount: mounting /dev/mtdblock0 on /mnt/mtdblock0 failed: Invalid argument
Jan 24 18:44:09 OpenWrt kern.debug kernel: [   42.710000] ar71xx: pll_reg 0xb8050014: 0x11110000
Jan 24 18:44:09 OpenWrt kern.info kernel: [   42.710000] eth1: link up (1000Mbps/Full duplex)
Jan 24 18:44:09 OpenWrt kern.info kernel: [   42.710000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Jan 24 18:44:09 OpenWrt kern.info kernel: [   42.850000] cfg80211: Calling CRDA for country: FI
Jan 24 18:44:09 OpenWrt user.notice fstab: mount: mounting /dev/mtdblock1 on /mnt/mtdblock1 failed: Invalid argument
Jan 24 18:44:10 OpenWrt user.notice fstab: mount: mounting /dev/mtdblock2 on /mnt/mtdblock2 failed: Invalid argument
Jan 24 18:44:10 OpenWrt user.notice fstab: mount: mounting /dev/mtdblock3 on /mnt/mtdblock3 failed: Device or resource busy
Jan 24 18:44:11 OpenWrt kern.info kernel: [   44.680000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 24 18:44:11 OpenWrt kern.info kernel: [   44.710000] device wlan0 entered promiscuous mode
Jan 24 18:44:11 OpenWrt user.notice fstab: mount: mounting /dev/mtdblock5 on /mnt/mtdblock5 failed: Invalid argument
Jan 24 18:44:11 OpenWrt user.notice fstab: mount: mounting /dev/mtdblock6 on /mnt/mtdblock6 failed: Invalid argument
Jan 24 18:44:11 OpenWrt kern.debug kernel: [   45.080000] ar71xx-wdt: enabling watchdog timer
Jan 24 18:44:12 OpenWrt user.notice ifup: Enabling Router Solicitations on loopback (lo)

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by hnyman <hannu.nyman@…>

The error materialized also with the next build, 29910, so it was not an one-time bug.

It has also materialized with Arokh's wndr3700 build, so it isn't related to just my build.

comment:2 Changed 6 years ago by alphasparc@…

I believe as a result of this bug configuration files in /etc/config are not obeyed
Eg. I set dropbear to listen on other ports for root and disable root login for port 22 but the router does not obey that setting unless I restart dropbear service.

comment:3 Changed 6 years ago by hnyman <hannu.nyman@…>

I think I have narrowed the regression range down:

r29860 does not produce the error, but the version built with r29862 does produce that error.

Of the two changesets r29861 and r29862, r29862 sounds like a more probable suspect for the reason of those error messages. If I understand the change correctly, it makes some of the hotplug triggers to re-run.
/changeset/29862.html

comment:4 Changed 6 years ago by hnyman <hannu.nyman@…>

I tested with reversing the change made by r29862 , and the extra directories and the error disappear.

comment:5 Changed 6 years ago by nbd

Why would the 'fstab' thing even attempt to mount mtdblock* - that makes no sense

comment:6 Changed 6 years ago by jow

Because it attmepts to automount each appearing block device, that was previously no issue since mtd* was missed by coldplug, now it seems block-mount needs some filtering for it.

It is understandable insofar as that the mount support cannot differentiate between block devices that make sense (sda, hda, vda, xvda, ...) and ones that don't make sense (mtd)

comment:7 Changed 6 years ago by jow

  • Owner changed from developers to cshore
  • Status changed from new to assigned
  • Type changed from defect to enhancement

Another thing to note is that the above error messages do not indicate any issue or new problem, they just reflect the failed mount attempts for the various enumerated mtdblock devices. If you'd insert an usb drive with an unrecognized file system you'd see a similar error in dmesg. That said I do not think that any action is required here, its also certainly not required to revert something. At most this is a cosmetic issue which might get addressed in block-mount eventually (for example with a case switch that only lets through "sane" device name patterns).

Due to this I make this ticket an enhancement request and assign it to cshore for consideration.

comment:8 Changed 6 years ago by cshore

  • Status changed from assigned to accepted

I'm hoping to to have time to work on this and the uuid thing sometime in the next month (i.e. now to mid-March), along with some of the other outstanding things on my plate.

Jow, could I ask you the huge favour of reminding of the various things you've asked me to do (if you could drop me an email it would be great). I think I'm forgotten some of them and I think I owe you some time (and Philip the sysupgrade for x86).

comment:9 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed in r30501

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.