Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10849 closed defect (duplicate)

ddns-script premature update

Reported by: anonymous Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: 10.03.1
Keywords: ddns, fail Cc:

Description

I am running backfire 10.3.01 on a netgear wndr3700V2, and I found the following problem.
ddns-script when detects a new IP on the WAN interface, first it updates its internal variable and then it attempts connection with dyndns. As a result, when the update fails, openwrt continues thinking that the update was made and thus there is no need to update the IP.

/usr/lib/ddns/dynamic_dns_updater.sh myddns
update_url=http://[USERNAME]:[PASSWORD]@members.dyndns.org/nic/update?hostname=[DOMAIN]&myip=[IP]
force seconds = 25920000
check seconds = 15
old process id (if it exists) = ""
time_since_update = 0 hours
Running IP check...
current system ip = 79.166.x.x
registered domain ip = 94.68.x.x
update necessary, performing update ...
updating with url="http://user:password@members.dyndns.org/nic/update?hostname=user.dyndns.org&myip=79.166.x.x"
--2012-01-23 19:44:33--  http://user:*password*@members.dyndns.org/nic/update?hostname=user.dyndns.org&myip=79.166.x.x
Resolving members.dyndns.org... 204.13.248.111
Connecting to members.dyndns.org|204.13.248.111|:80... failed: No route to host.
Update Output:


update complete, time is: Mon Jan 23 19:44:36 EET 2012
Running IP check...
current system ip = 79.166.x.x
registered domain ip = 79.166.x.x
update unnecessary

As you can see, even though Connecting to members.dyndns.org failed, the script updated the registered domain ip variable and then went to sleep.

Solution: postpone ip variable update until after ddns provider was successfully updated and introduce a second check cycle that acquire clients ip from the DNS.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #10848.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.