Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10840 closed defect (worksforme)

router blocks completely on boot (wifi/external RADIUS not available)

Reported by: alain Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

When the router is powered up, if wifi is configured to use RADIUS (external server on wan/lan) and this machine is unavailable for some reason, then the router cannot boot!

For example, if I have the following as part of my /etc/config/wireless:

option auth_server 10.1.1.2
option auth_port 1812
option auth_secret 'whatever'
option acct_server 10.1.1.2
option acct_port 2813
option acct_secret 'whatever'

and that machine is unavailable when the router powers up, then wifi does NOT start and the router is completely blocked (the SYS led is flashing continuously).

When I disable the wifi (option disabled 1) after booting into failsafe mode, the router boots up normally (without the wifi, obviously).

When I then re-enable wifi (option disabled 0) and execute "wifi" I am getting the following errors:

Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr xx:xx:xx:xx:xx:xx and ssid 'whatever'
socket[PF_INET6,SOCK_DGRAM]: Address family not supported by protocol
wlan0: RADIUS Authentication server 10.1.1.2:1812
socket[PF_INET6,SOCK_DGRAM]: Address family not supported by protocol
wlan0: RADIUS Accounting server 10.1.1.2:1813
random: Only 15/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations
WPA: Not enough entropy in random pool for secure operations - update keys later when the first station connects
recv[RADIUS]: Connection refused
recv[RADIUS]: Connection refused
recv[RADIUS]: Connection refused
recv[RADIUS]: Connection refused
[...ad infinitum...]

I presume this is what happens during power up which blocks the router completely!

The wifi script should be amended so that it exits - gracefully - with the appropriate message in the syslog shown up.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by alain

I've posted this yesterday, but found the cause of the problem - I did some debugging on the wireless over the weekend and when editing mac8011.sh I did not restore the hostapd options properly (missed the "-B" option) and that is the reason for the wireless to "hang" (it was actually running in foreground). Could you close this please - sorry for the noise!

comment:2 Changed 6 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.