Modify

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#10838 closed defect (worksforme)

WRT150N incorrect MAC addresses assigned to wan and lan interfaces

Reported by: kwestarz@… Owned by: hauke
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Lan interface gets wan MAC and wan gets wan MAC + 1, it causes problems with wireless network (b43), wlan0 and mon.wlan0 have different MACs, network is visible but clients can't connect. When lan MAC is changed to mon.wlan0 MAC, wireless work without any problems.

ifconfig:

br-lan    Link encap:Ethernet  HWaddr 00:1D:7E:3C:5D:69  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:495 errors:0 dropped:0 overruns:0 frame:0
          TX packets:465 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:36152 (35.3 KiB)  TX bytes:119441 (116.6 KiB)

eth0      Link encap:Ethernet  HWaddr 00:1D:7E:3C:5D:69  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2765 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2601 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:255774 (249.7 KiB)  TX bytes:634469 (619.5 KiB)
          Interrupt:4 

eth1      Link encap:Ethernet  HWaddr 00:1D:7E:3C:5D:6A  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:134 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:54538 (53.2 KiB)
          Interrupt:5 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3024 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3024 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:206304 (201.4 KiB)  TX bytes:206304 (201.4 KiB)

mon.wlan0 Link encap:UNSPEC  HWaddr 00-88-88-88-00-2A-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:851 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:77868 (76.0 KiB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1D:7E:3C:5D:69  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

nvram:

boardnum=42
boot_ver=v4.5
mfg_wait=on
pci/1/1/pa2gw2a0=0
pci/1/1/pa2gw2a1=0
sdram_ncdl=0x208
pci/1/1/bwduppo=0
boot_hw_ver=1.1
pci/1/1/pa2gw3a0=0
pci/1/1/pa2gw3a1=0
parkid=0
et1mdcport=0
pci/1/1/rxchain=3
pci/1/1/ag0=2
pci/1/1/ag1=2
pci/1/1/txchain=3
pci/1/1/mcs2gpo4=0
sdram_config=0x0022
pci/1/1/mcs2gpo5=0
pci/1/1/mcs2gpo6=0
pci/1/1/mcs2gpo7=0
pci/1/1/mcs2gpo0=0
pci/1/1/mcs2gpo1=0
pci/1/1/mcs2gpo2=0
pci/1/1/mcs2gpo3=0
pci/1/1/ofdm2gpo=0
pci/1/1/boardflags2=0x0000
pci/1/1/itt2ga0=0
pci/1/1/itt2ga1=0
pci/1/1/bw40po=0
lan_netmask=255.255.255.0
sromrev=2
et0macaddr=00:1d:7e:3c:5d:69
os_ram_addr=80001000
pci/1/1/stbcpo=0
et1phyaddr=4
pci/1/1/cck2gpo=0
pci/1/1/macaddr=00:88:88:88:00:2a
cardbus=1
dl_ram_addr=a0001000
sdram_init=0x0553
boot_hw_model=WRT150N
et0phyaddr=30
boardflags=0x0010
lan_ipaddr=192.168.1.1
clkfreq=264
pci/1/1/maxp2ga0=0
pci/1/1/maxp2ga1=0
tftpd_ipaddr=192.168.1.254
pci/1/1/venid=0x14e4
wait_time=3
blink_diag_led=1
boardtype=0x0472
et1macaddr=00:88:88:88:00:2a
pci/1/1/ccdpo=0
pmon_ver=CFE 4.151.10.5
boot_wait=off
bootnv_ver=5
boardrev=0x11
opo=0x0
pci/1/1/regrev=0
pci/1/1/devid=0x4329
pci/1/1/ccode=0
pci/1/1/leddc=0xffff
diag_gpio=1
sdram_refresh=0x0
pci/1/1/antswitch=0
pci/1/1/aa2g=3
scratch=a0180000
pci/1/1/ledbh0=8
pci/1/1/ledbh1=-1
pci/1/1/ledbh2=-1
pci/1/1/ledbh3=-1
pci/1/1/boardtype=0x46d
pci/1/1/boardrev=0x4b
pci/1/1/sromrev=4
pci/1/1/boardvendor=0x14e4
pci/1/1/boardflags=0x200
pci/1/1/pa2gw0a1=0
pci/1/1/txpt2g=0x36
pci/1/1/pa2gw0a0=0
pci/1/1/txpid2ga0=91
pci/1/1/txpid2ga1=91
os_flash_addr=bfc40000
et0mdcport=0
watchdog=5000
pci/1/1/pa2gw1a0=0
pci/1/1/pa2gw1a1=0

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by kwestarz@…

Looks like I messed up things with MACs above, below MAC addresses from orginal firmware:
lan: et0macaddr from nvram
wan: et0macaddr+1
wlan: et0macaddr+2
MAC for lan and wan in OpenWRT is correct but WIFI MAC/connection issue still open.

comment:2 Changed 6 years ago by roysjosh@…

"me too" but with a wrt160n v1.1 on r29957. The only MAC that is incorrect is wlan0 which ends up as 00:88:88:88:00:2a.

# nvram show | grep mac
et0macaddr=00:1d:7e:XX:YY:6c
pci/1/1/macaddr=00:88:88:88:00:2a
et1macaddr=00:88:88:88:00:2a
# cat /sys/class/ieee80211/phy0/macaddress
00:88:88:88:00:2a

comment:3 Changed 6 years ago by roysjosh@…

Some searching around indicates that dd-wrt is probably at fault for killing my MAC address. I had flashed to that first, got frustrated, then flashed OpenWRT. It would be interesting to see if the OP also is coming from dd-wrt or a derivative of it.

comment:4 Changed 6 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to accepted

comment:5 Changed 5 years ago by hauke

Does someone has the code with the changes dd-wrt does to the nvram for this device? If it is possible to detect this and reverse it it would be nice.

comment:6 Changed 4 years ago by hauke

  • Resolution set to worksforme
  • Status changed from accepted to closed

This seams to be a problem being caused by DD-wrt changing the nvram to something wrong, please reset the nvram to the default values using the vendor firmware if you have such a problem.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.