Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10817 closed defect (fixed)

Router DHCP not giving out IP Addresses

Reported by: alphasparc@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Router model TP-Link WR1043ND Version 1.0 DE
When the Router is rebooted with the client connected via Ethernet Cable the Router does not give out IP Addresses to the client.
No connection is established.
The Trunk is image is pre-compiled with the RTL8366RB switch driver installed.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by alphasparc@…

Not sure if this could be the fault but ACK timeout was received on dmesg.
Realtek RTL8366RB ethernet switch driver version 0.2.3
[ 0.620000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[ 0.620000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[ 0.630000] rtl8366rb rtl8366rb: ACK timeout
[ 0.680000] rtl8366rb: probed

comment:2 Changed 6 years ago by alphasparc@…

The issue is that sometimes when both machines are rebooted it works but sometimes it works but sometimes it does not.

comment:3 Changed 6 years ago by alphasparc@…

I managed to workaround the problem by checking 'force' on lan interface, previously there was no need to check 'force' but the dmesg seems to generate a lot of
rtl8366rb rtl8366rb: ACK timeout messages.

comment:4 Changed 6 years ago by anonymous

Noticed changeset 29844, updated Trunk.
That fixed it, no more ack timeout messages in the log and DHCP gives out IP Addresses without having to 'force' it.

comment:5 Changed 6 years ago by juhosg

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r29844.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.