Modify

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#10806 closed defect (fixed)

Pulseaudio reports 0 available sound cards, and fails to start

Reported by: fffredd Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: pulseaudio udev Cc:

Description

Hello,

According to the previous bugreport, I installed udev, but still can't start pulsaudio. I haven't touched the system.pa file at the moment. I have the folowing console output:

root@OpenWrt:~# pulseaudio --system -vvvvvvvvvv
W: [pulseaudio] main.c: Running in system mode, but --disallow-exit not set!
W: [pulseaudio] main.c: Running in system mode, but --disallow-module-loading not set!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling SHM mode!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling exit idle time!
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: setpriority() worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: Found user 'pulse' (UID 51) and group 'pulse' (GID 51).
I: [pulseaudio] main.c: Successfully dropped root privileges.
I: [pulseaudio] main.c: This is PulseAudio 1.1
D: [pulseaudio] main.c: Compilation host: armeb-openwrt-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves -fhonour-copts -msoft-float -I/home/openwrt/slave/ixp4xx/build/staging_dir/target-armeb_v5te_uClibc-0.9.32/usr/lib/libiconv-stub/include -I/home/openwrt/slave/ixp4xx/build/staging_dir/target-armeb_v5te_uClibc-0.9.32/usr/lib/libintl-stub/include -std=gnu99  -Wall -W -Wextra -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux armv5teb 2.6.37.6 #1 Mon Jan 16 03:22:49 MST 2012
D: [pulseaudio] main.c: Found 1 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: All asserts enabled.
I: [pulseaudio] main.c: Machine ID is 5b69782a75dc4e3a37c7cbf400000107.
I: [pulseaudio] main.c: Using runtime directory /var/run/pulse.
I: [pulseaudio] main.c: Using state directory /var/lib/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-1.1/modules.
I: [pulseaudio] main.c: Running in system mode: yes
W: [pulseaudio] main.c: OK, so you are running PA in system mode. Please note that you most likely shouldn't be doing that.
W: [pulseaudio] main.c: If you do it nonetheless then it's your own fault if things don't work as expected.
W: [pulseaudio] main.c: Please read http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode for an explanation why system mode is usually a bad idea.
W: [pulseaudio] pid.c: Stale PID file, overwriting.
I: [pulseaudio] main.c: Fresh high-resolution timers available! Bon appetit!
D: [pulseaudio] memblock.c: Using private memory pool with 1024 slots of size 4.0 KiB each, total size is 4.0 MiB, maximum usable slot size is 4056
I: [pulseaudio] cpu-arm.c: CPU flags: EDSP 
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-1.1/modules/module-udev-detect.so': success
'''I: [pulseaudio] module-udev-detect.c: Found 0 cards.'''
I: [pulseaudio] module.c: Loaded "module-udev-detect" (index: #0; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-1.1/modules/module-esound-protocol-unix.so': success
I: [pulseaudio] module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: [pulseaudio] module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: [pulseaudio] module-stream-restore.c: Successfully opened database file '/var/lib/pulse/5b69782a75dc4e3a37c7cbf400000107-stream-volumes'.
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 added for object /org/pulseaudio/stream_restore1
I: [pulseaudio] module.c: Loaded "module-stream-restore" (index: #3; argument: "").
I: [pulseaudio] module-device-restore.c: Successfully opened database file '/var/lib/pulse/5b69782a75dc4e3a37c7cbf400000107-device-volumes'.
I: [pulseaudio] module.c: Loaded "module-device-restore" (index: #4; argument: "").
I: [pulseaudio] module.c: Loaded "module-default-device-restore" (index: #5; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-1.1/modules/module-dbus-protocol.so': success
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Memstats added for object /org/pulseaudio/core1/memstats
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Module added for object /org/pulseaudio/core1/module0
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Module added for object /org/pulseaudio/core1/module1
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Module added for object /org/pulseaudio/core1/module2
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Module added for object /org/pulseaudio/core1/module3
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Module added for object /org/pulseaudio/core1/module4
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1.Module added for object /org/pulseaudio/core1/module5
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Core1 added for object /org/pulseaudio/core1
I: [pulseaudio] module.c: Loaded "module-dbus-protocol" (index: #6; argument: "access=local").
I: [pulseaudio] module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: [pulseaudio] module-always-sink.c: Autoloading null-sink as no other sinks detected.
E: [pulseaudio] sink.c: Assertion '!pa_thread_mq_get()' failed at pulsecore/sink.c:203, function pa_sink_new(). Aborting.
Aborted

I have avahi deamon, dbus daemon and udevd running in background.
Playing sound works fine with another sound stack though:

root@OpenWrt:~# wget -q -O - http://broadcast.infomaniak.net/radionova-high.mp3 | madplay -

I also tried to get debugging informations with udevadm, when unplugging and plugging the usb sound card:

root@OpenWrt:~# udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[2839.814332] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/mixer (sound)
UDEV  [2839.814952] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/mixer (sound)
KERNEL[2839.815402] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/dsp (sound)
KERNEL[2839.815790] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/audio (sound)
KERNEL[2839.816177] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/pcmC0D0p (sound)
KERNEL[2839.816567] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/controlC0 (sound)
KERNEL[2839.816909] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0 (sound)
KERNEL[2839.817304] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0 (usb)
KERNEL[2839.817725] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.1 (usb)
KERNEL[2839.818138] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.2 (usb)
KERNEL[2839.818619] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1 (usb)
UDEV  [2839.826411] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/dsp (sound)
UDEV  [2839.831737] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/audio (sound)
UDEV  [2839.845973] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/pcmC0D0p (sound)
UDEV  [2839.850536] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/controlC0 (sound)
UDEV  [2839.855627] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.1 (usb)
UDEV  [2839.863843] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0 (sound)
UDEV  [2839.873387] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.2 (usb)
UDEV  [2839.876443] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0 (usb)
UDEV  [2839.883562] remove   /devices/pci0000:00/0000:00:01.0/usb2/2-1 (usb)
KERNEL[2844.366259] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1 (usb)
KERNEL[2844.377764] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0 (usb)
KERNEL[2844.452355] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0 (sound)
KERNEL[2844.452812] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/pcmC0D0p (sound)
KERNEL[2844.453204] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/dsp (sound)
KERNEL[2844.453592] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/audio (sound)
KERNEL[2844.453990] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/controlC0 (sound)
KERNEL[2844.454388] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/mixer (sound)
KERNEL[2844.454809] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.1 (usb)
KERNEL[2844.455231] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.2 (usb)
UDEV  [2844.502602] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1 (usb)
UDEV  [2844.509228] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.1 (usb)
UDEV  [2844.516699] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0 (usb)
UDEV  [2844.534712] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0 (sound)
UDEV  [2844.547781] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/dsp (sound)
UDEV  [2844.555821] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/pcmC0D0p (sound)
UDEV  [2844.579222] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/controlC0 (sound)
UDEV  [2844.606804] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/audio (sound)
UDEV  [2844.608925] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.2 (usb)
UDEV  [2844.615094] add      /devices/pci0000:00/0000:00:01.0/usb2/2-1/2-1:1.0/sound/card0/mixer (sound)
root@OpenWrt:~# lsmod
Module                  Size  Used by    Tainted: P  
usb_storage            32400  0 
snd_usb_audio          63364  0 
snd_usbmidi_lib        12580  1 snd_usb_audio
ohci_hcd               16276  0 
ath_pci               278104  0 
ath_hal               267884  1 ath_pci
nf_nat_irc               736  0 
nf_conntrack_irc        2364  1 nf_nat_irc
nf_nat_ftp               960  0 
nf_conntrack_ftp        4316  1 nf_nat_ftp
ipt_MASQUERADE           868  1 
iptable_nat             2368  1 
nf_nat                  9382  4 nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
xt_conntrack            1740  3 
xt_CT                   1092  0 
xt_NOTRACK               460  0 
iptable_raw              536  1 
xt_state                 596  0 
nf_conntrack_ipv4       4312  6 iptable_nat,nf_nat
nf_defrag_ipv4           608  1 nf_conntrack_ipv4
nf_conntrack           36060 12 nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_conntrack,xt_CT,xt_NOTRACK,xt_state,nf_conntrack_ipv4
ehci_hcd               35276  0 
sd_mod                 21800  0 
pppoe                   6688  0 
pppox                    948  1 pppoe
ipt_REJECT              1484  2 
xt_TCPMSS               2204  0 
ipt_LOG                 5644  0 
xt_comment               380  0 
xt_multiport            1136  0 
xt_mac                   524  0 
xt_limit                1084  1 
iptable_mangle           692  1 
iptable_filter           608  1 
ip_tables               8004  4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp               1556  3 
x_tables                8736 18 ipt_MASQUERADE,iptable_nat,xt_conntrack,xt_CT,xt_NOTRACK,iptable_raw,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,iptable_mangle,iptable_filter,ip_tables,xt_tcpudp
msdos                   5220  0 
snd_pcm_oss            29628  0 
snd_mixer_oss          10996  1 snd_pcm_oss
snd_pcm                46272  2 snd_usb_audio,snd_pcm_oss
snd_timer              13688  1 snd_pcm
snd_rawmidi            12764  1 snd_usbmidi_lib
snd_seq_device          3624  1 snd_rawmidi
snd_hwdep               3784  1 snd_usb_audio
snd_page_alloc          3856  1 snd_pcm
snd                    32844  9 snd_usb_audio,snd_usbmidi_lib,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device,snd_hwdep
soundcore               3340  1 snd
ppp_async               5592  0 
ppp_generic            17680  3 pppoe,pppox,ppp_async
slhc                    3832  1 ppp_generic
vfat                    7520  0 
fat                    39600  2 msdos,vfat
ntfs                   96372  0 
nls_iso8859_1           2780  0 
usbcore                91116  6 usb_storage,snd_usb_audio,snd_usbmidi_lib,ohci_hcd,ehci_hcd
scsi_mod               64580  2 usb_storage,sd_mod
nls_base                4384  5 vfat,fat,ntfs,nls_iso8859_1,usbcore
crc_ccitt                880  1 ppp_async
input_core             17572  1 snd

I don't know where else to look. My devide is an nslu2 with the trunk (16/01) openwrt firmware.

Thanks for your help.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by loswillios

E: [pulseaudio] sink.c: Assertion '!pa_thread_mq_get()' failed at pulsecore/sink.c:203, function pa_sink_new(). Aborting.

This is a known problem. Unfortunately I have no idea how to solve it. It was suggested that missing TLS Support might have something to do with it. But that might only be a shot in the dark.

You can check build_dir/target-arm_v5te_uClibc-0.9.32_eabi/pulseaudio-avahi/pulseaudio-1.1/config.log for further infos.

comment:2 Changed 6 years ago by fffredd

After digging into the matter, I managed to observe a few other weird details.
I'm using PA on a nslu2, and there might be problems with the build for this platform.

Linux OpenWrt 2.6.37.6 #1 Mon Jan 16 03:22:49 MST 2012 armv5teb GNU/Linux
openwrt-trunk  objdump -t ./staging_dir/target-armeb_v5te_uClibc-0.9.32/root-ixp4xx/usr/bin/pulseaudio | grep UND
0000b1a0       F *UND*	00000000              pa_pid_file_check_running
0000b1ac       F *UND*	00000000              pa_fopen_cloexec
0000b1b8       F *UND*	00000000              sysconf
0000b1c4       F *UND*	00000000              pa_in_system_mode
0000b1d0       F *UND*	00000000              pa_cpu_init_orc
0000b1dc       F *UND*	00000000              pa_make_path_absolute
0000b1e8       F *UND*	00000000              pa_strbuf_puts
0000b1f4       F *UND*	00000000              __errno_location
0000b200       F *UND*	00000000              pa_path_get_filename@@PULSE_0
0000b20c       F *UND*	00000000              pa_client_conf_env
0000b218       F *UND*	00000000              lt_dlpreload_default
0000b224       F *UND*	00000000              getenv
0000b230       F *UND*	00000000              pa_loop_write
0000b23c       F *UND*	00000000              __aeabi_dmul@@GCC_3.5
0000b248       F *UND*	00000000              pa_autospawn_lock_done
0000b254       F *UND*	00000000              pa_unblock_sigs
0000b260       F *UND*	00000000              memcpy
0000b26c       F *UND*	00000000              pa_mainloop_new@@PULSE_0
0000b278       F *UND*	00000000              pa_rtclock_hrtimer_enable
00000000  w      *UND*	00000000              _Jv_RegisterClasses
0000b284       F *UND*	00000000              lt_dlloader_find
0000b290       F *UND*	00000000              pa_client_conf_load
0000b29c       F *UND*	00000000              pa_pipe_cloexec
0000b2a8       F *UND*	00000000              dbus_shutdown
0000b2b4       F *UND*	00000000              pa_stdio_acquire
0000b2c0       F *UND*	00000000              getegid
0000b2cc       F *UND*	00000000              putchar
0000b2d8       F *UND*	00000000              pa_log_set_ident
0000b2e4       F *UND*	00000000              dbus_message_new_method_return
0000b2f0       F *UND*	00000000              strspn
0000b2fc       F *UND*	00000000              dbus_error_init
0000b308       F *UND*	00000000              pa_channel_map_parse@@PULSE_0
0000b314       F *UND*	00000000              pa_make_fd_nonblock
0000b320       F *UND*	00000000              prctl
0000b32c       F *UND*	00000000              setreuid
0000b338       F *UND*	00000000              dbus_message_iter_close_container
0000b344       F *UND*	00000000              pa_modinfo_free
0000b350       F *UND*	00000000              pa_resample_method_supported
0000b35c       F *UND*	00000000              dbus_error_is_set
0000b368       F *UND*	00000000              sched_get_priority_max
0000b374       F *UND*	00000000              dbus_connection_send
0000b380       F *UND*	00000000              pa_log_set_show_backtrace
0000b38c       F *UND*	00000000              pa_machine_id
0000b398       F *UND*	00000000              malloc
0000b3a4       F *UND*	00000000              pa_xfree@@PULSE_0
0000b3b0       F *UND*	00000000              strrchr
0000b3bc       F *UND*	00000000              pa_realpath
0000b3c8       F *UND*	00000000              pa_reset_sigs
0000b3d4       F *UND*	00000000              strncmp
0000b3e0       F *UND*	00000000              pa_runtime_path
0000b3ec       F *UND*	00000000              lt_dlexit
0000b3f8       F *UND*	00000000              __uClibc_main
0000b404       F *UND*	00000000              pa_idxset_size
0000b410       F *UND*	00000000              pa_strbuf_new
0000b41c       F *UND*	00000000              pa_cpu_init_arm
0000b428       F *UND*	00000000              dlsym
0000b434       F *UND*	00000000              pa_rtclock_hrtimer
0000b440       F *UND*	00000000              dbus_message_unref
0000b44c       F *UND*	00000000              pa_config_parse_bool
0000b458       F *UND*	00000000              pa_config_parse_not_bool
0000b464       F *UND*	00000000              strlen
0000b470       F *UND*	00000000              dbus_bus_request_name
0000b47c       F *UND*	00000000              pa_shm_cleanup
0000b488       F *UND*	00000000              getrusage
0000b494       F *UND*	00000000              sched_get_priority_min
0000b4a0       F *UND*	00000000              pa_close_all
0000b4ac       F *UND*	00000000              pa_config_parse_unsigned
0000b4b8       F *UND*	00000000              lt_dlforeachfile
0000b4c4       F *UND*	00000000              pa_scache_free_all
0000b4d0       F *UND*	00000000              pa_channel_map_snprint@@PULSE_0
0000b4dc       F *UND*	00000000              execv
0000b4e8       F *UND*	00000000              pa_log_level_meta
0000b4f4       F *UND*	00000000              initgroups
0000b500       F *UND*	00000000              lt_dlloader_add
0000b50c       F *UND*	00000000              pa_autospawn_lock_acquire
0000b518       F *UND*	00000000              pa_config_parse_string
0000b524       F *UND*	00000000              pa_pid_file_create
0000b530       F *UND*	00000000              pa_xstrdup@@PULSE_0
0000b53c       F *UND*	00000000              pa_ncpus
0000b548       F *UND*	00000000              pa_autospawn_lock_init
0000b554       F *UND*	00000000              pa_strbuf_printf
0000b560       F *UND*	00000000              fclose
0000b56c       F *UND*	00000000              pa_config_parse
0000b578       F *UND*	00000000              pa_mainloop_get_api@@PULSE_0
0000b584       F *UND*	00000000              pa_strlcpy
0000b590       F *UND*	00000000              pa_get_state_dir
0000b59c       F *UND*	00000000              pa_xmemdup@@PULSE_0
0000b5a8       F *UND*	00000000              pa_object_unref
0000b5b4       F *UND*	00000000              pa_sample_format_to_string@@PULSE_0
0000b5c0       F *UND*	00000000              pa_client_conf_free
0000b5cc       F *UND*	00000000              pa_cli_command_execute_file_stream
0000b5d8       F *UND*	00000000              pa_module_unload_all
0000b5e4       F *UND*	00000000              pa_dbus_connection_unref
0000b5f0       F *UND*	00000000              pa_config_parse_int
0000b5fc       F *UND*	00000000              dbus_message_get_interface
0000b608       F *UND*	00000000              pa_session_id
0000b614       F *UND*	00000000              getpwnam
0000b620       F *UND*	00000000              pa_find_config_file
0000b62c       F *UND*	00000000              setregid
0000b638       F *UND*	00000000              pa_init_i18n
0000b644       F *UND*	00000000              pa_raise_priority
0000b650       F *UND*	00000000              pa_get_runtime_dir
0000b65c       F *UND*	00000000              pa_mainloop_free@@PULSE_0
0000b668       F *UND*	00000000              pa_log_set_flags
0000b674       F *UND*	00000000              pa_client_conf_new
0000b680       F *UND*	00000000              pa_reset_priority
0000b68c       F *UND*	00000000              setsid
0000b698       F *UND*	00000000              pa_write
0000b6a4       F *UND*	00000000              pa_get_dbus_address_from_server_type
0000b6b0       F *UND*	00000000              sigaction
0000b6bc       F *UND*	00000000              pa_signal_init@@PULSE_0
0000b6c8       F *UND*	00000000              dbus_connection_register_object_path
0000b6d4       F *UND*	00000000              umask
0000b6e0       F *UND*	00000000              pa_atoi
0000b6ec       F *UND*	00000000              pa_atou
0000b6f8       F *UND*	00000000              pa_disable_sigpipe
0000b704       F *UND*	00000000              pa_reset_personality
0000b710       F *UND*	00000000              pa_strlist_free
0000b71c       F *UND*	00000000              pa_channel_map_init_extend@@PULSE_0
0000b728       F *UND*	00000000              fputs
0000b734       F *UND*	00000000              setuid
0000b740       F *UND*	00000000              pa_pid_file_remove
0000b74c       F *UND*	00000000              pa_nullify_stdfds
0000b758       F *UND*	00000000              pa_mainloop_run@@PULSE_0
0000b764       F *UND*	00000000              chdir
0000b770       F *UND*	00000000              dbus_message_has_member
0000b77c       F *UND*	00000000              pa_close
0000b788       F *UND*	00000000              pa_open_config_file
0000b794       F *UND*	00000000              dbus_message_new_error
0000b7a0       F *UND*	00000000              pa_cpu_init_x86
0000b7ac       F *UND*	00000000              memset
0000b7b8       F *UND*	00000000              pa_config_parse_size
0000b7c4       F *UND*	00000000              pa_parse_boolean
0000b7d0       F *UND*	00000000              pa_cli_command_execute
0000b7dc       F *UND*	00000000              pa_sig2str
0000b7e8       F *UND*	00000000              pa_strlist_pop
0000b7f4       F *UND*	00000000              getuid
0000b800       F *UND*	00000000              mlockall
0000b80c       F *UND*	00000000              pa_module_load
0000b818       F *UND*	00000000              abort
0000b824       F *UND*	00000000              pa_snprintf
0000b830       F *UND*	00000000              dbus_message_new_error_printf
0000b83c       F *UND*	00000000              sigemptyset
0000b848       F *UND*	00000000              pa_strbuf_tostring_free
0000b854       F *UND*	00000000              dbus_message_get_args
0000b860       F *UND*	00000000              dbus_message_iter_append_basic
0000b86c       F *UND*	00000000              pa_modinfo_get_by_name
0000b878       F *UND*	00000000              pa_parse_resample_method
0000b884       F *UND*	00000000              pa_loop_read
0000b890       F *UND*	00000000              dbus_message_iter_init_append
0000b89c       F *UND*	00000000              pa_cstrerror
0000b8a8       F *UND*	00000000              pa_set_env
0000b8b4       F *UND*	00000000              fork
0000b8c0       F *UND*	00000000              pa_startswith
0000b8cc       F *UND*	00000000              pa_parse_sample_format@@PULSE_0
0000b8d8       F *UND*	00000000              dbus_error_free
0000b8e4       F *UND*	00000000              pa_running_in_vm
0000b8f0       F *UND*	00000000              seteuid
0000b8fc       F *UND*	00000000              open64
0000b908       F *UND*	00000000              pa_autospawn_lock_release
0000b914       F *UND*	00000000              strcmp
0000b920       F *UND*	00000000              pa_set_env_and_record
0000b92c       F *UND*	00000000              pa_full_status_string
0000b938       F *UND*	00000000              pa_resample_method_to_string
0000b944       F *UND*	00000000              pa_unset_env_recorded
0000b950       F *UND*	00000000              pa_memtrap_install
0000b95c       F *UND*	00000000              pa_close_pipe
0000b968       F *UND*	00000000              dbus_connection_unregister_object_path
0000b974       F *UND*	00000000              pa_strlist_parse
0000b980       F *UND*	00000000              pa_core_new
0000b98c       F *UND*	00000000              setrlimit64
0000b998       F *UND*	00000000              free
0000b9a4       F *UND*	00000000              pa_log_set_level
0000b9b0       F *UND*	00000000              atoi
0000b9bc       F *UND*	00000000              pa_dbus_bus_get
0000b9c8       F *UND*	00000000              dbus_message_iter_open_container
0000b9d4       F *UND*	00000000              pa_random_seed
0000b9e0       F *UND*	00000000              pa_xmalloc@@PULSE_0
0000b9ec       F *UND*	00000000              getgid
0000b9f8       F *UND*	00000000              printf
0000ba04       F *UND*	00000000              getopt_long
0000ba10       F *UND*	00000000              getgrnam
0000ba1c       F *UND*	00000000              pa_readlink
0000ba28       F *UND*	00000000              pa_log_set_fd
0000ba34       F *UND*	00000000              __aeabi_ul2d@@GCC_3.5
0000ba40       F *UND*	00000000              lt_dlseterror
0000ba4c       F *UND*	00000000              setlocale
0000ba58       F *UND*	00000000              puts
0000ba64       F *UND*	00000000              pa_rtclock_now@@PULSE_0
0000ba70       F *UND*	00000000              pa_pid_file_kill
0000ba7c       F *UND*	00000000              dlopen
0000ba88       F *UND*	00000000              pa_uname_string
0000ba94       F *UND*	00000000              pa_dbus_connection_get
0000baa0       F *UND*	00000000              dbus_message_is_method_call
0000baac       F *UND*	00000000              setresgid
0000bab8       F *UND*	00000000              pa_log_set_target
0000bac4       F *UND*	00000000              getrlimit64
0000bad0       F *UND*	00000000              signal
0000badc       F *UND*	00000000              pa_make_secure_dir
0000bae8       F *UND*	00000000              lt_dlinit
0000baf4       F *UND*	00000000              __aeabi_dcmple@@GCC_3.5
0000bb00       F *UND*	00000000              dbus_message_get_type
0000bb0c       F *UND*	00000000              pipe
0000bb18       F *UND*	00000000              pa_signal_done@@PULSE_0
0000bb24       F *UND*	00000000              pa_signal_new@@PULSE_0
0000bb30       F *UND*	00000000              pa_read
0000bb3c       F *UND*	00000000              dlclose
0000bb48       F *UND*	00000000              pa_strbuf_free
0000bb54       F *UND*	00000000              geteuid
0000bb60       F *UND*	00000000              dbus_message_append_args
0000bb6c       F *UND*	00000000              lt_dlsetsearchpath

I discussed the matter on #pulseaudio and they are suggesting that the matter comes from libatomic_ops not being linked during the build. What is your opinion on this claim?

Thank you for your time.

comment:3 Changed 6 years ago by anonymous

You also mention that it is a known problem. Does that mean that it affects every platform at the moment, of only a subset, such as some variants of ARM ?

comment:4 Changed 4 years ago by tripolar

  • Resolution set to fixed
  • Status changed from new to closed

fixed in latest trunk

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.