Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10797 closed defect (fixed)

RTL8366RB not detected in latest trunk for WZR-HP-G300NH(

Reported by: AlfredGanz <alfred-ganz+openwrt@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: RTL8366RB WZR-HP-G300NH Cc:

Description

I have been trying to upgrade my WZR-HP-G300NH (the version with
the unannounced RTL8366RB switch) from snapshot r29507 to the
latest version of:
openwrt-ar71xx-generic-wzr-hp-g300nh-squashfs-sysupgrade.bin
I have tried direct sysupgrade from the current system, mtd -r write
from the original DD-WRT, as well as tftp installation. In each case
it seems that the RTL8366RB switch is not detected by the kernel.
With the direct sysupgrade (which provided a wireless configuration)
I was able to ssh into the router using the wlan and do some
looking around. In all other cases I was not able to reach the
router at all. Here are my observations:

  • Trying /etc/init.d/network restart fails, leaving a message saying that the switch was not found
  • looking at dmesg confirms that the switch was not found:

{{{[ 0.090000] NET: Registered protocol family 16

[ 0.090000] MIPS: machine is Buffalo WZR-HP-G300NH
[ 0.100000] (NULL device *): ACK timeout
[ 0.550000] bio: create slab <bio-0> at 0}}}

vs. the working system:

{{{[ 0.090000] NET: Registered protocol family 16

[ 0.090000] MIPS: machine is Buffalo WZR-HP-G300NH
[ 0.100000] Found an RTL8366RB switch
[ 0.550000] bio: create slab <bio-0> at 0}}}

and later looking for the wrong switch:

{{{[ 1.170000] eth0: Atheros AG71xx at 0xba000000, irq 5

[ 1.470000] eth0: unable to find MII bus on device 'rtl8366s'
[ 1.490000] Atheros AR71xx hardware watchdog driver

version 0.1.0}}}

vs. the working system again:

{{{[ 1.200000] eth1: Atheros AG71xx at 0xba000000, irq 5

[ 1.510000] eth1: connected to PHY at rtl8366rb:04

[uid=001cc961, driver=Generic PHY]

[ 1.510000] Atheros AR71xx hardware watchdog driver

version 0.1.0}}}

My question is, should I use a different upgrade binary, or am I
doing something wrong or has there been a regression?

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

Regression. Already fixed with r29732

comment:2 Changed 6 years ago by Alfred Ganz <alfred-ganz+openwrt@…>

Jow, I installed bleeding edge, r29763 and as you predicted, the problem is fixed.
There are the new timeout messages, but also as expected the switch is probed and
the interface is brought up.

Thanks for the fix, AG

comment:3 Changed 6 years ago by anonymous

Hello ,
I got this router too... tried latest bleeding edge, r29763 , i see issue with RTL8366RB. is this newest chip ?

[ 0.820000] Realtek RTL8366RB ethernet switch driver version 0.2.3
[ 0.830000] rtl8366rb rtl8366rb: using GPIO pins 19 (SDA) and 20 (SCK)
[ 0.830000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[ 0.840000] rtl8366rb rtl8366rb: ACK timeout
[ 0.890000] rtl8366rb: probed

comment:4 Changed 6 years ago by anonymous

Please ignore my last post, it was bad flash.. second time worked. Thanks

comment:5 Changed 6 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

same problem with tp wr1034nd r29839
netwerk and once again no network access

[ 0.610000] Realtek RTL8366RB ethernet switch driver version 0.2.3
[ 0.620000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[ 0.620000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[ 0.630000] rtl8366rb rtl8366rb: ACK timeout
[ 0.680000] rtl8366rb: probed

comment:6 Changed 6 years ago by anonymous

error rtl8366rb rtl8366rb: ACK timeout is no longer in r29871
network is ok thanks
error:
/# /etc/init.d/network restart
[ 129.610000] br-lan: port 1(eth0.1) entering forwarding state
[ 129.620000] device eth0 left promiscuous mode
[ 129.630000] device eth0.1 left promiscuous mode
[ 129.640000] br-lan: port 1(eth0.1) entering disabled state
[ 132.690000] device eth0.1 entered promiscuous mode
[ 132.700000] device eth0 entered promiscuous mode
/sbin/ifup: line 1: can't create /sys/devices/virtual/net/br-lan/bridge/multicast_snooping: nonexistent directory
[ 132.750000] br-lan: port 1(eth0.1) entering forwarding state
[ 132.750000] br-lan: port 1(eth0.1) entering forwarding state


/sbin/ifup: line 1: can't create /sys/devices/virtual/net/br-lan/bridge/multicast_snooping: nonexistent directory ???????????????????????????????????

comment:7 Changed 6 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Unrelated.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.